diff --git a/.gitignore b/.gitignore
index 857d868..7986276 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,3 +8,7 @@ libgpg-error-1.9.tar.bz2.sig
/libgpg-error-1.12.tar.bz2.sig
/libgpg-error-1.13.tar.bz2
/libgpg-error-1.13.tar.bz2.sig
+/libgpg-error-1.16.tar.bz2
+/libgpg-error-1.16.tar.bz2.sig
+/libgpg-error-1.17.tar.bz2
+/libgpg-error-1.17.tar.bz2.sig
diff --git a/libgpg-error-1.17-no-buildhost.patch b/libgpg-error-1.17-no-buildhost.patch
new file mode 100644
index 0000000..12fd8b7
--- /dev/null
+++ b/libgpg-error-1.17-no-buildhost.patch
@@ -0,0 +1,12 @@
+diff -up libgpg-error-1.17/src/gpg-error.h.in.no-buildhost libgpg-error-1.17/src/gpg-error.h.in
+--- libgpg-error-1.17/src/gpg-error.h.in.no-buildhost 2014-10-03 08:14:00.000000000 +0200
++++ libgpg-error-1.17/src/gpg-error.h.in 2015-01-30 16:30:38.345980993 +0100
+@@ -16,7 +16,7 @@
+ You should have received a copy of the GNU Lesser General Public
+ License along with this program; if not, see .
+
+- @configure_input@
++ Do not edit. Generated from gpg-error.h.in.
+ */
+
+
diff --git a/libgpg-error.spec b/libgpg-error.spec
index 31e5cde..30d3ad0 100644
--- a/libgpg-error.spec
+++ b/libgpg-error.spec
@@ -1,15 +1,17 @@
Summary: Library for error values used by GnuPG components
Name: libgpg-error
-Version: 1.13
-Release: 3%{?dist}
+Version: 1.17
+Release: 2%{?dist}
URL: ftp://ftp.gnupg.org/gcrypt/libgpg-error/
Source0: ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
Source1: ftp://ftp.gnupg.org/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2.sig
+Patch1: libgpg-error-1.17-no-buildhost.patch
Group: System Environment/Libraries
License: LGPLv2+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gawk, gettext, autoconf, automake, gettext-devel, libtool
+BuildRequires: texinfo
%if 0%{?fedora} > 13
BuildRequires: gettext-autopoint
%endif
@@ -25,6 +27,8 @@ pinentry, SmartCard Daemon and possibly more in the future.
Summary: Development files for the %{name} package
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires(pre): /sbin/install-info
+Requires(post): /sbin/install-info
%description devel
This is a library that defines common error values for all GnuPG
@@ -34,13 +38,13 @@ contains files necessary to develop applications using libgpg-error.
%prep
%setup -q
+%patch1 -p1 -b .no-buildhost
# The config script already suppresses the -L if it's /usr/lib, so cheat and
# set it to a value which we know will be suppressed.
sed -i -e 's|^libdir=@libdir@$|libdir=@exec_prefix@/lib|g;s|@GPG_ERROR_CONFIG_HOST@|none|g' src/gpg-error-config.in
-# We need a version of libtool that won't decide to add an rpath of /usr/lib64
-# even when we ask it not to.
-autoreconf -f -i
+# Modify configure to drop rpath for /usr/lib64
+sed -i -e 's|sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/lib /usr/lib %{_libdir}|g' configure
%build
%configure --disable-static --disable-rpath --disable-languages
@@ -50,36 +54,10 @@ make %{?_smp_mflags}
rm -fr $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
+rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
%find_lang %{name}
-# Relocate the shared libraries to /%{_lib}.
-mkdir -p $RPM_BUILD_ROOT/%{_lib}
-for shlib in $RPM_BUILD_ROOT/%{_libdir}/*.so* ; do
- if test -L "$shlib" ; then
- rm "$shlib"
- else
- mv "$shlib" $RPM_BUILD_ROOT/%{_lib}/
- fi
-done
-# Figure out where /%{_lib} is relative to %{_libdir}.
-touch $RPM_BUILD_ROOT/root_marker
-relroot=..
-while ! test -f $RPM_BUILD_ROOT/%{_libdir}/$relroot/root_marker ; do
- relroot=$relroot/..
-done
-# Overwrite development symlinks.
-pushd $RPM_BUILD_ROOT/%{_libdir}
-for shlib in $relroot/%{_lib}/lib*.so.* ; do
- shlib=`echo "$shlib" | sed -e 's,//,/,g'`
- target=`basename "$shlib" | sed -e 's,\.so.*,,g'`.so
- ln -sf $shlib $target
-done
-popd
-# Add the soname symlink.
-/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_lib}/
-rm -f $RPM_BUILD_ROOT/root_marker
-
%check
make check
@@ -90,13 +68,24 @@ rm -fr $RPM_BUILD_ROOT
%postun -p /sbin/ldconfig
+%post devel
+[ -f %{_infodir}/gpgrt.info.gz ] && \
+ /sbin/install-info %{_infodir}/gpgrt.info.gz %{_infodir}/dir
+exit 0
+
+%preun devel
+if [ $1 = 0 -a -f %{_infodir}/gpgrt.info.gz ]; then
+ /sbin/install-info --delete %{_infodir}/gpgrt.info.gz %{_infodir}/dir
+fi
+exit 0
+
%files -f %{name}.lang
%defattr(-,root,root)
%{!?_licensedir:%global license %%doc}
%license COPYING COPYING.LIB
%doc AUTHORS README NEWS ChangeLog
%{_bindir}/gpg-error
-/%{_lib}/libgpg-error.so.0*
+%{_libdir}/libgpg-error.so.0*
%files devel
%defattr(-,root,root)
@@ -104,8 +93,20 @@ rm -fr $RPM_BUILD_ROOT
%{_libdir}/libgpg-error.so
%{_includedir}/gpg-error.h
%{_datadir}/aclocal/gpg-error.m4
+%{_infodir}/gpgrt.info*
+%{_mandir}/man1/gpg-error-config.*
%changelog
+* Fri Jan 30 2015 Tomáš Mráz 1.17-2
+- do not conflict on header file between architectures (#1180857)
+
+* Thu Jan 29 2015 Tomáš Mráz 1.17-1
+- new upstream release
+
+* Fri Sep 19 2014 Tomáš Mráz 1.16-1
+- new upstream release
+- move from /lib to /usr/lib
+
* Sun Aug 17 2014 Fedora Release Engineering - 1.13-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
diff --git a/sources b/sources
index 948027b..e37af2f 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,2 @@
-fe0cfa7e15262ef8fdeee366109e9ff6 libgpg-error-1.13.tar.bz2
-96e2f6b035e6a6b9bc0d4f88eb605007 libgpg-error-1.13.tar.bz2.sig
+b4f8d8b9ff14aed41f279aa844563539 libgpg-error-1.17.tar.bz2
+c73dc327cca7d993d268fd13680bce6b libgpg-error-1.17.tar.bz2.sig