From 601c3245cc4ea1625b6fe4b2da5c0da4d146eaef Mon Sep 17 00:00:00 2001
From: Bill Nottingham <notting@fedoraproject.org>
Date: Mon, 15 Oct 2007 19:01:18 +0000
Subject: [PATCH] makefile update to properly grab makefile.common

---
 Makefile | 19 +++++++++++++++++--
 1 file changed, 17 insertions(+), 2 deletions(-)

diff --git a/Makefile b/Makefile
index a96c5ed..a440802 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,21 @@
 # Makefile for source rpm: libgpg-error
-# $Id$
+# $Id: Makefile,v 1.1 2004/09/09 07:31:20 cvsdist Exp $
 NAME := libgpg-error
 SPECFILE = $(firstword $(wildcard *.spec))
 
-include ../common/Makefile.common
+define find-makefile-common
+for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
+endef
+
+MAKEFILE_COMMON := $(shell $(find-makefile-common))
+
+ifeq ($(MAKEFILE_COMMON),)
+# attempt a checkout
+define checkout-makefile-common
+test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
+endef
+
+MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
+endif
+
+include $(MAKEFILE_COMMON)