Update to latest snapshot, remove upstreamed patches.
Update release to packaging guidelines format. Make sure that for Fedora 24 and RHEL the libraries are always private. Merging in epel 6/7 to obsolete negativo17.org packages
This commit is contained in:
parent
b817731e51
commit
ef4f602bb8
@ -1,25 +0,0 @@
|
|||||||
From 2e35628e90e0b524ecadea498a2ffe06b6b5a4fc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rob Clark <robdclark@gmail.com>
|
|
||||||
Date: Wed, 14 Dec 2016 08:40:44 -0500
|
|
||||||
Subject: [PATCH 2/6] Print out $host_cpu when undetected, for easier debugging
|
|
||||||
|
|
||||||
---
|
|
||||||
configure.ac | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index fdfaf00..29f90d8 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -117,7 +117,7 @@ if test "x$enable_asm" = xyes; then
|
|
||||||
AC_MSG_RESULT([yes, aarch64])
|
|
||||||
;;
|
|
||||||
*)
|
|
||||||
- AC_MSG_RESULT([no, platform not supported])
|
|
||||||
+ AC_MSG_RESULT([no, platform '$host_cpu' not supported])
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
fi
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
@ -1,37 +0,0 @@
|
|||||||
From 07c095397bb336c2e4fbed89c6b9202730886acc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rob Clark <robdclark@gmail.com>
|
|
||||||
Date: Wed, 14 Dec 2016 09:35:40 -0500
|
|
||||||
Subject: [PATCH 3/6] Fix compile errors
|
|
||||||
|
|
||||||
---
|
|
||||||
src/GLdispatch/vnd-glapi/entry_armv7_tsd.c | 1 -
|
|
||||||
tests/dummy/EGL_dummy.c | 1 -
|
|
||||||
2 files changed, 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c b/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
|
|
||||||
index faec5bf..2bce0c2 100644
|
|
||||||
--- a/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
|
|
||||||
+++ b/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
|
|
||||||
@@ -166,7 +166,6 @@ const int entry_stub_size = ARMV7_ENTRY_SIZE;
|
|
||||||
static const int TEMPLATE_OFFSET_CURRENT_TABLE = ARMV7_BYTECODE_SIZE - 3*4;
|
|
||||||
static const int TEMPLATE_OFFSET_CURRENT_TABLE_GET = ARMV7_BYTECODE_SIZE - 2*4;
|
|
||||||
static const int TEMPLATE_OFFSET_SLOT = ARMV7_BYTECODE_SIZE - 4;
|
|
||||||
-static const int TEMPLATE_OFFSETS_SIZE = 3*4;
|
|
||||||
|
|
||||||
void
|
|
||||||
entry_init_public(void)
|
|
||||||
diff --git a/tests/dummy/EGL_dummy.c b/tests/dummy/EGL_dummy.c
|
|
||||||
index 372e0a0..7860dce 100644
|
|
||||||
--- a/tests/dummy/EGL_dummy.c
|
|
||||||
+++ b/tests/dummy/EGL_dummy.c
|
|
||||||
@@ -56,7 +56,6 @@ static const char *PLATFORM_EXTENSIONS =
|
|
||||||
;
|
|
||||||
|
|
||||||
static const char *DISPLAY_EXTENSIONS = "";
|
|
||||||
-static const EGLint DUMMY_EGL_CONFIG_COUNT = 2;
|
|
||||||
|
|
||||||
typedef struct DummyEGLDisplayRec {
|
|
||||||
EGLenum platform;
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
@ -1,34 +0,0 @@
|
|||||||
From c386bd5a233ed82d51ff9200c40e97e1817881f9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rob Clark <robdclark@gmail.com>
|
|
||||||
Date: Wed, 14 Dec 2016 10:44:07 -0500
|
|
||||||
Subject: [PATCH 4/6] armv7: make sure asm is compiled in unified syntax mode
|
|
||||||
|
|
||||||
The individual stub functions already have .thumb_func but if syntax is
|
|
||||||
divided the assembler will reject the STUB_ASM_CODE.
|
|
||||||
---
|
|
||||||
src/GLdispatch/vnd-glapi/entry_armv7_tsd.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c b/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
|
|
||||||
index 2bce0c2..0ea8902 100644
|
|
||||||
--- a/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
|
|
||||||
+++ b/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
|
|
||||||
@@ -140,6 +140,7 @@ static uint16_t BYTECODE_TEMPLATE[] =
|
|
||||||
|
|
||||||
__asm__(".section wtext,\"ax\"\n"
|
|
||||||
".balign 4096\n"
|
|
||||||
+ ".syntax unified\n"
|
|
||||||
".globl public_entry_start\n"
|
|
||||||
".hidden public_entry_start\n"
|
|
||||||
"public_entry_start:\n");
|
|
||||||
@@ -148,6 +149,7 @@ __asm__(".section wtext,\"ax\"\n"
|
|
||||||
#include "mapi_tmp.h"
|
|
||||||
|
|
||||||
__asm__(".balign 4096\n"
|
|
||||||
+ ".syntax divided\n"
|
|
||||||
".globl public_entry_end\n"
|
|
||||||
".hidden public_entry_end\n"
|
|
||||||
"public_entry_end:\n"
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From ec5bd547b5fe2b82a4a72b9dbd7c0c47d41c7bde Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rob Clark <robdclark@gmail.com>
|
|
||||||
Date: Wed, 14 Dec 2016 11:06:05 -0500
|
|
||||||
Subject: [PATCH 5/6] Treat armv7hl as armv7l
|
|
||||||
|
|
||||||
---
|
|
||||||
configure.ac | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 29f90d8..9a68eb2 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -91,7 +91,7 @@ if test "x$enable_asm" = xyes; then
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
;;
|
|
||||||
- armv7l)
|
|
||||||
+ armv7*l)
|
|
||||||
asm_arch=armv7l
|
|
||||||
;;
|
|
||||||
aarch64)
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
@ -1,49 +0,0 @@
|
|||||||
From 0475afe8e1c20509799b8e41ebad64938315e630 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rob Clark <robdclark@gmail.com>
|
|
||||||
Date: Mon, 9 Jan 2017 14:52:22 -0500
|
|
||||||
Subject: [PATCH 6/6] skip tests that cannot pass with pure-c dispatch
|
|
||||||
|
|
||||||
glvnd will not actually work 100% with pure-c dispatch.. but this at
|
|
||||||
least removes expected make-check fails so that it can be built.
|
|
||||||
---
|
|
||||||
tests/Makefile.am | 6 ++++++
|
|
||||||
1 file changed, 6 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
||||||
index fb8408f..e413d5b 100644
|
|
||||||
--- a/tests/Makefile.am
|
|
||||||
+++ b/tests/Makefile.am
|
|
||||||
@@ -56,7 +56,9 @@ AM_CFLAGS = \
|
|
||||||
-I$(top_srcdir)/src/util/glvnd_pthread
|
|
||||||
|
|
||||||
|
|
||||||
+if ! GLDISPATCH_TYPE_PURE_C
|
|
||||||
TESTS += testpatchentrypoints_gldispatch.sh
|
|
||||||
+endif
|
|
||||||
check_PROGRAMS += testpatchentrypoints_gldispatch
|
|
||||||
testpatchentrypoints_gldispatch_SOURCES = \
|
|
||||||
testpatchentrypoints_gldispatch.c
|
|
||||||
@@ -74,6 +76,7 @@ testpatchentrypoints_gldispatch_LDADD += $(top_builddir)/src/util/libutils_misc.
|
|
||||||
# the scripts would be missing when you run "make dist" or "make distcheck".
|
|
||||||
|
|
||||||
TESTS_GLX =
|
|
||||||
+if ! GLDISPATCH_TYPE_PURE_C
|
|
||||||
TESTS_GLX += testglxmcbasic.sh
|
|
||||||
TESTS_GLX += testglxmcloop.sh
|
|
||||||
TESTS_GLX += testglxmcthreads.sh
|
|
||||||
@@ -81,9 +84,12 @@ TESTS_GLX += testglxmclate.sh
|
|
||||||
TESTS_GLX += testglxmcoldlink.sh
|
|
||||||
TESTS_GLX += testglxgetprocaddress.sh
|
|
||||||
TESTS_GLX += testglxgetprocaddress_genentry.sh
|
|
||||||
+endif
|
|
||||||
TESTS_GLX += testglxgetclientstr.sh
|
|
||||||
TESTS_GLX += testglxqueryversion.sh
|
|
||||||
+if ! GLDISPATCH_TYPE_PURE_C
|
|
||||||
TESTS_GLX += testpatchentrypoints.sh
|
|
||||||
+endif
|
|
||||||
|
|
||||||
if ENABLE_GLX
|
|
||||||
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
@ -1,9 +1,14 @@
|
|||||||
%global commit0 dc16f8c337703ad141f83583a4004fcf42e07766
|
%global commit0 8e6e1028208fda96deb6e1aa282ca17b405ccd26
|
||||||
|
%global date 20170308
|
||||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||||
|
|
||||||
|
%if 0%{?rhel} <= 7 || 0%{?fedora} <= 24
|
||||||
|
%global _without_mesa_glvnd_default 1
|
||||||
|
%endif
|
||||||
|
|
||||||
Name: libglvnd
|
Name: libglvnd
|
||||||
Version: 0.2.999
|
Version: 0.2.999
|
||||||
Release: 11%{?commit0:.git%{shortcommit0}}%{?dist}
|
Release: 12%{?commit0:.%{date}git%{shortcommit0}}%{?dist}
|
||||||
# Provide an upgrade path from the negativo17.org pkgs which have Epoch 1
|
# Provide an upgrade path from the negativo17.org pkgs which have Epoch 1
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: The GL Vendor-Neutral Dispatch library
|
Summary: The GL Vendor-Neutral Dispatch library
|
||||||
@ -13,13 +18,6 @@ URL: https://github.com/NVIDIA/libglvnd
|
|||||||
Source0: https://github.com/NVIDIA/%{name}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
|
Source0: https://github.com/NVIDIA/%{name}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
|
||||||
# https://github.com/NVIDIA/libglvnd/pull/100
|
# https://github.com/NVIDIA/libglvnd/pull/100
|
||||||
Patch1: 0001-OpenGL-Statically-export-a-few-more-things.patch
|
Patch1: 0001-OpenGL-Statically-export-a-few-more-things.patch
|
||||||
# https://github.com/NVIDIA/libglvnd/pull/113
|
|
||||||
Patch2: 0002-Print-out-host_cpu-when-undetected-for-easier-debugg.patch
|
|
||||||
Patch3: 0003-Fix-compile-errors.patch
|
|
||||||
Patch4: 0004-armv7-make-sure-asm-is-compiled-in-unified-syntax-mo.patch
|
|
||||||
Patch5: 0005-Treat-armv7hl-as-armv7l.patch
|
|
||||||
# WIP
|
|
||||||
Patch6: 0006-skip-tests-that-cannot-pass-with-pure-c-dispatch.patch
|
|
||||||
|
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -146,7 +144,7 @@ find %{buildroot} -name '*.la' -delete
|
|||||||
%{?_without_mesa_glvnd_default:
|
%{?_without_mesa_glvnd_default:
|
||||||
# Avoid conflict with mesa-libGL
|
# Avoid conflict with mesa-libGL
|
||||||
mkdir -p %{buildroot}%{_libdir}/%{name}
|
mkdir -p %{buildroot}%{_libdir}/%{name}
|
||||||
for l in libEGL libGL libGLESv1_CM libGLESv2 ; do
|
for l in libEGL libGL libGLESv1_CM libGLESv2 libGLX; do
|
||||||
mv %{buildroot}%{_libdir}/${l}.so* \
|
mv %{buildroot}%{_libdir}/${l}.so* \
|
||||||
%{buildroot}%{_libdir}/%{name}
|
%{buildroot}%{_libdir}/%{name}
|
||||||
done
|
done
|
||||||
@ -161,10 +159,8 @@ mkdir -p %{buildroot}%{_datadir}/egl/egl_external_platform.d
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
export DO_X11_TESTS=1
|
export DO_X11_TESTS=1
|
||||||
# theses tests are failing in mock
|
# these tests are skipped in mock (server does not support the GLX extension)
|
||||||
#FAIL: testglxqueryversion.sh
|
# SKIP: testglxqueryversion.sh
|
||||||
#FAIL: testglxnscrthreads.sh
|
|
||||||
#reported as https://github.com/NVIDIA/libglvnd/issues/93
|
|
||||||
xvfb-run -a make check V=1 || cat `find . -name test-suite.log`
|
xvfb-run -a make check V=1 || cat `find . -name test-suite.log`
|
||||||
|
|
||||||
|
|
||||||
@ -227,6 +223,11 @@ xvfb-run -a make check V=1 || cat `find . -name test-suite.log`
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 03 2017 Simone Caronni <negativo17@gmail.com> - 1:0.2.999-12.20170308git8e6e102
|
||||||
|
- Update to latest snapshot, remove upstreamed patches.
|
||||||
|
- Update release to packaging guidelines format.
|
||||||
|
- Make sure that for Fedora 24 and RHEL the libraries are always private.
|
||||||
|
|
||||||
* Thu Feb 23 2017 Nicolas Chauvet <kwizart@gmail.com> - 1:0.2.999-11.gitdc16f8c
|
* Thu Feb 23 2017 Nicolas Chauvet <kwizart@gmail.com> - 1:0.2.999-11.gitdc16f8c
|
||||||
- asm enabled only for x86 - rhbz#1419944
|
- asm enabled only for x86 - rhbz#1419944
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libglvnd-dc16f8c.tar.gz) = ac236cbf39be47d34c5df05fac720e13425cb1cd27c3d66c1cea5c2c6a337bddfb16851f76c2c6b0888b0b01cd8d2324971d5220b13d4ac0ec24f1a5c3d8177f
|
SHA512 (libglvnd-8e6e102.tar.gz) = f5811ba2f82b688af4bd93516df46b5a84ba86607181420b30bf754f2ef4517a547cf7cccd4344a01f6520c5d6e30c2f3acd74c97f43bbabb88b6ed9a13d5c4b
|
||||||
|
Loading…
Reference in New Issue
Block a user