Update to 1.4.4 (with compat copy of 1.3.1)
This commit is contained in:
parent
269a5ce17d
commit
e2ce24a51f
1
.gitignore
vendored
1
.gitignore
vendored
@ -39,3 +39,4 @@
|
|||||||
/libgit2-1.1.0.tar.gz
|
/libgit2-1.1.0.tar.gz
|
||||||
/libgit2-1.3.0.tar.gz
|
/libgit2-1.3.0.tar.gz
|
||||||
/libgit2-1.3.1.tar.gz
|
/libgit2-1.3.1.tar.gz
|
||||||
|
/libgit2-1.4.4.tar.gz
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From c40964b5c2a313a88588bd1be3abe72267bba44b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Carl Dong <accounts@carldong.me>
|
|
||||||
Date: Mon, 9 May 2022 12:09:08 -0400
|
|
||||||
Subject: [PATCH] revparse: Remove error-prone, redundant test
|
|
||||||
|
|
||||||
Originally introduced in: 776a6a8e5f8e258d31aded73c0ce38df6ac7bdc4
|
|
||||||
|
|
||||||
This test case has recently been fixed in bdab22384cc61d315005a65456a9f9563bb27c8f, but that fix will only last for a year. Next year the same problem will crop up and the test will need to be re-edited.
|
|
||||||
|
|
||||||
This is not ideal as
|
|
||||||
- This test case becomes an unnecessary burden for developers
|
|
||||||
- Downstream distros or even just users who want to build older versions of libgit2 are guaranteed to have this test fail
|
|
||||||
|
|
||||||
Furthermore, this test case is entirely unnecessary, as the functionality that was originally (see 776a6a8e5f8e258d31aded73c0ce38df6ac7bdc4) intended to be tested is well-covered by subsequent tests which specify a date instead of a "x ago" specification.
|
|
||||||
|
|
||||||
(cherry picked from commit 7f53d7b600a838c19276e835fd0188c361a63801)
|
|
||||||
Signed-off-by: Nils Philippsen <nils@redhat.com>
|
|
||||||
---
|
|
||||||
tests/refs/revparse.c | 2 --
|
|
||||||
1 file changed, 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/refs/revparse.c b/tests/refs/revparse.c
|
|
||||||
index bc6e0a4c4..a8b2efe6a 100644
|
|
||||||
--- a/tests/refs/revparse.c
|
|
||||||
+++ b/tests/refs/revparse.c
|
|
||||||
@@ -400,8 +400,6 @@ void test_refs_revparse__date(void)
|
|
||||||
* a65fedf HEAD@{1335806603 -0900}: commit:
|
|
||||||
* be3563a HEAD@{1335806563 -0700}: clone: from /Users/ben/src/libgit2/tests/resour
|
|
||||||
*/
|
|
||||||
- test_object("HEAD@{10 years ago}", NULL);
|
|
||||||
-
|
|
||||||
test_object("HEAD@{1 second}", "a65fedf39aefe402d3bb6e24df4d4f5fe4547750");
|
|
||||||
test_object("HEAD@{1 second ago}", "a65fedf39aefe402d3bb6e24df4d4f5fe4547750");
|
|
||||||
test_object("HEAD@{2 days ago}", "a65fedf39aefe402d3bb6e24df4d4f5fe4547750");
|
|
||||||
--
|
|
||||||
2.36.1
|
|
||||||
|
|
12
libgit2.spec
12
libgit2.spec
@ -6,14 +6,12 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libgit2
|
Name: libgit2
|
||||||
Version: 1.3.1
|
Version: 1.4.4
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
Summary: C implementation of the Git core methods as a library with a solid API
|
Summary: C implementation of the Git core methods as a library with a solid API
|
||||||
License: GPLv2 with exceptions
|
License: GPLv2 with exceptions
|
||||||
URL: https://libgit2.org/
|
URL: https://libgit2.org/
|
||||||
Source0: https://github.com/libgit2/libgit2/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
Source0: https://github.com/libgit2/libgit2/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
# Backported from https://github.com/libgit2/libgit2/pull/6299
|
|
||||||
Patch1: 0001-revparse-Remove-error-prone-redundant-test.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: cmake >= 3.5.1
|
BuildRequires: cmake >= 3.5.1
|
||||||
@ -27,6 +25,7 @@ BuildRequires: openssl-devel
|
|||||||
BuildRequires: pcre2-devel
|
BuildRequires: pcre2-devel
|
||||||
BuildRequires: python3
|
BuildRequires: python3
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
|
BuildRequires: libgit2
|
||||||
Provides: bundled(libxdiff)
|
Provides: bundled(libxdiff)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -64,7 +63,9 @@ rm -vr deps
|
|||||||
-DUSE_SHA1=HTTPS \
|
-DUSE_SHA1=HTTPS \
|
||||||
-DUSE_HTTPS=OpenSSL \
|
-DUSE_HTTPS=OpenSSL \
|
||||||
-DUSE_NTLMCLIENT=OFF \
|
-DUSE_NTLMCLIENT=OFF \
|
||||||
%if %{without libssh2}
|
%if %{with libssh2}
|
||||||
|
-DUSE_SSH=ON \
|
||||||
|
%else
|
||||||
-DUSE_SSH=OFF \
|
-DUSE_SSH=OFF \
|
||||||
%endif
|
%endif
|
||||||
%{nil}
|
%{nil}
|
||||||
@ -72,12 +73,15 @@ rm -vr deps
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
%cmake_install
|
%cmake_install
|
||||||
|
# Include previous ABI version for temporary binary compatibility
|
||||||
|
cp -a %{_libdir}/libgit2.so.1.3* %{buildroot}%{_libdir}
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%ctest
|
%ctest
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%license COPYING
|
%license COPYING
|
||||||
|
%{_libdir}/libgit2.so.1.4*
|
||||||
%{_libdir}/libgit2.so.1.3*
|
%{_libdir}/libgit2.so.1.3*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libgit2-1.3.1.tar.gz) = 012ffda7e8b9557923758fdbe68869875977d419bfa60b61f90adadc056600e2b1cc2db1c2a003315ea0e193c0145c1f431054f7bd960c5e6e14fa541e46cba3
|
SHA512 (libgit2-1.4.4.tar.gz) = 8f4cc43de9b92866ac12e01613efe0ff808deca29ff82b6da98a38c814bb711ff3133145d0219210af7015955fbe381be6f1cb98915811d3c37e92b01eb522e9
|
||||||
|
Loading…
Reference in New Issue
Block a user