Update to 0.23.0
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
6c515da71d
commit
8beb6d3af1
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
|||||||
/libgit2-0.22.1.tar.gz
|
/libgit2-0.22.1.tar.gz
|
||||||
/libgit2-0.22.2.tar.gz
|
/libgit2-0.22.2.tar.gz
|
||||||
/libgit2-0.22.3.tar.gz
|
/libgit2-0.22.3.tar.gz
|
||||||
|
/libgit2-0.23.0.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 5eacce57a3556ac39fa8aadfba35788ee29f5fb1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mathieu Bridon <bochecha@daitauha.fr>
|
|
||||||
Date: Tue, 20 Jan 2015 17:59:21 +0100
|
|
||||||
Subject: [PATCH] Disable some unit tests
|
|
||||||
|
|
||||||
These tests just can't work in Koji, because they require an Internet
|
|
||||||
access, but Koji builders don't have access to the outside world.
|
|
||||||
---
|
|
||||||
tests/network/remote/remotes.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/network/remote/remotes.c b/tests/network/remote/remotes.c
|
|
||||||
index 995f1d5..d9b8f5b 100644
|
|
||||||
--- a/tests/network/remote/remotes.c
|
|
||||||
+++ b/tests/network/remote/remotes.c
|
|
||||||
@@ -549,6 +549,7 @@ void test_network_remote_remotes__fetch_from_anonymous(void)
|
|
||||||
git_remote_free(remote);
|
|
||||||
}
|
|
||||||
|
|
||||||
+/* Disabling, can't work in Koji as there's no network access there
|
|
||||||
void test_network_remote_remotes__single_branch(void)
|
|
||||||
{
|
|
||||||
git_clone_options opts = GIT_CLONE_OPTIONS_INIT;
|
|
||||||
@@ -581,3 +582,4 @@ void test_network_remote_remotes__restricted_refspecs(void)
|
|
||||||
|
|
||||||
cl_git_fail_with(GIT_EINVALIDSPEC, git_clone(&repo, "git://github.com/libgit2/TestGitRepository", "./restrict-refspec", &opts));
|
|
||||||
}
|
|
||||||
+*/
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
13
libgit2.spec
13
libgit2.spec
@ -1,5 +1,5 @@
|
|||||||
Name: libgit2
|
Name: libgit2
|
||||||
Version: 0.22.3
|
Version: 0.23.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: C implementation of the Git core methods as a library with a solid API
|
Summary: C implementation of the Git core methods as a library with a solid API
|
||||||
License: GPLv2 with exceptions
|
License: GPLv2 with exceptions
|
||||||
@ -13,8 +13,6 @@ BuildRequires: python2
|
|||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
Provides: bundled(libxdiff)
|
Provides: bundled(libxdiff)
|
||||||
|
|
||||||
Patch0: 0001-Disable-some-unit-tests.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
libgit2 is a portable, pure C implementation of the Git core methods
|
libgit2 is a portable, pure C implementation of the Git core methods
|
||||||
provided as a re-entrant linkable library with a solid API, allowing
|
provided as a re-entrant linkable library with a solid API, allowing
|
||||||
@ -30,9 +28,7 @@ This package contains libraries and header files for
|
|||||||
developing applications that use %{name}.
|
developing applications that use %{name}.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
# Remove VCS files from examples
|
# Remove VCS files from examples
|
||||||
find examples -name ".gitignore" -delete -print
|
find examples -name ".gitignore" -delete -print
|
||||||
@ -61,7 +57,7 @@ ctest -V
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc COPYING
|
%license COPYING
|
||||||
%{_libdir}/libgit2.so.*
|
%{_libdir}/libgit2.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -72,6 +68,9 @@ ctest -V
|
|||||||
%{_includedir}/git2/
|
%{_includedir}/git2/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 30 2015 Igor Gnatenko <ignatenko@src.gnome.org> - 0.23.0-1
|
||||||
|
- Update to 0.23.0
|
||||||
|
|
||||||
* Fri Jul 03 2015 Veeti Paananen <veeti.paananen@rojekti.fi> - 0.22.3-1
|
* Fri Jul 03 2015 Veeti Paananen <veeti.paananen@rojekti.fi> - 0.22.3-1
|
||||||
- Update to 0.22.3
|
- Update to 0.22.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user