import libgit2-0.26.8-1.el8

This commit is contained in:
CentOS Sources 2019-11-05 14:39:21 -05:00 committed by Andrew Lukoshko
parent f6c62a169e
commit 20ca9f6949
5 changed files with 73 additions and 7 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/libgit2-0.26.6.tar.gz
SOURCES/libgit2-0.26.8.tar.gz

View File

@ -1 +1 @@
b663c12fadaa886781334d745b914dc3a1afd16d SOURCES/libgit2-0.26.6.tar.gz
ec4242317439239e53c5a137f918fcee9d21bcef SOURCES/libgit2-0.26.8.tar.gz

View File

@ -0,0 +1,31 @@
From 25567536469c9cbe75445bb9875c7f10ff7f9ba2 Mon Sep 17 00:00:00 2001
From: "Brian C. Lane" <bcl@brianlane.com>
Date: Wed, 15 May 2019 12:05:34 -0700
Subject: [PATCH] Disable online tests
We do not support online tests during build, and with ssh disabled that
one also doesn't apply.
Related: rhbz#1638880
---
CMakeLists.txt | 4 ----
1 file changed, 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eabc524..5a23d01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -705,10 +705,6 @@ IF (BUILD_CLAR)
ENABLE_TESTING()
ADD_TEST(offline libgit2_clar -v -xonline)
- ADD_TEST(online libgit2_clar -v -sonline)
- ADD_TEST(gitdaemon libgit2_clar -v -sonline::push)
- ADD_TEST(ssh libgit2_clar -v -sonline::push -sonline::clone::ssh_cert -sonline::clone::ssh_with_paths)
- ADD_TEST(proxy libgit2_clar -v -sonline::clone::proxy_credentials_in_url -sonline::clone::proxy_credentials_request)
ENDIF ()
IF (TAGS)
--
2.20.1

View File

@ -0,0 +1,28 @@
From 53686ab27d6fa7f78274e6ec7efd846626e1eb65 Mon Sep 17 00:00:00 2001
From: "Brian C. Lane" <bcl@redhat.com>
Date: Wed, 31 Oct 2018 12:13:01 -0700
Subject: [PATCH] tests: Increase TOOBIG value used on i686
0x0fffffff isn't big enough.
Related: rhbz#1638880
---
tests/buf/oom.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/buf/oom.c b/tests/buf/oom.c
index 16a03cc1a..c01e87895 100644
--- a/tests/buf/oom.c
+++ b/tests/buf/oom.c
@@ -12,7 +12,7 @@
#if defined(GIT_ARCH_64) && defined(__linux__)
# define TOOBIG 0x0fffffffffffffff
#elif defined(__linux__)
-# define TOOBIG 0x0fffffff
+# define TOOBIG 0xffffff00
#elif defined(GIT_ARCH_64)
# define TOOBIG 0xffffffffffffff00
#else
--
2.20.1

View File

@ -1,6 +1,6 @@
Name: libgit2
Version: 0.26.6
Release: 3%{?dist}
Version: 0.26.8
Release: 1%{?dist}
Summary: C implementation of the Git core methods as a library with a solid API
License: GPLv2 with exceptions
URL: http://libgit2.github.com/
@ -9,6 +9,8 @@ Source1: README.rhel8
Patch0001: 0001-Revert-cmake-disable-optimization-on-debug-builds.patch
Patch0002: 0002-CMakeLists-increase-strict-aliasing-level-to-3.patch
Patch0003: 0003-Disable-online-tests.patch
Patch0004: 0004-tests-Increase-TOOBIG-value-used-on-i686.patch
BuildRequires: gcc
BuildRequires: cmake
@ -42,9 +44,6 @@ find examples -name ".gitignore" -delete -print
# Fix pkgconfig generation
sed -i 's|@CMAKE_INSTALL_PREFIX@/||' libgit2.pc.in
# Don't test network
sed -i 's/ionline/xonline/' CMakeLists.txt
# Remove bundled libraries
rm -frv deps
@ -80,6 +79,14 @@ popd
%{_includedir}/git2/
%changelog
* Wed May 15 2019 Brian C. Lane <bcl@redhat.com> - 0.26.8-1
- Update to 0.26.8
Resolves: rhbz#1638880
- Disable upstream online tests
Related: rhbz#1638880
- tests: Increase TOOBIG value used on i686
Related: rhbz#1638880
* Fri Sep 07 2018 Brian C. Lane <bcl@redhat.com> - 0.26.6-3
- CMakeLists increase strict aliasing level to 3
Related: rhbz#1624129