import libgit2-0.26.8-2.el8
This commit is contained in:
parent
a23a12674f
commit
13c4714653
30
SOURCES/0005-openssl-Use-the-system-profile-ciphers.patch
Normal file
30
SOURCES/0005-openssl-Use-the-system-profile-ciphers.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 04916e405fb34f98497536ee5cec5b48c137dac1 Mon Sep 17 00:00:00 2001
|
||||
From: "Brian C. Lane" <bcl@redhat.com>
|
||||
Date: Tue, 2 Jun 2020 10:39:45 -0700
|
||||
Subject: [PATCH] openssl: Use the system profile ciphers
|
||||
|
||||
On Fedora and RHEL we let the system decide which ciphers to use instead
|
||||
of setting them explicitly.
|
||||
|
||||
Resolves: rhbz#1842814
|
||||
---
|
||||
src/openssl_stream.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/openssl_stream.c b/src/openssl_stream.c
|
||||
index 6bab6b54a..fbf3bd578 100644
|
||||
--- a/src/openssl_stream.c
|
||||
+++ b/src/openssl_stream.c
|
||||
@@ -35,7 +35,8 @@
|
||||
|
||||
SSL_CTX *git__ssl_ctx;
|
||||
|
||||
-#define GIT_SSL_DEFAULT_CIPHERS "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES128-SHA256:DHE-DSS-AES256-SHA256:DHE-DSS-AES128-SHA:DHE-DSS-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA"
|
||||
+/* rhbz#1842814 use the system defined ciphers. Override with GIT_OPT_SET_SSL_CIPHERS */
|
||||
+#define GIT_SSL_DEFAULT_CIPHERS "PROFILE=SYSTEM"
|
||||
|
||||
#if defined(GIT_THREADS) && OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: libgit2
|
||||
Version: 0.26.8
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: C implementation of the Git core methods as a library with a solid API
|
||||
License: GPLv2 with exceptions
|
||||
URL: http://libgit2.github.com/
|
||||
@ -11,6 +11,7 @@ Patch0001: 0001-Revert-cmake-disable-optimization-on-debug-builds.patch
|
||||
Patch0002: 0002-CMakeLists-increase-strict-aliasing-level-to-3.patch
|
||||
Patch0003: 0003-Disable-online-tests.patch
|
||||
Patch0004: 0004-tests-Increase-TOOBIG-value-used-on-i686.patch
|
||||
Patch0005: 0005-openssl-Use-the-system-profile-ciphers.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: cmake
|
||||
@ -79,6 +80,10 @@ popd
|
||||
%{_includedir}/git2/
|
||||
|
||||
%changelog
|
||||
* Tue Jun 02 2020 Brian C. Lane <bcl@redhat.com> - 0.26.8-2
|
||||
- openssl: Use the system profile ciphers
|
||||
Resolves: rhbz#1842814
|
||||
|
||||
* Wed May 15 2019 Brian C. Lane <bcl@redhat.com> - 0.26.8-1
|
||||
- Update to 0.26.8
|
||||
Resolves: rhbz#1638880
|
||||
|
Loading…
Reference in New Issue
Block a user