Update to 0.8.2
- Drop s390x patch, no longer needed
This commit is contained in:
parent
7b806d1f4a
commit
6887110c43
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/libgee-0.8.1.tar.xz
|
/libgee-0.8.2.tar.xz
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- libgee-0.7.90/gee/treemap.c.declaration 2012-08-28 13:35:16.000000000 +0700
|
|
||||||
+++ libgee-0.7.90/gee/treemap.c 2012-09-05 18:35:13.124163383 +0700
|
|
||||||
@@ -1510,6 +1510,7 @@
|
|
||||||
static GeeSortedMap* gee_tree_map_sub_map_real_tail_map (GeeAbstractSortedMap* base, gconstpointer after);
|
|
||||||
static GeeSortedMap* gee_tree_map_sub_map_real_sub_map (GeeAbstractSortedMap* base, gconstpointer after, gconstpointer before);
|
|
||||||
GeeSet* gee_abstract_map_get_keys (GeeAbstractMap* self);
|
|
||||||
+GeeSet* gee_map_get_keys (GeeMap* self);
|
|
||||||
gint gee_collection_get_size (GeeCollection* self);
|
|
||||||
static gboolean gee_tree_map_sub_map_get_is_empty (GeeTreeMapSubMap* self);
|
|
||||||
gboolean gee_collection_get_is_empty (GeeCollection* self);
|
|
12
libgee.spec
12
libgee.spec
@ -1,5 +1,5 @@
|
|||||||
Name: libgee
|
Name: libgee
|
||||||
Version: 0.8.1
|
Version: 0.8.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: GObject collection library
|
Summary: GObject collection library
|
||||||
|
|
||||||
@ -8,11 +8,6 @@ License: LGPLv2+
|
|||||||
URL: http://live.gnome.org/Libgee
|
URL: http://live.gnome.org/Libgee
|
||||||
#VCS: git:git://git.gnome.org/libgee
|
#VCS: git:git://git.gnome.org/libgee
|
||||||
Source0: http://download.gnome.org/sources/libgee/0.8/libgee-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/libgee/0.8/libgee-%{version}.tar.xz
|
||||||
# manually fix the generated code otherwise 32-to-64 bit conversion is done and
|
|
||||||
# bad things happen for values >= 0x8000000, probably a Vala compiler bug, seems
|
|
||||||
# like something with abstract classes/methods, but needs a Vala expert, found
|
|
||||||
# on s390x, search for "implicit declaration of function ..." in build.log
|
|
||||||
Patch0: %{name}-0.7.90-declaration.patch
|
|
||||||
|
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
BuildRequires: gobject-introspection-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
@ -64,7 +59,6 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .declaration
|
|
||||||
# ChangeLog not UTF8
|
# ChangeLog not UTF8
|
||||||
iconv -f iso88591 -t utf8 ChangeLog -o ChangeLog.new
|
iconv -f iso88591 -t utf8 ChangeLog -o ChangeLog.new
|
||||||
touch -r ChangeLog ChangeLog.new
|
touch -r ChangeLog ChangeLog.new
|
||||||
@ -116,6 +110,10 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 16 2012 Michel Salim <salimma@fedoraproject.org> - 0.8.2-1
|
||||||
|
- Update to 0.8.2
|
||||||
|
- Drop s390x patch, no longer needed
|
||||||
|
|
||||||
* Tue Oct 16 2012 Michel Salim <salimma@fedoraproject.org> - 0.8.1-1
|
* Tue Oct 16 2012 Michel Salim <salimma@fedoraproject.org> - 0.8.1-1
|
||||||
- Update to 0.8.1
|
- Update to 0.8.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user