fix build, see patch comment for details
This commit is contained in:
parent
e7e9a59e5a
commit
4c9d5d57a2
11
libgee-0.7.1-declaration.patch
Normal file
11
libgee-0.7.1-declaration.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up libgee-0.7.1/gee/treemap.c.declaration libgee-0.7.1/gee/treemap.c
|
||||||
|
--- libgee-0.7.1/gee/treemap.c.declaration 2012-01-12 17:53:00.000000000 +0100
|
||||||
|
+++ libgee-0.7.1/gee/treemap.c 2012-01-12 17:54:49.000000000 +0100
|
||||||
|
@@ -1339,6 +1339,7 @@ static GeeSortedMap* gee_tree_map_sub_ma
|
||||||
|
static GeeSortedMap* gee_tree_map_sub_map_real_tail_map (GeeAbstractSortedMap* base, gconstpointer after);
|
||||||
|
static GeeSortedMap* gee_tree_map_sub_map_real_sub_map (GeeAbstractSortedMap* base, gconstpointer after, gconstpointer before);
|
||||||
|
GeeSet* gee_abstract_map_get_keys (GeeAbstractMap* self);
|
||||||
|
+GeeSet* gee_map_get_keys (GeeMap* self);
|
||||||
|
gint gee_collection_get_size (GeeCollection* self);
|
||||||
|
gboolean gee_collection_get_is_empty (GeeCollection* self);
|
||||||
|
static GeeTreeMapSubKeySet* gee_tree_map_sub_key_set_new (GType k_type, GBoxedCopyFunc k_dup_func, GDestroyNotify k_destroy_func, GType v_type, GBoxedCopyFunc v_dup_func, GDestroyNotify v_destroy_func, GeeTreeMap* map, GeeTreeMapRange* range);
|
11
libgee.spec
11
libgee.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libgee
|
Name: libgee
|
||||||
Version: 0.7.1
|
Version: 0.7.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: GObject collection library
|
Summary: GObject collection library
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -8,6 +8,11 @@ License: LGPLv2+
|
|||||||
URL: http://live.gnome.org/Libgee
|
URL: http://live.gnome.org/Libgee
|
||||||
#VCS: git:git://git.gnome.org/libgee
|
#VCS: git:git://git.gnome.org/libgee
|
||||||
Source0: http://download.gnome.org/sources/libgee/0.7/libgee-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/libgee/0.7/libgee-%{version}.tar.xz
|
||||||
|
# manually fix the generated code otherwise 32-to-64 bit conversion is done and
|
||||||
|
# bad things happen for values >= 0x8000000, probably a Vala compiler bug, seems
|
||||||
|
# like something with abstract classes/methods, but needs a Vala expert, found
|
||||||
|
# on s390x, search for "implicit declaration of function ..." in build.log
|
||||||
|
Patch0: %{name}-0.7.1-declaration.patch
|
||||||
|
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
BuildRequires: gobject-introspection-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
@ -59,6 +64,7 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .declaration
|
||||||
# ChangeLog not UTF8
|
# ChangeLog not UTF8
|
||||||
iconv -f iso88591 -t utf8 ChangeLog -o ChangeLog.new
|
iconv -f iso88591 -t utf8 ChangeLog -o ChangeLog.new
|
||||||
touch -r ChangeLog ChangeLog.new
|
touch -r ChangeLog ChangeLog.new
|
||||||
@ -110,6 +116,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 12 2012 Dan Horák <dan[at]danny.cz> - 0.7.1-2
|
||||||
|
- fix build, see patch comment for details
|
||||||
|
|
||||||
* Wed Sep 28 2011 Ray <rstrode@redhat.com> - 0.7.1-1
|
* Wed Sep 28 2011 Ray <rstrode@redhat.com> - 0.7.1-1
|
||||||
- Update to 0.7.1
|
- Update to 0.7.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user