import libgdither-0.6-17.el8
This commit is contained in:
commit
51fe94aa66
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libgdither-0.6.tar.gz
|
1
.libgdither.metadata
Normal file
1
.libgdither.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
8727600550401c22ba9ec7a24e1ab6d2c02cee9a SOURCES/libgdither-0.6.tar.gz
|
52
SOURCES/libgdither-0.6-default.patch
Normal file
52
SOURCES/libgdither-0.6-default.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
diff -up libgdither-0.6/Makefile.default libgdither-0.6/Makefile
|
||||||
|
--- libgdither-0.6/Makefile.default 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither-0.6/Makefile 2008-06-10 20:05:01.000000000 +0200
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
VERSION = 0.6
|
||||||
|
-PREFIX = /usr/local
|
||||||
|
-CFLAGS = -Wall -g -I. -O3 -funroll-loops -finline-limit=9999999 -ffast-math -malign-double -march=`uname -m` -fPIC
|
||||||
|
+PREFIX = /usr
|
||||||
|
+CFLAGS = $(INIT_CFLAGS) -I. -ffast-math -fPIC
|
||||||
|
|
||||||
|
TARDIR = libgdither-$(VERSION)
|
||||||
|
|
||||||
|
@@ -10,20 +10,22 @@ gdither.o: gdither.c gdither.h gdither_t
|
||||||
|
$(CC) $(CFLAGS) -c gdither.c
|
||||||
|
|
||||||
|
libgdither.so: gdither.o
|
||||||
|
- $(CC) -shared gdither.o -o libgdither.so
|
||||||
|
+ $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
|
||||||
|
libgdither.pc: libgdither.pc.in Makefile
|
||||||
|
sed -e 's|@VERSION@|$(VERSION)|' -e 's|@PREFIX@|$(PREFIX)|' \
|
||||||
|
libgdither.pc.in > libgdither.pc
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- install -d $(PREFIX)/lib/
|
||||||
|
- install libgdither.so $(PREFIX)/lib/
|
||||||
|
- install -d $(PREFIX)/include/
|
||||||
|
- install gdither.h $(PREFIX)/include/
|
||||||
|
- install gdither_types.h $(PREFIX)/include/
|
||||||
|
- install -d $(PREFIX)/lib/pkgconfig/
|
||||||
|
- install libgdither.pc $(PREFIX)/lib/pkgconfig/
|
||||||
|
+ mkdir -p $(DESTDIR)$(LIBDIR)
|
||||||
|
+ install -pm 0755 libgdither.so* $(DESTDIR)$(LIBDIR)
|
||||||
|
+ ln -s libgdither.so.1.0 $(DESTDIR)$(LIBDIR)/libgdither.so.1
|
||||||
|
+ ln -s libgdither.so.1.0 $(DESTDIR)$(LIBDIR)/libgdither.so
|
||||||
|
+ mkdir -p $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ install -pm 0644 gdither.h $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ install -pm 0644 gdither_types.h $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig/
|
||||||
|
+ install -pm 0644 libgdither.pc $(DESTDIR)$(LIBDIR)/pkgconfig/
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f *.o *.so
|
||||||
|
diff -up libgdither-0.6/libgdither.pc.default libgdither-0.6/libgdither.pc
|
||||||
|
--- libgdither-0.6/libgdither.pc.default 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither-0.6/libgdither.pc 2008-06-10 20:04:09.000000000 +0200
|
||||||
|
@@ -6,4 +6,4 @@ Name: libgdither
|
||||||
|
Version: 0.6
|
||||||
|
Description: A library for applying dithering to PCM audio sources
|
||||||
|
Libs: -L${libdir} -lgdither -lm
|
||||||
|
-Cflags: -I${includedir}
|
||||||
|
+Cflags: -I${includedir}/libgdither
|
13
SOURCES/libgdither-0.6-gavl.patch
Normal file
13
SOURCES/libgdither-0.6-gavl.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -ur libgdither-0.6/gdither.c libgdither/gdither.c
|
||||||
|
--- libgdither-0.6/gdither.c 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither/gdither.c 2008-04-20 13:43:33.000000000 +0200
|
||||||
|
@@ -342,7 +342,7 @@
|
||||||
|
for (i=0; (i + pos) < length && i < GDITHER_CONV_BLOCK; i++) {
|
||||||
|
conv[i] = x[pos + i];
|
||||||
|
}
|
||||||
|
- gdither_runf(s, channel, i, conv, ycast + s->channels * step);
|
||||||
|
+ gdither_runf(s, channel, i, conv, ycast + pos * step);
|
||||||
|
pos += i;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
20
SOURCES/libgdither-0.6-ldflags.patch
Normal file
20
SOURCES/libgdither-0.6-ldflags.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up libgdither-0.6/Makefile.ldflags libgdither-0.6/Makefile
|
||||||
|
--- libgdither-0.6/Makefile.ldflags 2018-10-13 15:01:35.228468070 -0400
|
||||||
|
+++ libgdither-0.6/Makefile 2018-10-13 15:07:29.070561578 -0400
|
||||||
|
@@ -4,13 +4,13 @@ CFLAGS = $(INIT_CFLAGS) -I. -ffast-math
|
||||||
|
|
||||||
|
TARDIR = libgdither-$(VERSION)
|
||||||
|
|
||||||
|
-all: libgdither.so
|
||||||
|
+all: libgdither.so.1.0
|
||||||
|
|
||||||
|
gdither.o: gdither.c gdither.h gdither_types_internal.h
|
||||||
|
$(CC) $(CFLAGS) -c gdither.c
|
||||||
|
|
||||||
|
-libgdither.so: gdither.o
|
||||||
|
- $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
+libgdither.so.1.0: gdither.o
|
||||||
|
+ $(CC) $(LDFLAGS) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
|
||||||
|
libgdither.pc: libgdither.pc.in Makefile
|
||||||
|
sed -e 's|@VERSION@|$(VERSION)|' -e 's|@PREFIX@|$(PREFIX)|' \
|
136
SPECS/libgdither.spec
Normal file
136
SPECS/libgdither.spec
Normal file
@ -0,0 +1,136 @@
|
|||||||
|
Name: libgdither
|
||||||
|
Version: 0.6
|
||||||
|
Release: 17%{?dist}
|
||||||
|
Summary: Library for applying dithering to PCM audio sources
|
||||||
|
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
License: GPLv2+
|
||||||
|
URL: http://plugin.org.uk/libgdither/README
|
||||||
|
Source0: http://plugin.org.uk/libgdither/libgdither-%{version}.tar.gz
|
||||||
|
Patch0: libgdither-0.6-default.patch
|
||||||
|
Patch1: libgdither-0.6-gavl.patch
|
||||||
|
Patch2: libgdither-0.6-ldflags.patch
|
||||||
|
|
||||||
|
BuildRequires: fftw-devel >= 3.0.0
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
Libgdither is a GPL'd library library for performing audio dithering on
|
||||||
|
PCM samples. The dithering process should be carried out before reducing
|
||||||
|
the bit width of PCM audio data (eg. float to 16 bit int conversions) to
|
||||||
|
preserve audio quality.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .default
|
||||||
|
%patch1 -p1 -b .gavl_fix
|
||||||
|
%patch2 -p1 -b .ldflags
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
|
||||||
|
export LDFLAGS="%{build_ldflags}"
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
|
||||||
|
export LDFLAGS="%{build_ldflags}"
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir}
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
sed -i -e 's|/usr/local|%{_prefix}|g' \
|
||||||
|
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
sed -i -e 's|%{_prefix}/lib|%{_libdir}|' \
|
||||||
|
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
|
||||||
|
%check
|
||||||
|
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
|
||||||
|
export LDFLAGS="%{build_ldflags}"
|
||||||
|
make test CFLAGS="${RPM_OPT_FLAGS} -Werror --std=c99 -I%{_builddir}/%{?buildsubdir}"
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc COPYING README
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_includedir}/libgdither/
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Oct 13 2018 Ray Strode <rstrode@redhat.com> - 0.6-17
|
||||||
|
- Address annocheck failures
|
||||||
|
Resolves: #1630581
|
||||||
|
|
||||||
|
* Tue Apr 10 2018 Rafael Santos <rdossant@redhat.com> - 0.6-16
|
||||||
|
- Use Fedora standard linker flags (bug #1548657)
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 27 2008 kwizart < kwizart at gmail.com > - 0.6-1
|
||||||
|
- Backport patch from gavl
|
||||||
|
|
||||||
|
* Mon Jun 16 2008 kwizart < kwizart at gmail.com > - 0.6-0
|
||||||
|
- Initial package
|
Loading…
Reference in New Issue
Block a user