Update to 0.16.1
This commit is contained in:
parent
2a809c379c
commit
6ae85de006
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ libgdata-0.6.4.tar.bz2
|
||||
/libgdata-0.15.1.tar.xz
|
||||
/libgdata-0.15.2.tar.xz
|
||||
/libgdata-0.16.0.tar.xz
|
||||
/libgdata-0.16.1.tar.xz
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 730dfd4f728ca33d5dee20216562a45b644ae952 Mon Sep 17 00:00:00 2001
|
||||
From: Kalev Lember <kalevlember@gmail.com>
|
||||
Date: Thu, 30 Oct 2014 11:31:36 +0100
|
||||
Subject: [PATCH] Add --disable-tests to skip the building of tests
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=739395
|
||||
---
|
||||
Makefile.am | 6 +++++-
|
||||
configure.ac | 12 ++++++++----
|
||||
2 files changed, 13 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index e5c5d07..8a54690 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,4 +1,8 @@
|
||||
-SUBDIRS = . gdata/tests po docs
|
||||
+SUBDIRS = . po docs
|
||||
+
|
||||
+if ENABLE_TESTS
|
||||
+SUBDIRS += gdata/tests
|
||||
+endif
|
||||
|
||||
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c578235..ae57c49 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -149,10 +149,14 @@ AC_SUBST([GNOME_PACKAGES_PRIVATE])
|
||||
AC_SUBST([GNOME_PACKAGES])
|
||||
AC_SUBST([GOA_ENABLED])
|
||||
|
||||
-dnl ****************************
|
||||
-dnl Check for uhttpmock
|
||||
-dnl ****************************
|
||||
-PKG_CHECK_MODULES(UHTTPMOCK, libuhttpmock-0.0)
|
||||
+AC_MSG_CHECKING([whether to build tests])
|
||||
+AC_ARG_ENABLE([tests], AS_HELP_STRING([--enable-tests], [Enable building of tests]),, [enable_tests=yes])
|
||||
+AC_MSG_RESULT($enable_tests)
|
||||
+AM_CONDITIONAL([ENABLE_TESTS], [test "x$enable_tests" = "xyes"])
|
||||
+
|
||||
+if test "x$enable_tests" = "xyes"; then
|
||||
+ PKG_CHECK_MODULES(UHTTPMOCK, libuhttpmock-0.0)
|
||||
+fi
|
||||
|
||||
# Various necessary functions and headers
|
||||
AC_CHECK_FUNCS([memset])
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: libgdata
|
||||
Version: 0.16.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.16.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Library for the GData protocol
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -8,9 +8,6 @@ License: LGPLv2+
|
||||
URL: http://live.gnome.org/libgdata
|
||||
Source0: http://download.gnome.org/sources/%{name}/0.16/%{name}-%{version}.tar.xz
|
||||
|
||||
# Backported upstream patch to allow building without uhttpmock
|
||||
Patch0: 0001-Add-disable-tests-to-skip-the-building-of-tests.patch
|
||||
|
||||
BuildRequires: gcr-devel
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: gnome-online-accounts-devel
|
||||
@ -26,8 +23,6 @@ BuildRequires: libsoup-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: vala-devel
|
||||
BuildRequires: vala-tools
|
||||
# For patch0
|
||||
BuildRequires: autoconf automake libtool
|
||||
|
||||
Requires: gobject-introspection
|
||||
|
||||
@ -47,8 +42,6 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .no-uhttpmock
|
||||
autoreconf -fi
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -90,6 +83,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
%{_datadir}/vala/
|
||||
|
||||
%changelog
|
||||
* Mon Nov 10 2014 Kalev Lember <kalevlember@gmail.com> - 0.16.1-1
|
||||
- Update to 0.16.1
|
||||
|
||||
* Mon Nov 03 2014 Kalev Lember <kalevlember@gmail.com> - 0.16.0-2
|
||||
- Fix the build on RHEL
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user