- with the integrity verification check the library needs to link to libdl
(#488702)
This commit is contained in:
parent
4b8542ad6d
commit
e569e43744
@ -1,6 +1,6 @@
|
|||||||
diff -up libgcrypt-1.4.4/src/fips.c.use-fipscheck libgcrypt-1.4.4/src/fips.c
|
diff -up libgcrypt-1.4.4/src/fips.c.use-fipscheck libgcrypt-1.4.4/src/fips.c
|
||||||
--- libgcrypt-1.4.4/src/fips.c.use-fipscheck 2009-03-03 18:10:49.000000000 +0100
|
--- libgcrypt-1.4.4/src/fips.c.use-fipscheck 2009-03-03 21:09:27.000000000 +0100
|
||||||
+++ libgcrypt-1.4.4/src/fips.c 2009-03-03 18:51:31.000000000 +0100
|
+++ libgcrypt-1.4.4/src/fips.c 2009-03-05 11:20:48.000000000 +0100
|
||||||
@@ -570,23 +570,48 @@ run_random_selftests (void)
|
@@ -570,23 +570,48 @@ run_random_selftests (void)
|
||||||
return !!err;
|
return !!err;
|
||||||
}
|
}
|
||||||
@ -72,3 +72,15 @@ diff -up libgcrypt-1.4.4/src/fips.c.use-fipscheck libgcrypt-1.4.4/src/fips.c
|
|||||||
p = strrchr (fname, '/');
|
p = strrchr (fname, '/');
|
||||||
if (p)
|
if (p)
|
||||||
p++;
|
p++;
|
||||||
|
diff -up libgcrypt-1.4.4/src/Makefile.use-fipscheck libgcrypt-1.4.4/src/Makefile
|
||||||
|
--- libgcrypt-1.4.4/src/Makefile.use-fipscheck 2009-03-03 21:09:41.000000000 +0100
|
||||||
|
+++ libgcrypt-1.4.4/src/Makefile 2009-03-05 11:20:40.000000000 +0100
|
||||||
|
@@ -337,7 +337,7 @@ libgcrypt_la_LIBADD = \
|
||||||
|
../cipher/libcipher.la \
|
||||||
|
../random/librandom.la \
|
||||||
|
../mpi/libmpi.la \
|
||||||
|
- -lgpg-error
|
||||||
|
+ -lgpg-error -ldl
|
||||||
|
|
||||||
|
dumpsexp_SOURCES = dumpsexp.c
|
||||||
|
dumpsexp_LDADD =
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Name: libgcrypt
|
Name: libgcrypt
|
||||||
Version: 1.4.4
|
Version: 1.4.4
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Source0: libgcrypt-%{version}-hobbled.tar.bz2
|
Source0: libgcrypt-%{version}-hobbled.tar.bz2
|
||||||
# The original libgcrypt sources now contain potentially patented ECC
|
# The original libgcrypt sources now contain potentially patented ECC
|
||||||
# cipher support. We have to remove it in the tarball we ship with
|
# cipher support. We have to remove it in the tarball we ship with
|
||||||
@ -145,6 +145,10 @@ exit 0
|
|||||||
%{_infodir}/gcrypt.info*
|
%{_infodir}/gcrypt.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 5 2009 Tomas Mraz <tmraz@redhat.com> 1.4.4-4
|
||||||
|
- with the integrity verification check the library needs to link to libdl
|
||||||
|
(#488702)
|
||||||
|
|
||||||
* Tue Mar 3 2009 Tomas Mraz <tmraz@redhat.com> 1.4.4-3
|
* Tue Mar 3 2009 Tomas Mraz <tmraz@redhat.com> 1.4.4-3
|
||||||
- add hmac FIPS integrity verification check
|
- add hmac FIPS integrity verification check
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user