Fix regression - missing -ldl linkage
This commit is contained in:
parent
618a71d4e9
commit
a51c9f8187
@ -1,7 +1,7 @@
|
|||||||
diff -up libgcrypt-1.6.2/src/fips.c.use-fipscheck libgcrypt-1.6.2/src/fips.c
|
diff -up libgcrypt-1.8.5/src/fips.c.use-fipscheck libgcrypt-1.8.5/src/fips.c
|
||||||
--- libgcrypt-1.6.2/src/fips.c.use-fipscheck 2014-08-21 14:50:39.000000000 +0200
|
--- libgcrypt-1.8.5/src/fips.c.use-fipscheck 2017-11-23 19:16:58.000000000 +0100
|
||||||
+++ libgcrypt-1.6.2/src/fips.c 2014-09-26 11:42:20.999588282 +0200
|
+++ libgcrypt-1.8.5/src/fips.c 2020-04-23 10:18:36.235764741 +0200
|
||||||
@@ -578,23 +578,50 @@ run_random_selftests (void)
|
@@ -581,23 +581,50 @@ run_random_selftests (void)
|
||||||
return !!err;
|
return !!err;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -57,7 +57,7 @@ diff -up libgcrypt-1.6.2/src/fips.c.use-fipscheck libgcrypt-1.6.2/src/fips.c
|
|||||||
key, strlen (key));
|
key, strlen (key));
|
||||||
if (dlen < 0)
|
if (dlen < 0)
|
||||||
err = gpg_error_from_syserror ();
|
err = gpg_error_from_syserror ();
|
||||||
@@ -602,7 +629,7 @@ check_binary_integrity (void)
|
@@ -605,7 +632,7 @@ check_binary_integrity (void)
|
||||||
err = gpg_error (GPG_ERR_INTERNAL);
|
err = gpg_error (GPG_ERR_INTERNAL);
|
||||||
else
|
else
|
||||||
{
|
{
|
||||||
@ -66,7 +66,7 @@ diff -up libgcrypt-1.6.2/src/fips.c.use-fipscheck libgcrypt-1.6.2/src/fips.c
|
|||||||
if (!fname)
|
if (!fname)
|
||||||
err = gpg_error_from_syserror ();
|
err = gpg_error_from_syserror ();
|
||||||
else
|
else
|
||||||
@@ -611,7 +638,7 @@ check_binary_integrity (void)
|
@@ -614,7 +641,7 @@ check_binary_integrity (void)
|
||||||
char *p;
|
char *p;
|
||||||
|
|
||||||
/* Prefix the basename with a dot. */
|
/* Prefix the basename with a dot. */
|
||||||
@ -75,15 +75,15 @@ diff -up libgcrypt-1.6.2/src/fips.c.use-fipscheck libgcrypt-1.6.2/src/fips.c
|
|||||||
p = strrchr (fname, '/');
|
p = strrchr (fname, '/');
|
||||||
if (p)
|
if (p)
|
||||||
p++;
|
p++;
|
||||||
diff -up libgcrypt-1.6.2/src/Makefile.in.use-fipscheck libgcrypt-1.6.2/src/Makefile.in
|
diff -up libgcrypt-1.8.5/src/Makefile.am.use-fipscheck libgcrypt-1.8.5/src/Makefile.am
|
||||||
--- libgcrypt-1.6.2/src/Makefile.in.use-fipscheck 2014-08-21 15:14:08.000000000 +0200
|
--- libgcrypt-1.8.5/src/Makefile.am.use-fipscheck 2020-04-23 10:18:36.237764702 +0200
|
||||||
+++ libgcrypt-1.6.2/src/Makefile.in 2014-09-26 11:41:13.271059281 +0200
|
+++ libgcrypt-1.8.5/src/Makefile.am 2020-04-23 10:19:03.186247455 +0200
|
||||||
@@ -449,7 +449,7 @@ libgcrypt_la_LIBADD = $(gcrypt_res) \
|
@@ -125,7 +125,7 @@ libgcrypt_la_LIBADD = $(gcrypt_res) \
|
||||||
../cipher/libcipher.la \
|
../cipher/libcipher.la \
|
||||||
../random/librandom.la \
|
../random/librandom.la \
|
||||||
../mpi/libmpi.la \
|
../mpi/libmpi.la \
|
||||||
- ../compat/libcompat.la $(GPG_ERROR_LIBS)
|
- ../compat/libcompat.la $(GPG_ERROR_LIBS)
|
||||||
+ ../compat/libcompat.la $(GPG_ERROR_LIBS) -ldl
|
+ ../compat/libcompat.la $(GPG_ERROR_LIBS) -ldl
|
||||||
|
|
||||||
|
|
||||||
dumpsexp_SOURCES = dumpsexp.c
|
dumpsexp_SOURCES = dumpsexp.c
|
||||||
dumpsexp_CFLAGS = $(arch_gpg_error_cflags)
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: libgcrypt
|
Name: libgcrypt
|
||||||
Version: 1.8.5
|
Version: 1.8.5
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
URL: http://www.gnupg.org/
|
URL: http://www.gnupg.org/
|
||||||
Source0: libgcrypt-%{version}-hobbled.tar.xz
|
Source0: libgcrypt-%{version}-hobbled.tar.xz
|
||||||
# The original libgcrypt sources now contain potentially patented ECC
|
# The original libgcrypt sources now contain potentially patented ECC
|
||||||
@ -18,7 +18,7 @@ Source6: t-mpi-point.c
|
|||||||
Source7: random.conf
|
Source7: random.conf
|
||||||
# make FIPS hmac compatible with fipscheck - non upstreamable
|
# make FIPS hmac compatible with fipscheck - non upstreamable
|
||||||
# update on soname bump
|
# update on soname bump
|
||||||
Patch2: libgcrypt-1.6.2-use-fipscheck.patch
|
Patch2: libgcrypt-1.8.5-use-fipscheck.patch
|
||||||
# modify FIPS RSA and DSA keygen to comply with requirements
|
# modify FIPS RSA and DSA keygen to comply with requirements
|
||||||
Patch5: libgcrypt-1.8.4-fips-keygen.patch
|
Patch5: libgcrypt-1.8.4-fips-keygen.patch
|
||||||
# fix the tests to work correctly in the FIPS mode
|
# fix the tests to work correctly in the FIPS mode
|
||||||
@ -202,6 +202,9 @@ install -m644 %{SOURCE7} $RPM_BUILD_ROOT/etc/gcrypt/random.conf
|
|||||||
%license COPYING
|
%license COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 23 2020 Tomáš Mráz <tmraz@redhat.com> 1.8.5-6
|
||||||
|
- Fix regression - missing -ldl linkage
|
||||||
|
|
||||||
* Wed Apr 22 2020 Tomáš Mráz <tmraz@redhat.com> 1.8.5-5
|
* Wed Apr 22 2020 Tomáš Mráz <tmraz@redhat.com> 1.8.5-5
|
||||||
- AES performance improvements backported from master branch
|
- AES performance improvements backported from master branch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user