drop the temporary compat shared library version
- fix the soname version in -use-fipscheck.patch
This commit is contained in:
parent
45af5b745b
commit
85a7dd9dad
@ -46,7 +46,7 @@ diff -up libgcrypt-1.5.0/src/fips.c.use-fipscheck libgcrypt-1.5.0/src/fips.c
|
|||||||
- if (!dladdr ("gcry_check_version", &info))
|
- if (!dladdr ("gcry_check_version", &info))
|
||||||
+ const char key[] = "orboDeJITITejsirpADONivirpUkvarP";
|
+ const char key[] = "orboDeJITITejsirpADONivirpUkvarP";
|
||||||
+
|
+
|
||||||
+ if (get_library_path ("libgcrypt.so.11", "gcry_check_version", libpath, sizeof(libpath)))
|
+ if (get_library_path ("libgcrypt.so.20", "gcry_check_version", libpath, sizeof(libpath)))
|
||||||
err = gpg_error_from_syserror ();
|
err = gpg_error_from_syserror ();
|
||||||
else
|
else
|
||||||
{
|
{
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
diff -up libgcrypt-1.5.2/cipher/Makefile.am.aliasing libgcrypt-1.5.2/cipher/Makefile.am
|
|
||||||
--- libgcrypt-1.5.2/cipher/Makefile.am.aliasing 2013-04-18 16:49:13.000000000 +0200
|
|
||||||
+++ libgcrypt-1.5.2/cipher/Makefile.am 2013-04-25 21:48:57.867465215 +0200
|
|
||||||
@@ -81,3 +81,9 @@ tiger.o: $(srcdir)/tiger.c
|
|
||||||
|
|
||||||
tiger.lo: $(srcdir)/tiger.c
|
|
||||||
`echo $(LTCOMPILE) -c $(srcdir)/tiger.c | $(o_flag_munging) `
|
|
||||||
+
|
|
||||||
+rijndael.o: $(srcdir)/rijndael.c
|
|
||||||
+ `echo $(COMPILE) -fno-strict-aliasing -c $(srcdir)/rijndael.c `
|
|
||||||
+
|
|
||||||
+rijndael.lo: $(srcdir)/rijndael.c
|
|
||||||
+ `echo $(LTCOMPILE) -fno-strict-aliasing -c $(srcdir)/rijndael.c `
|
|
||||||
diff -up libgcrypt-1.5.2/cipher/Makefile.in.aliasing libgcrypt-1.5.2/cipher/Makefile.in
|
|
||||||
--- libgcrypt-1.5.2/cipher/Makefile.in.aliasing 2013-04-18 17:06:03.000000000 +0200
|
|
||||||
+++ libgcrypt-1.5.2/cipher/Makefile.in 2013-04-25 21:48:59.164493610 +0200
|
|
||||||
@@ -638,6 +638,12 @@ tiger.o: $(srcdir)/tiger.c
|
|
||||||
tiger.lo: $(srcdir)/tiger.c
|
|
||||||
`echo $(LTCOMPILE) -c $(srcdir)/tiger.c | $(o_flag_munging) `
|
|
||||||
|
|
||||||
+rijndael.o: $(srcdir)/rijndael.c
|
|
||||||
+ `echo $(COMPILE) -fno-strict-aliasing -c $(srcdir)/rijndael.c `
|
|
||||||
+
|
|
||||||
+rijndael.lo: $(srcdir)/rijndael.c
|
|
||||||
+ `echo $(LTCOMPILE) -fno-strict-aliasing -c $(srcdir)/rijndael.c `
|
|
||||||
+
|
|
||||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
||||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
||||||
.NOEXPORT:
|
|
||||||
diff -up libgcrypt-1.5.2/cipher/rijndael.c.aliasing libgcrypt-1.5.2/cipher/rijndael.c
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: libgcrypt
|
Name: libgcrypt
|
||||||
Version: 1.6.1
|
Version: 1.6.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
URL: http://www.gnupg.org/
|
URL: http://www.gnupg.org/
|
||||||
Source0: libgcrypt-%{version}-hobbled.tar.xz
|
Source0: libgcrypt-%{version}-hobbled.tar.xz
|
||||||
# The original libgcrypt sources now contain potentially patented ECC
|
# The original libgcrypt sources now contain potentially patented ECC
|
||||||
@ -16,6 +16,7 @@ Source4: ecc-curves.c
|
|||||||
Source5: curves.c
|
Source5: curves.c
|
||||||
Source6: t-mpi-point.c
|
Source6: t-mpi-point.c
|
||||||
# make FIPS hmac compatible with fipscheck - non upstreamable
|
# make FIPS hmac compatible with fipscheck - non upstreamable
|
||||||
|
# update on soname bump
|
||||||
Patch2: libgcrypt-1.5.0-use-fipscheck.patch
|
Patch2: libgcrypt-1.5.0-use-fipscheck.patch
|
||||||
# fix tests in the FIPS mode, fix the FIPS-186-3 DSA keygen
|
# fix tests in the FIPS mode, fix the FIPS-186-3 DSA keygen
|
||||||
Patch5: libgcrypt-1.6.1-tests.patch
|
Patch5: libgcrypt-1.6.1-tests.patch
|
||||||
@ -28,8 +29,6 @@ Patch7: libgcrypt-1.6.1-fips-cavs.patch
|
|||||||
Patch9: libgcrypt-1.6.1-leak.patch
|
Patch9: libgcrypt-1.6.1-leak.patch
|
||||||
# use poll instead of select when gathering randomness
|
# use poll instead of select when gathering randomness
|
||||||
Patch11: libgcrypt-1.6.1-use-poll.patch
|
Patch11: libgcrypt-1.6.1-use-poll.patch
|
||||||
# compile rijndael with -fno-strict-aliasing
|
|
||||||
Patch12: libgcrypt-1.5.2-aliasing.patch
|
|
||||||
# slight optimalization of mpicoder.c to silence Valgrind (#968288)
|
# slight optimalization of mpicoder.c to silence Valgrind (#968288)
|
||||||
Patch13: libgcrypt-1.6.1-mpicoder-gccopt.patch
|
Patch13: libgcrypt-1.6.1-mpicoder-gccopt.patch
|
||||||
# fix tests to work with approved ECC
|
# fix tests to work with approved ECC
|
||||||
@ -42,7 +41,7 @@ Patch14: libgcrypt-1.6.1-ecc-test-fix.patch
|
|||||||
# are in the devel subpackage.
|
# are in the devel subpackage.
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Summary: A general-purpose cryptography library
|
Summary: A general-purpose cryptography library
|
||||||
BuildRequires: gawk, libgpg-error-devel >= 1.4, pkgconfig
|
BuildRequires: gawk, libgpg-error-devel >= 1.11, pkgconfig
|
||||||
BuildRequires: fipscheck
|
BuildRequires: fipscheck
|
||||||
# This is needed only when patching the .texi doc.
|
# This is needed only when patching the .texi doc.
|
||||||
BuildRequires: texinfo
|
BuildRequires: texinfo
|
||||||
@ -75,7 +74,6 @@ applications using libgcrypt.
|
|||||||
%patch7 -p1 -b .cavs
|
%patch7 -p1 -b .cavs
|
||||||
%patch9 -p1 -b .leak
|
%patch9 -p1 -b .leak
|
||||||
%patch11 -p1 -b .use-poll
|
%patch11 -p1 -b .use-poll
|
||||||
#%patch12 -p1 -b .aliasing
|
|
||||||
%patch13 -p1 -b .gccopt
|
%patch13 -p1 -b .gccopt
|
||||||
%patch14 -p1 -b .eccfix
|
%patch14 -p1 -b .eccfix
|
||||||
cp %{SOURCE4} cipher/
|
cp %{SOURCE4} cipher/
|
||||||
@ -129,23 +127,21 @@ for shlib in $RPM_BUILD_ROOT%{_libdir}/*.so* ; do
|
|||||||
fi
|
fi
|
||||||
done
|
done
|
||||||
|
|
||||||
|
# Add soname symlink.
|
||||||
|
/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_lib}/
|
||||||
|
%endif
|
||||||
|
|
||||||
# Overwrite development symlinks.
|
# Overwrite development symlinks.
|
||||||
pushd $RPM_BUILD_ROOT/%{_libdir}
|
pushd $RPM_BUILD_ROOT/%{gcrylibdir}
|
||||||
for shlib in %{gcrylibdir}/lib*.so.* ; do
|
for shlib in lib*.so.?? ; do
|
||||||
shlib=`echo "$shlib" | sed -e 's,//,/,g'`
|
target=$RPM_BUILD_ROOT/%{_libdir}/`echo "$shlib" | sed -e 's,\.so.*,,g'`.so
|
||||||
target=`basename "$shlib" | sed -e 's,\.so.*,,g'`.so
|
%if "%{gcrylibdir}" != "%{_libdir}"
|
||||||
|
shlib=%{gcrylibdir}/$shlib
|
||||||
|
%endif
|
||||||
ln -sf $shlib $target
|
ln -sf $shlib $target
|
||||||
done
|
done
|
||||||
popd
|
popd
|
||||||
|
|
||||||
# Add soname symlink.
|
|
||||||
/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_lib}/
|
|
||||||
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# temporary compat library for buildroots
|
|
||||||
install %{gcrylibdir}/libgcrypt.so.11.*.* $RPM_BUILD_ROOT/%{_libdir}
|
|
||||||
|
|
||||||
# Create /etc/gcrypt (hardwired, not dependent on the configure invocation) so
|
# Create /etc/gcrypt (hardwired, not dependent on the configure invocation) so
|
||||||
# that _someone_ owns it.
|
# that _someone_ owns it.
|
||||||
mkdir -p -m 755 $RPM_BUILD_ROOT/etc/gcrypt
|
mkdir -p -m 755 $RPM_BUILD_ROOT/etc/gcrypt
|
||||||
@ -187,6 +183,10 @@ exit 0
|
|||||||
%doc COPYING
|
%doc COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 24 2014 Tomáš Mráz <tmraz@redhat.com> 1.6.1-2
|
||||||
|
- drop the temporary compat shared library version
|
||||||
|
- fix the soname version in -use-fipscheck.patch
|
||||||
|
|
||||||
* Fri Feb 28 2014 Tomáš Mráz <tmraz@redhat.com> 1.6.1-1
|
* Fri Feb 28 2014 Tomáš Mráz <tmraz@redhat.com> 1.6.1-1
|
||||||
- new upstream version breaking ABI compatibility
|
- new upstream version breaking ABI compatibility
|
||||||
- this release temporarily includes old compatibility .so
|
- this release temporarily includes old compatibility .so
|
||||||
|
Loading…
Reference in New Issue
Block a user