libgcrypt-1.10.0-0.3
Fix bad soname in the beta tarball Related: rhbz#2026636
This commit is contained in:
parent
e89d5d8b63
commit
554d85f093
27
libgcrypt-1.10.0-soname.patch
Normal file
27
libgcrypt-1.10.0-soname.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 2ef408ba09e93aa9b4e352908c9443b247a656ea Mon Sep 17 00:00:00 2001
|
||||||
|
From: Werner Koch <wk@gnupg.org>
|
||||||
|
Date: Thu, 27 Jan 2022 15:35:39 +0100
|
||||||
|
Subject: [PATCH] build: Fix accidental SO number bump.
|
||||||
|
|
||||||
|
--
|
||||||
|
Fixes-commit: 65998903f6d17e702fb35b9d4878e33715981298
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 6e038412..4f2988eb 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -56,7 +56,7 @@ AC_INIT([mym4_package],[mym4_version],[https://bugs.gnupg.org])
|
||||||
|
# (Interfaces added: CURRENT++, AGE++, REVISION=0)
|
||||||
|
# (No interfaces changed: REVISION++)
|
||||||
|
LIBGCRYPT_LT_CURRENT=24
|
||||||
|
-LIBGCRYPT_LT_AGE=0
|
||||||
|
+LIBGCRYPT_LT_AGE=4
|
||||||
|
LIBGCRYPT_LT_REVISION=0
|
||||||
|
################################################
|
||||||
|
|
||||||
|
--
|
||||||
|
2.34.1
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: libgcrypt
|
Name: libgcrypt
|
||||||
Version: 1.10.0
|
Version: 1.10.0
|
||||||
Release: 0.2%{?dist}
|
Release: 0.3%{?dist}
|
||||||
URL: https://www.gnupg.org/
|
URL: https://www.gnupg.org/
|
||||||
%global beta -beta221
|
%global beta -beta221
|
||||||
#Source0: https://www.gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-{version}.tar.bz2
|
#Source0: https://www.gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-{version}.tar.bz2
|
||||||
@ -9,9 +9,11 @@ Source0: https://www.gnupg.org/ftp/gcrypt/alpha/libgcrypt/libgcrypt-%{version}%{
|
|||||||
Source1: https://www.gnupg.org/ftp/gcrypt/alpha/libgcrypt/libgcrypt-%{version}%{beta}.tar.bz2.sig
|
Source1: https://www.gnupg.org/ftp/gcrypt/alpha/libgcrypt/libgcrypt-%{version}%{beta}.tar.bz2.sig
|
||||||
Source2: wk@g10code.com
|
Source2: wk@g10code.com
|
||||||
Patch1: libgcrypt-1.10.0-disable-brainpool.patch
|
Patch1: libgcrypt-1.10.0-disable-brainpool.patch
|
||||||
|
# Broken soname in the 1.10.0 beta release
|
||||||
|
Patch2: libgcrypt-1.10.0-soname.patch
|
||||||
|
|
||||||
%global gcrylibdir %{_libdir}
|
%global gcrylibdir %{_libdir}
|
||||||
%global gcrysoname libgcrypt.so.24
|
%global gcrysoname libgcrypt.so.20
|
||||||
%global hmackey orboDeJITITejsirpADONivirpUkvarP
|
%global hmackey orboDeJITITejsirpADONivirpUkvarP
|
||||||
|
|
||||||
# Technically LGPLv2.1+, but Fedora's table doesn't draw a distinction.
|
# Technically LGPLv2.1+, but Fedora's table doesn't draw a distinction.
|
||||||
@ -45,6 +47,7 @@ applications using libgcrypt.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n libgcrypt-1.10.0%{beta}
|
%setup -q -n libgcrypt-1.10.0%{beta}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# This package has a configure test which uses ASMs, but does not link the
|
# This package has a configure test which uses ASMs, but does not link the
|
||||||
@ -128,9 +131,6 @@ done
|
|||||||
/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_lib}/
|
/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_lib}/
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# This is a compat version after the soname bump to .24
|
|
||||||
install %{gcrylibdir}/libgcrypt.so.20.*.* $RPM_BUILD_ROOT/%{_libdir}
|
|
||||||
|
|
||||||
# Overwrite development symlinks.
|
# Overwrite development symlinks.
|
||||||
pushd $RPM_BUILD_ROOT/%{gcrylibdir}
|
pushd $RPM_BUILD_ROOT/%{gcrylibdir}
|
||||||
for shlib in lib*.so.?? ; do
|
for shlib in lib*.so.?? ; do
|
||||||
@ -152,7 +152,6 @@ mkdir -p -m 755 $RPM_BUILD_ROOT/etc/gcrypt
|
|||||||
%dir /etc/gcrypt
|
%dir /etc/gcrypt
|
||||||
%{gcrylibdir}/libgcrypt.so.*.*
|
%{gcrylibdir}/libgcrypt.so.*.*
|
||||||
%{gcrylibdir}/%{gcrysoname}
|
%{gcrylibdir}/%{gcrysoname}
|
||||||
%{gcrylibdir}/libgcrypt.so.20
|
|
||||||
%license COPYING.LIB
|
%license COPYING.LIB
|
||||||
%doc AUTHORS NEWS THANKS
|
%doc AUTHORS NEWS THANKS
|
||||||
|
|
||||||
@ -171,6 +170,9 @@ mkdir -p -m 755 $RPM_BUILD_ROOT/etc/gcrypt
|
|||||||
%license COPYING
|
%license COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 27 2022 Jakub Jelen <jjelen@redhat.com> - 1.10.0-0.3
|
||||||
|
- Fix broken soname in the previous beta
|
||||||
|
|
||||||
* Thu Jan 27 2022 Jakub Jelen <jjelen@redhat.com> - 1.10.0-0.2
|
* Thu Jan 27 2022 Jakub Jelen <jjelen@redhat.com> - 1.10.0-0.2
|
||||||
- Provide compat soname symlink as the new release is backward compatible
|
- Provide compat soname symlink as the new release is backward compatible
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user