libgcrypt-1.10.2-1
* Remove already-applied patches * Avoid using deprecated %patchN
This commit is contained in:
parent
a17db7fa58
commit
021f499feb
2
.gitignore
vendored
2
.gitignore
vendored
@ -32,3 +32,5 @@ libgcrypt-1.4.5-hobbled.tar.bz2
|
||||
/libgcrypt-1.10.0.tar.bz2.sig
|
||||
/libgcrypt-1.10.1.tar.bz2
|
||||
/libgcrypt-1.10.1.tar.bz2.sig
|
||||
/libgcrypt-1.10.2.tar.bz2
|
||||
/libgcrypt-1.10.2.tar.bz2.sig
|
||||
|
@ -1,55 +0,0 @@
|
||||
From cd30ed3c0d715aa0c58a32a29cfb1476163a5b94 Mon Sep 17 00:00:00 2001
|
||||
From: NIIBE Yutaka <gniibe@fsij.org>
|
||||
Date: Wed, 20 Apr 2022 15:09:41 +0900
|
||||
Subject: [PATCH] cipher: Change the bounds for RSA key generation round.
|
||||
|
||||
* cipher/rsa.c (generate_fips): Use 10 for p, 20 for q.
|
||||
|
||||
--
|
||||
|
||||
Constants from FIPS 186-5-draft.
|
||||
|
||||
GnuPG-bug-id: 5919
|
||||
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
||||
---
|
||||
cipher/rsa.c | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/cipher/rsa.c b/cipher/rsa.c
|
||||
index 486a34f0..771413b3 100644
|
||||
--- a/cipher/rsa.c
|
||||
+++ b/cipher/rsa.c
|
||||
@@ -476,7 +476,7 @@ generate_fips (RSA_secret_key *sk, unsigned int nbits, unsigned long use_e,
|
||||
|
||||
retry:
|
||||
/* generate p and q */
|
||||
- for (i = 0; i < 5 * pbits; i++)
|
||||
+ for (i = 0; i < 10 * pbits; i++)
|
||||
{
|
||||
ploop:
|
||||
if (!testparms)
|
||||
@@ -506,10 +506,10 @@ generate_fips (RSA_secret_key *sk, unsigned int nbits, unsigned long use_e,
|
||||
else if (testparms)
|
||||
goto err;
|
||||
}
|
||||
- if (i >= 5 * pbits)
|
||||
+ if (i >= 10 * pbits)
|
||||
goto err;
|
||||
|
||||
- for (i = 0; i < 5 * pbits; i++)
|
||||
+ for (i = 0; i < 20 * pbits; i++)
|
||||
{
|
||||
qloop:
|
||||
if (!testparms)
|
||||
@@ -555,7 +555,7 @@ generate_fips (RSA_secret_key *sk, unsigned int nbits, unsigned long use_e,
|
||||
else if (testparms)
|
||||
goto err;
|
||||
}
|
||||
- if (i >= 5 * pbits)
|
||||
+ if (i >= 20 * pbits)
|
||||
goto err;
|
||||
|
||||
if (testparms)
|
||||
--
|
||||
2.38.1
|
||||
|
@ -1,140 +0,0 @@
|
||||
Add missing prototypes to test functions. Future compilers will not
|
||||
support implicit function declarations by default, causing spurious
|
||||
test failures.
|
||||
|
||||
Submitted upstream:
|
||||
|
||||
<https://lists.gnupg.org/pipermail/gcrypt-devel/2022-December/005410.html>
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6ea38f53b8548ee8..2baf25bc7d9481e6 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1211,7 +1211,8 @@ AC_CACHE_CHECK([whether GCC assembler is compatible for ARM assembly implementat
|
||||
/* Test if '.type' and '.size' are supported. */
|
||||
".size asmfunc,.-asmfunc;\n\t"
|
||||
".type asmfunc,%function;\n\t"
|
||||
- );]], [ asmfunc(); ] )],
|
||||
+ );
|
||||
+ void asmfunc(void);]], [ asmfunc(); ] )],
|
||||
[gcry_cv_gcc_arm_platform_as_ok=yes])
|
||||
fi])
|
||||
if test "$gcry_cv_gcc_arm_platform_as_ok" = "yes" ; then
|
||||
@@ -1238,7 +1239,8 @@ AC_CACHE_CHECK([whether GCC assembler is compatible for ARMv8/Aarch64 assembly i
|
||||
"eor x0, x0, x30, ror #12;\n\t"
|
||||
"add x0, x0, x30, asr #12;\n\t"
|
||||
"eor v0.16b, v0.16b, v31.16b;\n\t"
|
||||
- );]], [ asmfunc(); ] )],
|
||||
+ );
|
||||
+ void asmfunc(void);]], [ asmfunc(); ] )],
|
||||
[gcry_cv_gcc_aarch64_platform_as_ok=yes])
|
||||
fi])
|
||||
if test "$gcry_cv_gcc_aarch64_platform_as_ok" = "yes" ; then
|
||||
@@ -1267,7 +1269,8 @@ AC_CACHE_CHECK([whether GCC assembler supports for CFI directives],
|
||||
".cfi_restore_state\n\t"
|
||||
".long 0\n\t"
|
||||
".cfi_endproc\n\t"
|
||||
- );]])],
|
||||
+ );
|
||||
+ void asmfunc(void)]])],
|
||||
[gcry_cv_gcc_asm_cfi_directives=yes])])
|
||||
if test "$gcry_cv_gcc_asm_cfi_directives" = "yes" ; then
|
||||
AC_DEFINE(HAVE_GCC_ASM_CFI_DIRECTIVES,1,
|
||||
@@ -1666,7 +1669,8 @@ if test $amd64_as_feature_detection = yes; then
|
||||
[gcry_cv_gcc_as_const_division_ok],
|
||||
[gcry_cv_gcc_as_const_division_ok=no
|
||||
AC_LINK_IFELSE([AC_LANG_PROGRAM(
|
||||
- [[__asm__(".text\n\tfn:\n\t xorl \$(123456789/12345678), %ebp;\n\t");]],
|
||||
+ [[__asm__(".text\n\tfn:\n\t xorl \$(123456789/12345678), %ebp;\n\t");
|
||||
+ void fn(void);]],
|
||||
[fn();])],
|
||||
[gcry_cv_gcc_as_const_division_ok=yes])])
|
||||
if test "$gcry_cv_gcc_as_const_division_ok" = "no" ; then
|
||||
@@ -1679,7 +1683,8 @@ if test $amd64_as_feature_detection = yes; then
|
||||
[gcry_cv_gcc_as_const_division_with_wadivide_ok],
|
||||
[gcry_cv_gcc_as_const_division_with_wadivide_ok=no
|
||||
AC_LINK_IFELSE([AC_LANG_PROGRAM(
|
||||
- [[__asm__(".text\n\tfn:\n\t xorl \$(123456789/12345678), %ebp;\n\t");]],
|
||||
+ [[__asm__(".text\n\tfn:\n\t xorl \$(123456789/12345678), %ebp;\n\t");
|
||||
+ void fn(void);]],
|
||||
[fn();])],
|
||||
[gcry_cv_gcc_as_const_division_with_wadivide_ok=yes])])
|
||||
if test "$gcry_cv_gcc_as_const_division_with_wadivide_ok" = "no" ; then
|
||||
@@ -1715,7 +1720,8 @@ if test $amd64_as_feature_detection = yes; then
|
||||
* and "-Wa,--divide" workaround failed, this causes assembly
|
||||
* to be disable on this machine. */
|
||||
"xorl \$(123456789/12345678), %ebp;\n\t"
|
||||
- );]], [ asmfunc(); ])],
|
||||
+ );
|
||||
+ void asmfunc(void);]], [ asmfunc(); ])],
|
||||
[gcry_cv_gcc_amd64_platform_as_ok=yes])
|
||||
fi])
|
||||
if test "$gcry_cv_gcc_amd64_platform_as_ok" = "yes" ; then
|
||||
@@ -1734,7 +1740,8 @@ if test $amd64_as_feature_detection = yes; then
|
||||
".globl asmfunc\n\t"
|
||||
"asmfunc:\n\t"
|
||||
"xorq \$(1234), %rbp;\n\t"
|
||||
- );]], [ asmfunc(); ])],
|
||||
+ );
|
||||
+ void asmfunc(void);]], [ asmfunc(); ])],
|
||||
[gcry_cv_gcc_win64_platform_as_ok=yes])])
|
||||
if test "$gcry_cv_gcc_win64_platform_as_ok" = "yes" ; then
|
||||
AC_DEFINE(HAVE_COMPATIBLE_GCC_WIN64_PLATFORM_AS,1,
|
||||
@@ -1767,7 +1774,8 @@ AC_CACHE_CHECK([whether GCC assembler is compatible for Intel syntax assembly im
|
||||
"sub eax, [esp + 4];\n\t"
|
||||
"add dword ptr [esp + eax], 0b10101;\n\t"
|
||||
".att_syntax prefix\n\t"
|
||||
- );]], [ actest(); ])],
|
||||
+ );
|
||||
+ void actest(void);]], [ actest(); ])],
|
||||
[gcry_cv_gcc_platform_as_ok_for_intel_syntax=yes])
|
||||
fi])
|
||||
if test "$gcry_cv_gcc_platform_as_ok_for_intel_syntax" = "yes" ; then
|
||||
@@ -1832,6 +1840,7 @@ AC_CACHE_CHECK([whether GCC inline assembler supports NEON instructions],
|
||||
"vadd.u64 %q0, %q1;\n\t"
|
||||
"vadd.s64 %d3, %d2, %d3;\n\t"
|
||||
);
|
||||
+ void testfn(void);
|
||||
]], [ testfn(); ])],
|
||||
[gcry_cv_gcc_inline_asm_neon=yes])
|
||||
fi])
|
||||
@@ -1879,6 +1888,7 @@ AC_CACHE_CHECK([whether GCC inline assembler supports AArch32 Crypto Extension i
|
||||
|
||||
"vmull.p64 q0, d0, d0;\n\t"
|
||||
);
|
||||
+ void testfn(void);
|
||||
]], [ testfn(); ])],
|
||||
[gcry_cv_gcc_inline_asm_aarch32_crypto=yes])
|
||||
fi])
|
||||
@@ -1907,6 +1917,7 @@ AC_CACHE_CHECK([whether GCC inline assembler supports AArch64 NEON instructions]
|
||||
"dup v0.8b, w0;\n\t"
|
||||
"ld4 {v0.8b,v1.8b,v2.8b,v3.8b},[x0],\#32;\n\t"
|
||||
);
|
||||
+ void testfn(void);
|
||||
]], [ testfn(); ])],
|
||||
[gcry_cv_gcc_inline_asm_aarch64_neon=yes])
|
||||
fi])
|
||||
@@ -1955,6 +1966,7 @@ AC_CACHE_CHECK([whether GCC inline assembler supports AArch64 Crypto Extension i
|
||||
"pmull v0.1q, v0.1d, v31.1d;\n\t"
|
||||
"pmull2 v0.1q, v0.2d, v31.2d;\n\t"
|
||||
);
|
||||
+ void testfn(void);
|
||||
]], [ testfn(); ])],
|
||||
[gcry_cv_gcc_inline_asm_aarch64_crypto=yes])
|
||||
fi])
|
||||
@@ -2050,6 +2062,7 @@ AC_CACHE_CHECK([whether GCC inline assembler supports PowerPC AltiVec/VSX/crypto
|
||||
"vshasigmad %v0, %v1, 0, 15;\n"
|
||||
"vpmsumd %v11, %v11, %v11;\n"
|
||||
);
|
||||
+ void testfn(void);
|
||||
]], [ testfn(); ] )],
|
||||
[gcry_cv_gcc_inline_asm_ppc_altivec=yes])
|
||||
fi])
|
||||
@@ -2075,6 +2088,7 @@ AC_CACHE_CHECK([whether GCC inline assembler supports PowerISA 3.00 instructions
|
||||
"testfn:\n"
|
||||
"stxvb16x %r1,%v12,%v30;\n"
|
||||
);
|
||||
+ void testfn(void);
|
||||
]], [ testfn(); ])],
|
||||
[gcry_cv_gcc_inline_asm_ppc_arch_3_00=yes])
|
||||
fi])
|
@ -14,20 +14,14 @@ print(string.sub(hash, 0, 16))
|
||||
}
|
||||
|
||||
Name: libgcrypt
|
||||
Version: 1.10.1
|
||||
Release: 7%{?dist}
|
||||
Version: 1.10.2
|
||||
Release: 1%{?dist}
|
||||
URL: https://www.gnupg.org/
|
||||
Source0: https://www.gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-%{version}.tar.bz2
|
||||
Source1: https://www.gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-%{version}.tar.bz2.sig
|
||||
Source2: wk@g10code.com
|
||||
# Pass the annobin flags to the libgcrypt.so (#2016349)
|
||||
Patch1: libgcrypt-1.10.1-annobin.patch
|
||||
# https://dev.gnupg.org/T5919
|
||||
# tests occasionally fail with "error generating RSA key: Number is not prime"
|
||||
# https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=patch;h=cd30ed3c0
|
||||
Patch2: 0001-cipher-Change-the-bounds-for-RSA-key-generation-roun.patch
|
||||
|
||||
Patch3: libgcrypt-configure-c99.patch
|
||||
|
||||
%global gcrylibdir %{_libdir}
|
||||
%global gcrysoname libgcrypt.so.20
|
||||
@ -63,9 +57,7 @@ applications using libgcrypt.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch 1 -p1
|
||||
|
||||
%build
|
||||
# This package has a configure test which uses ASMs, but does not link the
|
||||
@ -183,6 +175,9 @@ mkdir -p -m 755 $RPM_BUILD_ROOT/etc/gcrypt
|
||||
%license COPYING
|
||||
|
||||
%changelog
|
||||
* Tue Apr 11 2023 Jakub Jelen <jjelen@redhat.com> - 1.10.2-1
|
||||
- New upstream release (#2185084)
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (libgcrypt-1.10.1.tar.bz2) = e5ca7966624fff16c3013795836a2c4377f0193dbb4ac5ad2b79654b1fa8992e17d83816569a402212dc8367a7980d4141f5d6ac282bae6b9f02186365b61f13
|
||||
SHA512 (libgcrypt-1.10.1.tar.bz2.sig) = b156ae05079776698bc95ba5a9e48e95de8f716aa1760ef4b2e7cb8518ccec660337fc7823f865bde870461800d472fd8e458d03a7095b6bb614f6dd96f796d8
|
||||
SHA512 (libgcrypt-1.10.2.tar.bz2) = 3a850baddfe8ffe8b3e96dc54af3fbb9e1dab204db1f06b9b90b8fbbfb7fb7276260cd1e61ba4dde5a662a2385385007478834e62e95f785d2e3d32652adb29e
|
||||
SHA512 (libgcrypt-1.10.2.tar.bz2.sig) = 9350444a0bcfa49217815a831f2286ccea470311673257bd809eb5dedbe97d2a5543b0bc7fb752312df69adeb7ac5f064e433f2545a8bf3e494027986cd8020c
|
||||
|
Loading…
Reference in New Issue
Block a user