60 lines
1.5 KiB
Diff
60 lines
1.5 KiB
Diff
From 06a58d71dcef5265d37539128b2beef006599706 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
|
|
Date: Mon, 16 Dec 2019 18:07:30 +0100
|
|
Subject: [PATCH 138/181] meson: Parse all private headers
|
|
|
|
So we don't have to list each one in case we add new enums.
|
|
Also, as per previous commit we can reorder them alphabetically.
|
|
---
|
|
libfprint/meson.build | 19 ++++++++++++-------
|
|
1 file changed, 12 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/libfprint/meson.build b/libfprint/meson.build
|
|
index 74908f4..781ea81 100644
|
|
--- a/libfprint/meson.build
|
|
+++ b/libfprint/meson.build
|
|
@@ -8,14 +8,14 @@ libfprint_sources = [
|
|
|
|
libfprint_private_sources = [
|
|
'fpi-assembling.c',
|
|
+ 'fpi-byte-reader.c',
|
|
+ 'fpi-byte-writer.c',
|
|
'fpi-device.c',
|
|
- 'fpi-image.c',
|
|
'fpi-image-device.c',
|
|
+ 'fpi-image.c',
|
|
'fpi-print.c',
|
|
'fpi-ssm.c',
|
|
'fpi-usb-transfer.c',
|
|
- 'fpi-byte-reader.c',
|
|
- 'fpi-byte-writer.c',
|
|
]
|
|
|
|
libfprint_public_headers = [
|
|
@@ -27,13 +27,18 @@ libfprint_public_headers = [
|
|
|
|
libfprint_private_headers = [
|
|
'fpi-assembling.h',
|
|
+ 'fpi-byte-reader.h',
|
|
+ 'fpi-byte-utils.h',
|
|
+ 'fpi-byte-writer.h',
|
|
+ 'fpi-context.h',
|
|
'fpi-device.h',
|
|
- 'fpi-image.h',
|
|
'fpi-image-device.h',
|
|
+ 'fpi-image.h',
|
|
+ 'fpi-log.h',
|
|
+ 'fpi-minutiae.h',
|
|
'fpi-print.h',
|
|
- 'fpi-byte-reader.h',
|
|
- 'fpi-byte-writer.h',
|
|
- 'fpi-byte-utils.h',
|
|
+ 'fpi-usb-transfer.h',
|
|
+ 'fpi-ssm.h',
|
|
]
|
|
|
|
nbis_sources = [
|
|
--
|
|
2.24.1
|
|
|