libfprint/SOURCES/0035-tests-Add-gdb-setup-to...

33 lines
942 B
Diff

From 923fc9e108a352a1fa4cad98a361cf4cdc233d25 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
Date: Tue, 26 Nov 2019 18:45:31 +0100
Subject: [PATCH 035/181] tests: Add 'gdb' setup to run tests using gdb
When using --setup=gdb the tests will be running using gdb, however this
as per meson limitation allows only running a test when using verbose mode.
---
tests/meson.build | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/tests/meson.build b/tests/meson.build
index 7987692..1645028 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -44,3 +44,13 @@ if get_option('introspection')
)
endif
endif
+
+gdb = find_program('gdb', required: false)
+if gdb.found()
+ add_test_setup('gdb',
+ timeout_multiplier: 1000,
+ env: [
+ 'LIBFPRINT_TEST_WRAPPER=@0@ --args'.format(
+ gdb.path())
+ ])
+endif
--
2.24.1