40 lines
1.2 KiB
Diff
40 lines
1.2 KiB
Diff
From 1fb15d4dc57bab6a34bfe6de0c9717809a9e4dfd Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
|
|
Date: Mon, 16 Dec 2019 19:05:35 +0100
|
|
Subject: [PATCH 143/181] meson: Use soversion everywhere
|
|
|
|
Don't repeat the 2 version number hard-coding it, so we can easily track
|
|
updates
|
|
---
|
|
libfprint/meson.build | 2 +-
|
|
meson.build | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libfprint/meson.build b/libfprint/meson.build
|
|
index 210e45c..8132a1b 100644
|
|
--- a/libfprint/meson.build
|
|
+++ b/libfprint/meson.build
|
|
@@ -293,7 +293,7 @@ if get_option('introspection')
|
|
libfprint_public_headers,
|
|
libfprint_sources,
|
|
],
|
|
- nsversion : '2.0',
|
|
+ nsversion : '@0@.0'.format(soversion),
|
|
namespace : 'FPrint',
|
|
symbol_prefix : 'fp_',
|
|
identifier_prefix : 'Fp',
|
|
diff --git a/meson.build b/meson.build
|
|
index 29bdff5..afd98db 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -208,5 +208,5 @@ pkgconfig.generate(
|
|
version: meson.project_version(),
|
|
libraries: libfprint,
|
|
subdirs: meson.project_name(),
|
|
- filebase: meson.project_name() + '2',
|
|
+ filebase: meson.project_name() + '@0@'.format(soversion),
|
|
)
|
|
--
|
|
2.24.1
|
|
|