libfprint/SOURCES/0142-meson-Use-more-meson-s-project_name.patch
2021-09-09 20:12:48 +00:00

80 lines
2.8 KiB
Diff

From 73b62b67c55639f4184f2c2de228b68f21093768 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
Date: Mon, 16 Dec 2019 19:02:00 +0100
Subject: [PATCH 142/181] meson: Use more meson's project_name()
Not that libfprint is long to write, but in case we'll ever change the
basename, we do it once.
---
doc/meson.build | 2 +-
doc/xml/meson.build | 6 +++---
libfprint/meson.build | 4 +++-
meson.build | 6 +++---
4 files changed, 10 insertions(+), 8 deletions(-)
diff --git a/doc/meson.build b/doc/meson.build
index bed320d..2c7a384 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -24,7 +24,7 @@ glib_prefix = dependency('glib-2.0').get_pkgconfig_variable('prefix')
glib_docpath = join_paths(glib_prefix, 'share', 'gtk-doc', 'html')
docpath = join_paths(get_option('datadir'), 'gtk-doc', 'html')
-gnome.gtkdoc('libfprint',
+gnome.gtkdoc(meson.project_name(),
main_xml: 'libfprint-docs.xml',
src_dir: join_paths(meson.source_root(), 'libfprint'),
dependencies: libfprint_dep,
diff --git a/doc/xml/meson.build b/doc/xml/meson.build
index 2ca1100..5e56bb4 100644
--- a/doc/xml/meson.build
+++ b/doc/xml/meson.build
@@ -1,8 +1,8 @@
ent_conf = configuration_data()
-ent_conf.set('PACKAGE', 'libfprint')
+ent_conf.set('PACKAGE', meson.project_name())
ent_conf.set('PACKAGE_BUGREPORT', 'https://gitlab.freedesktop.org/libfprint/libfprint/issues')
-ent_conf.set('PACKAGE_NAME', 'libfprint')
-ent_conf.set('PACKAGE_STRING', 'libfprint')
+ent_conf.set('PACKAGE_NAME', meson.project_name())
+ent_conf.set('PACKAGE_STRING', meson.project_name())
ent_conf.set('PACKAGE_TARNAME', 'libfprint-' + meson.project_version())
ent_conf.set('PACKAGE_URL', 'https://fprint.freedesktop.org/')
ent_conf.set('PACKAGE_VERSION', meson.project_version())
diff --git a/libfprint/meson.build b/libfprint/meson.build
index 23ab60a..210e45c 100644
--- a/libfprint/meson.build
+++ b/libfprint/meson.build
@@ -251,7 +251,9 @@ libfprint_dep = declare_dependency(link_with: libfprint,
gusb_dep,
])
-install_headers(['fprint.h'] + libfprint_public_headers, subdir: 'libfprint')
+install_headers(['fprint.h'] + libfprint_public_headers,
+ subdir: meson.project_name()
+)
libfprint_private_dep = declare_dependency(
include_directories: include_directories('.'),
diff --git a/meson.build b/meson.build
index 1d101a7..29bdff5 100644
--- a/meson.build
+++ b/meson.build
@@ -203,10 +203,10 @@ subdir('tests')
pkgconfig = import('pkgconfig')
pkgconfig.generate(
- name: 'libfprint',
+ name: meson.project_name(),
description: 'Generic C API for fingerprint reader access',
version: meson.project_version(),
libraries: libfprint,
- subdirs: 'libfprint',
- filebase: 'libfprint2',
+ subdirs: meson.project_name(),
+ filebase: meson.project_name() + '2',
)
--
2.24.1