libfprint/SOURCES/0129-meson-Split-single-line-dependencies-to-reduce-the-d.patch
2021-09-09 20:12:48 +00:00

77 lines
2.3 KiB
Diff

From ff490a0222987dcb5a618d7ea73743289ba56ec1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
Date: Fri, 13 Dec 2019 19:33:12 +0100
Subject: [PATCH 129/181] meson: Split single-line dependencies to reduce the
diff on changes
Make it more readable and in case we add something else, it's easier to track
---
demo/meson.build | 5 ++++-
examples/meson.build | 5 ++++-
libfprint/meson.build | 11 +++++++++--
3 files changed, 17 insertions(+), 4 deletions(-)
diff --git a/demo/meson.build b/demo/meson.build
index 20f8962..68d865f 100644
--- a/demo/meson.build
+++ b/demo/meson.build
@@ -9,7 +9,10 @@ datadir = join_paths(prefix, get_option('datadir'))
executable('gtk-libfprint-test',
[ 'gtk-libfprint-test.c', gtk_test_resources ],
- dependencies: [ libfprint_dep, gtk_dep ],
+ dependencies: [
+ gtk_dep,
+ libfprint_dep,
+ ],
c_args: '-DPACKAGE_VERSION="' + meson.project_version() + '"',
install: true,
install_dir: bindir)
diff --git a/examples/meson.build b/examples/meson.build
index 7b313d0..90a1178 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -3,7 +3,10 @@ examples = [ 'enroll', 'verify', 'manage-prints' ]
foreach example: examples
executable(example,
[ example + '.c', 'storage.c', 'utilities.c' ],
- dependencies: [ libfprint_dep, glib_dep ],
+ dependencies: [
+ libfprint_dep,
+ glib_dep,
+ ],
)
endforeach
diff --git a/libfprint/meson.build b/libfprint/meson.build
index 06668b3..61fd506 100644
--- a/libfprint/meson.build
+++ b/libfprint/meson.build
@@ -233,14 +233,21 @@ libfprint = library('fprint',
libfprint_dep = declare_dependency(link_with: libfprint,
sources: [ fp_enums_h ],
include_directories: root_inc,
- dependencies: [ glib_dep, gusb_dep, gio_dep ])
+ dependencies: [
+ gio_dep,
+ glib_dep,
+ gusb_dep,
+ ])
install_headers(['fprint.h'] + libfprint_public_headers, subdir: 'libfprint')
libfprint_private_dep = declare_dependency(
include_directories: include_directories('.'),
link_with: libfprint_private,
- dependencies: [ deps, libfprint_dep ]
+ dependencies: [
+ deps,
+ libfprint_dep,
+ ]
)
udev_rules = executable('fprint-list-udev-rules',
--
2.24.1