libfprint/SOURCES/0109-meson-Rely-on-libfprint-dependency-to-get-root_inclu.patch
2021-09-09 20:12:48 +00:00

51 lines
1.4 KiB
Diff

From 733e4256a107440218e2fb79cd6c7eade2565293 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
Date: Thu, 12 Dec 2019 14:52:23 +0100
Subject: [PATCH 109/181] meson: Rely on libfprint dependency to get
root_include
No need to redefine it in all our tools
---
demo/meson.build | 3 ---
examples/meson.build | 8 ++------
2 files changed, 2 insertions(+), 9 deletions(-)
diff --git a/demo/meson.build b/demo/meson.build
index 279a43c..20f8962 100644
--- a/demo/meson.build
+++ b/demo/meson.build
@@ -10,9 +10,6 @@ datadir = join_paths(prefix, get_option('datadir'))
executable('gtk-libfprint-test',
[ 'gtk-libfprint-test.c', gtk_test_resources ],
dependencies: [ libfprint_dep, gtk_dep ],
- include_directories: [
- root_inc,
- ],
c_args: '-DPACKAGE_VERSION="' + meson.project_version() + '"',
install: true,
install_dir: bindir)
diff --git a/examples/meson.build b/examples/meson.build
index eef8c3f..7b313d0 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -4,14 +4,10 @@ foreach example: examples
executable(example,
[ example + '.c', 'storage.c', 'utilities.c' ],
dependencies: [ libfprint_dep, glib_dep ],
- include_directories: [
- root_inc,
- ])
+ )
endforeach
executable('cpp-test',
'cpp-test.cpp',
dependencies: libfprint_dep,
- include_directories: [
- root_inc,
- ])
+)
--
2.24.1