37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 348c1febc17a4d9c7ef13dd3f7ffc396dcac44f4 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
|
|
Date: Thu, 5 Dec 2019 14:28:05 +0100
|
|
Subject: [PATCH 108/181] meson: Use files to track the map file presence
|
|
|
|
---
|
|
libfprint/meson.build | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/libfprint/meson.build b/libfprint/meson.build
|
|
index 8cb8609..d3d0fd6 100644
|
|
--- a/libfprint/meson.build
|
|
+++ b/libfprint/meson.build
|
|
@@ -186,9 +186,6 @@ drivers_sources += configure_file(input: 'empty_file',
|
|
'\n'.join(drivers_type_list + [] + drivers_type_func)
|
|
])
|
|
|
|
-mapfile = 'libfprint.ver'
|
|
-vflag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfile)
|
|
-
|
|
deps = [ mathlib_dep, glib_dep, gusb_dep, nss_dep, imaging_dep, gio_dep ]
|
|
|
|
deps += declare_dependency(include_directories: [
|
|
@@ -212,6 +209,9 @@ libfprint_private = static_library('fprint-private',
|
|
dependencies: deps,
|
|
install: false)
|
|
|
|
+mapfile = files('libfprint.ver')
|
|
+vflag = '-Wl,--version-script,@0@/@1@'.format(meson.source_root(), mapfile[0])
|
|
+
|
|
libfprint = library('fprint',
|
|
sources: libfprint_sources + fp_enums + drivers_sources + other_sources,
|
|
soversion: soversion,
|
|
--
|
|
2.24.1
|
|
|