35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
From 5be8080ced85d14d7d8905827a8d2af40fcddd8d Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marco=20Trevisan=20=28Trevi=C3=B1o=29?= <mail@3v1n0.net>
|
|
Date: Thu, 5 Dec 2019 14:39:45 +0100
|
|
Subject: [PATCH 102/181] tests/meson: Set the typelib env var only if we have
|
|
introspection
|
|
|
|
---
|
|
tests/meson.build | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/tests/meson.build b/tests/meson.build
|
|
index d6196be..6e56cb3 100644
|
|
--- a/tests/meson.build
|
|
+++ b/tests/meson.build
|
|
@@ -5,7 +5,6 @@ envs.set('G_MESSAGES_DEBUG', 'all')
|
|
|
|
# Setup paths
|
|
envs.set('MESON_SOURCE_ROOT', meson.build_root())
|
|
-envs.prepend('GI_TYPELIB_PATH', join_paths(meson.build_root(), 'libfprint'))
|
|
envs.prepend('LD_LIBRARY_PATH', join_paths(meson.build_root(), 'libfprint'))
|
|
|
|
# Set FP_DEVICE_EMULATION so that drivers can adapt (e.g. to use fixed
|
|
@@ -15,6 +14,8 @@ envs.set('FP_DEVICE_EMULATION', '1')
|
|
envs.set('NO_AT_BRIDGE', '1')
|
|
|
|
if get_option('introspection')
|
|
+ envs.prepend('GI_TYPELIB_PATH', join_paths(meson.build_root(), 'libfprint'))
|
|
+
|
|
if 'virtual_image' in drivers
|
|
test('virtual-image',
|
|
find_program('virtual-image.py'),
|
|
--
|
|
2.24.1
|
|
|