diff --git a/libformula-1.1.3-remove-ant-contrib-support.patch b/libformula-1.1.3-remove-ant-contrib-support.patch
new file mode 100644
index 0000000..e6cde9d
--- /dev/null
+++ b/libformula-1.1.3-remove-ant-contrib-support.patch
@@ -0,0 +1,246 @@
+diff --git a/common_build.xml b/common_build.xml
+index 3a42daa..5575f19 100644
+--- a/common_build.xml
++++ b/common_build.xml
+@@ -152,9 +152,6 @@ TYPICAL TARGET SEQUENCE
+
+-
+
+@@ -325,68 +322,6 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
++ depends="svnant.download-check">
+
+
+
+@@ -491,58 +426,13 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
++ depends="ivy.download-check">
+
+
+
+@@ -602,7 +492,7 @@ TYPICAL TARGET SEQUENCE
+ Verifies that there are no SNAPSHOT dependencies defined in the ivy xml.
+ If there are SNAPSHOTS, fail the release build.
+ ====================================================================-->
+-
++
+
+
+
+@@ -769,7 +659,7 @@ TYPICAL TARGET SEQUENCE
+ Publishes the jar file for this project to a Maven2 repository.
+ ====================================================================-->
+
++ depends="create-pom,ivy.deliver">
+
+
+
+@@ -1038,12 +928,11 @@ TYPICAL TARGET SEQUENCE
+ - compile.pre : anything needed to prep for compile
+ - compile.compile : the actual compilation step
+ - compile.src_copy : copying the source into the bin directory
+- - compile.res_copy : copying the resources into the bin directory
+ - compile.lic_copy : copying the license information into the bin directory
+ - compile.post : anything needed after the compile is done
+ ====================================================================-->
+
+
+
+@@ -1075,36 +964,6 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+-
++
+
+
+
+@@ -1164,7 +1023,7 @@ TYPICAL TARGET SEQUENCE
+ Creates a new manifest file if one is not specified, or updates
+ an existing manifest file if one is specified.
+ ====================================================================-->
+-
++
+
+
+
+@@ -1648,4 +1507,4 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+\ No newline at end of file
++
diff --git a/libformula.spec b/libformula.spec
index c177bc1..6381715 100644
--- a/libformula.spec
+++ b/libformula.spec
@@ -1,6 +1,6 @@
Name: libformula
Version: 1.1.3
-Release: 26%{?dist}
+Release: 27%{?dist}
Summary: Formula Parser
License: LGPLv2
#Original source: http://downloads.sourceforge.net/jfreereport/%%{name}-%%{version}.zip
@@ -8,11 +8,12 @@ License: LGPLv2
#to simplify the licensing
Source: %{name}-%{version}-jarsdeleted.zip
URL: http://reporting.pentaho.org/
-BuildRequires: ant, ant-contrib, java-devel, jpackage-utils, libbase >= 1.1.3
+BuildRequires: ant, java-devel, jpackage-utils, libbase >= 1.1.3
Requires: java-headless, jpackage-utils, apache-commons-logging, libbase >= 1.1.3
BuildArch: noarch
Patch0: libformula-1.1.2.build.patch
Patch1: libformula-1.1.2.java11.patch
+Patch2: libformula-1.1.3-remove-ant-contrib-support.patch
%description
LibFormula provides Excel-Style-Expressions. The implementation provided
@@ -31,11 +32,11 @@ Javadoc for %{name}.
%setup -q -c
%patch0 -p1 -b .build
%patch1 -p1 -b .java11
+%patch2 -p1 -b .no_antcontrib
+
find . -name "*.jar" -exec rm -f {} \;
mkdir -p lib
build-jar-repository -s -p lib commons-logging-api libbase
-cd lib
-ln -s /usr/share/java/ant ant-contrib
%build
ant jar javadoc
@@ -55,6 +56,9 @@ cp -rp bin/javadoc/docs/api $RPM_BUILD_ROOT%{_javadocdir}/%{name}
%{_javadocdir}/%{name}
%changelog
+* Fri Jan 15 2021 Nicolas Lécureuil - 1.1.3-27
+- Remove ant-contrib support
+
* Tue Jul 28 2020 Fedora Release Engineering - 1.1.3-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild