RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libfonts#6915e206bb477a1ad384e805ff4bfc9edc934511
This commit is contained in:
parent
18d0da63dd
commit
3ce61b97e0
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
|||||||
|
/libfonts-1.1.3-jarsdeleted.zip
|
16
libfonts-1.1.2.build.patch
Normal file
16
libfonts-1.1.2.build.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- libfonts-1.1.3/build.properties 2009-11-17 15:56:39.000000000 +0000
|
||||||
|
+++ libfonts-1.1.3/build.properties 2009-11-17 15:57:29.000000000 +0000
|
||||||
|
@@ -1,8 +1,10 @@
|
||||||
|
-project.revision=TRUNK-SNAPSHOT
|
||||||
|
+project.revision=1.1.3
|
||||||
|
ivy.artifact.group=pentaho-library
|
||||||
|
ivy.artifact.id=libfonts
|
||||||
|
impl.title=LibFonts
|
||||||
|
impl.productID=libfonts
|
||||||
|
src.dir=${basedir}/source
|
||||||
|
dependency.libloader.revision=1.1.3
|
||||||
|
-testsrc.dir=${basedir}/test
|
||||||
|
\ No newline at end of file
|
||||||
|
+testsrc.dir=${basedir}/test
|
||||||
|
+antcontrib.available=true
|
||||||
|
+build.cache.dir=lib
|
13
libfonts-1.1.2.java11.patch
Normal file
13
libfonts-1.1.2.java11.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- libfonts-1.1.3/common_build.xml 2020-05-05 19:47:17.413675774 +0100
|
||||||
|
+++ libfonts-1.1.3/common_build.xml 2020-05-05 19:47:24.239734072 +0100
|
||||||
|
@@ -136,8 +136,8 @@
|
||||||
|
<property name="javac.deprecation"
|
||||||
|
value="true"
|
||||||
|
description="Indicates whether source should be compiled with deprecation information" />
|
||||||
|
- <property name="javac.source" value="1.5" description="Provide source compatibility with specified release" />
|
||||||
|
- <property name="javac.target" value="1.5" description="Generate class files for specific VM version" />
|
||||||
|
+ <property name="javac.source" value="1.6" description="Provide source compatibility with specified release" />
|
||||||
|
+ <property name="javac.target" value="1.6" description="Generate class files for specific VM version" />
|
||||||
|
|
||||||
|
<!-- Build Cache properties -->
|
||||||
|
<property name="build.cache.dir"
|
169
libfonts.spec
Normal file
169
libfonts.spec
Normal file
@ -0,0 +1,169 @@
|
|||||||
|
Name: libfonts
|
||||||
|
Version: 1.1.3
|
||||||
|
Release: 29%{?dist}
|
||||||
|
Summary: TrueType Font Layouting
|
||||||
|
License: LGPLv2 and UCD
|
||||||
|
#Original source: http://downloads.sourceforge.net/jfreereport/%%{name}-%%{version}.zip
|
||||||
|
#unzip, find . -name "*.jar" -exec rm {} \;
|
||||||
|
#to simplify the licensing
|
||||||
|
Source: %{name}-%{version}-jarsdeleted.zip
|
||||||
|
URL: http://reporting.pentaho.org/
|
||||||
|
BuildRequires: ant, ant-contrib, java-devel, jpackage-utils, libloader >= 1.1.3
|
||||||
|
Requires: java-headless, jpackage-utils, libloader >= 1.1.3
|
||||||
|
BuildArch: noarch
|
||||||
|
Patch0: libfonts-1.1.2.build.patch
|
||||||
|
Patch1: libfonts-1.1.2.java11.patch
|
||||||
|
|
||||||
|
%description
|
||||||
|
LibFonts is a library developed to support advanced layouting in JFreeReport.
|
||||||
|
This library allows to read TrueType-Font files to extract layouting specific
|
||||||
|
informations.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: jpackage-utils
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
Javadoc for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -c
|
||||||
|
%patch0 -p1 -b .build
|
||||||
|
%patch1 -p1 -b .java11
|
||||||
|
find . -name "*.jar" -exec rm -f {} \;
|
||||||
|
rm -r source/org/pentaho/reporting/libraries/fonts/itext
|
||||||
|
mkdir -p lib
|
||||||
|
build-jar-repository -s -p lib libbase commons-logging-api libloader
|
||||||
|
cd lib
|
||||||
|
ln -s /usr/share/java/ant ant-contrib
|
||||||
|
|
||||||
|
%build
|
||||||
|
ant jar javadoc
|
||||||
|
for file in README.txt licence-LGPL.txt ChangeLog.txt; do
|
||||||
|
tr -d '\r' < $file > $file.new
|
||||||
|
mv $file.new $file
|
||||||
|
done
|
||||||
|
|
||||||
|
%install
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||||
|
cp -p ./dist/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
|
||||||
|
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
cp -rp bin/javadoc/docs/api $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc licence-LGPL.txt README.txt ChangeLog.txt
|
||||||
|
%{_javadir}/%{name}.jar
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-29
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 1.1.3-28
|
||||||
|
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||||
|
|
||||||
|
* Tue May 05 2020 Caolán McNamara <caolanm@redhat.com> - 1.1.3-27
|
||||||
|
- allow rebuild with java 11
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-25
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 04 2019 Stephan Bergmann <sbergman@redhat.com> - 1.1.3-24
|
||||||
|
- Use /usr/share/java instead of _javadir macro for build dependencies
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-22
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-20
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 25 2014 Caolán McNamara <caolanm@redhat.com> - 1.1.3-15
|
||||||
|
- Resolves: rhbz#1068353 Switch to java-headless (build)requires
|
||||||
|
|
||||||
|
* Wed Oct 23 2013 Caolán McNamara <caolanm@redhat.com> - 1.1.3-14
|
||||||
|
- Resolves: rhbz#1022131 remove versioned jars
|
||||||
|
|
||||||
|
* Tue Aug 06 2013 Parag Nemade <paragn AT fedoraproject DOT org> - 1.1.3-13
|
||||||
|
- ant-nodeps is dropped from ant-1.9.0-2 build in rawhide
|
||||||
|
- Drop buildroot, %%clean, %%defattr and removal of buildroot in %%install
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 02 2013 Caolán McNamara <caolanm@redhat.com> - 1.1.3-11
|
||||||
|
- drop iText requirement, we don't need it, and it's a complete pain
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Nov 03 2012 Caolán McNamara <caolanm@redhat.com> - 1.1.3-9
|
||||||
|
- repack source to remove bundled multi-license .jars
|
||||||
|
- encodings/Grapheme-Cluster-Properties.txt is under UCD
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 10 2012 Caolán McNamara <caolanm@redhat.com> - 1.1.3-7
|
||||||
|
- Resolves: rhbz#749103 use itext-core
|
||||||
|
|
||||||
|
* Tue Feb 21 2012 Caolán McNamara <caolanm@redhat.com> - 1.1.3-6
|
||||||
|
- Related: rhbz#749103 can restore iText requirement now that
|
||||||
|
iText doesn't pull in the entire gcj stack
|
||||||
|
|
||||||
|
* Wed Feb 08 2012 Caolán McNamara <caolanm@redhat.com> - 1.1.3-5
|
||||||
|
- Related: rhbz#749103 drop iText requirement
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Oct 28 2011 Caolán McNamara <caolanm@redhat.com> - 1.1.3-3
|
||||||
|
- Related: rhbz#749103 drop gcj aot
|
||||||
|
|
||||||
|
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 03 2009 Caolan McNamara <caolanm@redhat.com> 1.1.3-1
|
||||||
|
- latest version
|
||||||
|
|
||||||
|
* Tue Nov 17 2009 Caolan McNamara <caolanm@redhat.com> 1.1.2-1
|
||||||
|
- latest version
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Caolan McNamara <caolanm@redhat.com> 1.0.0-2.OOo31
|
||||||
|
- make javadoc no-arch when building as arch-dependant aot
|
||||||
|
|
||||||
|
* Mon Mar 16 2009 Caolan McNamara <caolanm@redhat.com> 1.0.0-1.OOo31
|
||||||
|
- Post-release tuned for OpenOffice.org
|
||||||
|
|
||||||
|
* Mon Mar 09 2009 Caolan McNamara <caolanm@redhat.com> 0.4.0-1
|
||||||
|
- latest version
|
||||||
|
|
||||||
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 07 2008 Caolan McNamara <caolanm@redhat.com> 0.3.4-1
|
||||||
|
- initial fedora import
|
Loading…
Reference in New Issue
Block a user