RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libffi#fdac85aeb043fc5ce78b59c74c22045fa2fa765a
This commit is contained in:
parent
6e3a5a2f67
commit
8fe50a94e2
5
.gitignore
vendored
5
.gitignore
vendored
@ -0,0 +1,5 @@
|
|||||||
|
libffi-3.0.9.tar.gz
|
||||||
|
/libffi-3.0.10.tar.gz
|
||||||
|
/libffi-3.0.11.tar.gz
|
||||||
|
/libffi-3.0.13.tar.gz
|
||||||
|
/libffi-3.1.tar.gz
|
23
ffi-multilib.h
Normal file
23
ffi-multilib.h
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
/* This file is here to prevent a file conflict on multiarch systems. */
|
||||||
|
#ifdef ffi_wrapper_h
|
||||||
|
#error "Do not define ffi_wrapper_h!"
|
||||||
|
#endif
|
||||||
|
#define ffi_wrapper_h
|
||||||
|
|
||||||
|
#if defined(__i386__)
|
||||||
|
#include "ffi-i386.h"
|
||||||
|
#elif defined(__powerpc64__)
|
||||||
|
#include "ffi-ppc64.h"
|
||||||
|
#elif defined(__powerpc__)
|
||||||
|
#include "ffi-ppc.h"
|
||||||
|
#elif defined(__s390x__)
|
||||||
|
#include "ffi-s390x.h"
|
||||||
|
#elif defined(__s390__)
|
||||||
|
#include "ffi-s390.h"
|
||||||
|
#elif defined(__x86_64__)
|
||||||
|
#include "ffi-x86_64.h"
|
||||||
|
#else
|
||||||
|
#error "The libffi-devel package is not usable with the architecture."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#undef ffi_wrapper_h
|
23
ffitarget-multilib.h
Normal file
23
ffitarget-multilib.h
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
/* This file is here to prevent a file conflict on multiarch systems. */
|
||||||
|
#ifdef ffitarget_wrapper_h
|
||||||
|
#error "Do not define ffitarget_wrapper_h!"
|
||||||
|
#endif
|
||||||
|
#define ffitarget_wrapper_h
|
||||||
|
|
||||||
|
#if defined(__i386__)
|
||||||
|
#include "ffitarget-i386.h"
|
||||||
|
#elif defined(__powerpc64__)
|
||||||
|
#include "ffitarget-ppc64.h"
|
||||||
|
#elif defined(__powerpc__)
|
||||||
|
#include "ffitarget-ppc.h"
|
||||||
|
#elif defined(__s390x__)
|
||||||
|
#include "ffitarget-s390x.h"
|
||||||
|
#elif defined(__s390__)
|
||||||
|
#include "ffitarget-s390.h"
|
||||||
|
#elif defined(__x86_64__)
|
||||||
|
#include "ffitarget-x86_64.h"
|
||||||
|
#else
|
||||||
|
#error "The libffi-devel package is not usable with the architecture."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#undef ffitarget_wrapper_h
|
11
libffi-3.1-aarch64-fix-exec-stack.patch
Normal file
11
libffi-3.1-aarch64-fix-exec-stack.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/src/aarch64/sysv.S
|
||||||
|
+++ b/src/aarch64/sysv.S
|
||||||
|
@@ -396,3 +396,8 @@
|
||||||
|
#ifdef __ELF__
|
||||||
|
.size CNAME(ffi_closure_SYSV), .-CNAME(ffi_closure_SYSV)
|
||||||
|
#endif
|
||||||
|
+
|
||||||
|
+#if defined __ELF__ && defined __linux__
|
||||||
|
+ .section .note.GNU-stack,"",%progbits
|
||||||
|
+#endif
|
||||||
|
+
|
31
libffi-3.1-fix-exec-stack.patch
Normal file
31
libffi-3.1-fix-exec-stack.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 978c9540154d320525488db1b7049277122f736d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Samuli Suominen <ssuominen@gentoo.org>
|
||||||
|
Date: Sat, 31 May 2014 08:53:10 -0400
|
||||||
|
Subject: [PATCH] Add missing GNU stack markings in win32.S
|
||||||
|
|
||||||
|
---
|
||||||
|
src/x86/win32.S | 6 +++++-
|
||||||
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/x86/win32.S b/src/x86/win32.S
|
||||||
|
index daf0e79..e42baf2 100644
|
||||||
|
--- a/src/x86/win32.S
|
||||||
|
+++ b/src/x86/win32.S
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
/* -----------------------------------------------------------------------
|
||||||
|
- win32.S - Copyright (c) 1996, 1998, 2001, 2002, 2009 Red Hat, Inc.
|
||||||
|
+ win32.S - Copyright (c) 2014 Anthony Green
|
||||||
|
+ Copyright (c) 1996, 1998, 2001, 2002, 2009 Red Hat, Inc.
|
||||||
|
Copyright (c) 2001 John Beniton
|
||||||
|
Copyright (c) 2002 Ranjit Mathew
|
||||||
|
Copyright (c) 2009 Daniel Witte
|
||||||
|
@@ -1304,3 +1305,6 @@ L_ffi_closure_SYSV_inner$stub:
|
||||||
|
|
||||||
|
#endif /* !_MSC_VER */
|
||||||
|
|
||||||
|
+#if defined __ELF__ && defined __linux__
|
||||||
|
+ .section .note.GNU-stack,"",@progbits
|
||||||
|
+#endif
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
17
libffi-3.1-fix-include-path.patch
Normal file
17
libffi-3.1-fix-include-path.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -up libffi-3.1/libffi.pc.in.fixpath libffi-3.1/libffi.pc.in
|
||||||
|
--- libffi-3.1/libffi.pc.in.fixpath 2014-04-25 19:45:13.000000000 +0200
|
||||||
|
+++ libffi-3.1/libffi.pc.in 2014-06-12 12:06:06.000000000 +0200
|
||||||
|
@@ -1,11 +1,10 @@
|
||||||
|
prefix=@prefix@
|
||||||
|
exec_prefix=@exec_prefix@
|
||||||
|
libdir=@libdir@
|
||||||
|
-toolexeclibdir=@toolexeclibdir@
|
||||||
|
-includedir=${libdir}/@PACKAGE_NAME@-@PACKAGE_VERSION@/include
|
||||||
|
+includedir=@includedir@
|
||||||
|
|
||||||
|
Name: @PACKAGE_NAME@
|
||||||
|
Description: Library supporting Foreign Function Interfaces
|
||||||
|
Version: @PACKAGE_VERSION@
|
||||||
|
-Libs: -L${toolexeclibdir} -lffi
|
||||||
|
+Libs: -L${libdir} -lffi
|
||||||
|
Cflags: -I${includedir}
|
17
libffi-3.1-libffi_tmpdir.patch
Normal file
17
libffi-3.1-libffi_tmpdir.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
Most temp file directories need to be hardened against execution, but
|
||||||
|
libffi needs execute privileges. Add a libffi-specific temp directory
|
||||||
|
that can be set up by sysadmins as needed with suitable permissions.
|
||||||
|
This both ensures that libffi will have a valid temp directory to use
|
||||||
|
as well as preventing attempts to access other directories.
|
||||||
|
|
||||||
|
diff -rup a/src/closures.c b/src/closures.c
|
||||||
|
--- a/src/closures.c 2014-05-11 09:54:19.000000000 -0400
|
||||||
|
+++ b/src/closures.c 2020-04-29 20:50:00.454853909 -0400
|
||||||
|
@@ -362,6 +362,7 @@ static struct
|
||||||
|
const char *arg;
|
||||||
|
int repeat;
|
||||||
|
} open_temp_exec_file_opts[] = {
|
||||||
|
+ { open_temp_exec_file_env, "LIBFFI_TMPDIR", 0 },
|
||||||
|
{ open_temp_exec_file_env, "TMPDIR", 0 },
|
||||||
|
{ open_temp_exec_file_dir, "/tmp", 0 },
|
||||||
|
{ open_temp_exec_file_dir, "/var/tmp", 0 },
|
11
libffi-aarch64-rhbz1174037.patch
Normal file
11
libffi-aarch64-rhbz1174037.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libffi-3.1/src/aarch64/ffi.c.orig 2014-04-25 18:45:13.000000000 +0100
|
||||||
|
+++ libffi-3.1/src/aarch64/ffi.c 2015-01-15 02:36:56.314906455 +0000
|
||||||
|
@@ -728,7 +728,7 @@
|
||||||
|
state.ngrn = N_X_ARG_REG;
|
||||||
|
|
||||||
|
memcpy (allocate_to_stack (&state, stack, ty->alignment,
|
||||||
|
- ty->size), ecif->avalue + i, ty->size);
|
||||||
|
+ ty->size), ecif->avalue[i], ty->size);
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
|
288
libffi.spec
Normal file
288
libffi.spec
Normal file
@ -0,0 +1,288 @@
|
|||||||
|
%bcond_with bootstrap
|
||||||
|
|
||||||
|
%global multilib_arches %{ix86} ppc ppc64 ppc64p7 s390 s390x x86_64
|
||||||
|
|
||||||
|
Name: libffi
|
||||||
|
Version: 3.1
|
||||||
|
Release: 26%{?dist}
|
||||||
|
Summary: A portable foreign function interface library
|
||||||
|
License: MIT
|
||||||
|
URL: http://sourceware.org/libffi
|
||||||
|
|
||||||
|
Source0: ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
|
||||||
|
Source1: ffi-multilib.h
|
||||||
|
Source2: ffitarget-multilib.h
|
||||||
|
Patch0: libffi-3.1-fix-include-path.patch
|
||||||
|
Patch1: libffi-3.1-fix-exec-stack.patch
|
||||||
|
Patch2: libffi-aarch64-rhbz1174037.patch
|
||||||
|
Patch3: libffi-3.1-aarch64-fix-exec-stack.patch
|
||||||
|
Patch4: libffi-3.1-libffi_tmpdir.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
%if %{without bootstrap}
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: dejagnu
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
Compilers for high level languages generate code that follow certain
|
||||||
|
conventions. These conventions are necessary, in part, for separate
|
||||||
|
compilation to work. One such convention is the "calling convention".
|
||||||
|
The calling convention is a set of assumptions made by the compiler
|
||||||
|
about where function arguments will be found on entry to a function. A
|
||||||
|
calling convention also specifies where the return value for a function
|
||||||
|
is found.
|
||||||
|
|
||||||
|
Some programs may not know at the time of compilation what arguments
|
||||||
|
are to be passed to a function. For instance, an interpreter may be
|
||||||
|
told at run-time about the number and types of arguments used to call a
|
||||||
|
given function. `Libffi' can be used in such programs to provide a
|
||||||
|
bridge from the interpreter program to compiled code.
|
||||||
|
|
||||||
|
The `libffi' library provides a portable, high level programming
|
||||||
|
interface to various calling conventions. This allows a programmer to
|
||||||
|
call any function specified by a call interface description at run time.
|
||||||
|
|
||||||
|
FFI stands for Foreign Function Interface. A foreign function
|
||||||
|
interface is the popular name for the interface that allows code
|
||||||
|
written in one language to call code written in another language. The
|
||||||
|
`libffi' library really only provides the lowest, machine dependent
|
||||||
|
layer of a fully featured foreign function interface. A layer must
|
||||||
|
exist above `libffi' that handles type conversions for values passed
|
||||||
|
between the two languages.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .fixpath
|
||||||
|
%patch1 -p1 -b .execstack
|
||||||
|
%patch2 -p1 -b .aarch64
|
||||||
|
%patch3 -p1 -b .aarch64execstack
|
||||||
|
%patch4 -p1 -b .libffitmpdir
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%check
|
||||||
|
%if %{without bootstrap}
|
||||||
|
%make_build check
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
|
|
||||||
|
# Determine generic arch target name for multilib wrapper
|
||||||
|
basearch=%{_arch}
|
||||||
|
%ifarch %{ix86}
|
||||||
|
basearch=i386
|
||||||
|
%endif
|
||||||
|
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_includedir}
|
||||||
|
%ifarch %{multilib_arches}
|
||||||
|
# Do header file switcheroo to avoid file conflicts on systems where you
|
||||||
|
# can have both a 32- and 64-bit version of the library, and they each need
|
||||||
|
# their own correct-but-different versions of the headers to be usable.
|
||||||
|
for i in ffi ffitarget; do
|
||||||
|
mv $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}/include/$i.h $RPM_BUILD_ROOT%{_includedir}/$i-${basearch}.h
|
||||||
|
done
|
||||||
|
install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/ffi.h
|
||||||
|
install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_includedir}/ffitarget.h
|
||||||
|
%else
|
||||||
|
mv $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}/include/{ffi,ffitarget}.h $RPM_BUILD_ROOT%{_includedir}
|
||||||
|
%endif
|
||||||
|
rm -rf $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE
|
||||||
|
%doc README
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
%{_includedir}/ffi*.h
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_mandir}/man3/*.gz
|
||||||
|
%{_infodir}/libffi.info.*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 30 2020 DJ Delorie <idj@redhat.com> - 3.1-25
|
||||||
|
- Add $LIBFFI_TMPDIR environment variable support (#1667620)
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 9 2019 Florian Weimer <fweimer@redhat.com> - 3.1-22
|
||||||
|
- Run test suite during build (#1727088)
|
||||||
|
|
||||||
|
* Wed Jun 19 2019 Anthony Green <green@redhat.com> - 3.1-21
|
||||||
|
- Fix license tag
|
||||||
|
|
||||||
|
* Wed Apr 24 2019 Björn Esser <besser82@fedoraproject.org> - 3.1-20
|
||||||
|
- Remove hardcoded gzip suffix from GNU info pages
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jul 22 2018 Peter Robinson <pbrobinson@fedoraproject.org> 3.1-28
|
||||||
|
- Fix FTBFS
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.1-15
|
||||||
|
- Switch to %%ldconfig_scriptlets
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 5 2017 Jens Petersen <petersen@redhat.com> - 3.1-12
|
||||||
|
- protect install-info in the rpm scriptlets
|
||||||
|
https://fedoraproject.org/wiki/Packaging:Scriptlets#Texinfo
|
||||||
|
|
||||||
|
* Tue Jun 20 2017 Anthony Green <green@redhat.com> - 3.1-11
|
||||||
|
- fix exec stack problem on aarch64 build
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 15 2015 Peter Robinson <pbrobinson@fedoraproject.org> 3.1-7
|
||||||
|
- Add patch to fix issues on aarch64 (rhbz 1174037)
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 17 2014 Tom Callaway <spot@fedoraproject.org> - 3.1-5
|
||||||
|
- fix license handling
|
||||||
|
|
||||||
|
* Sun Jun 29 2014 Anthony Green <green@redhat.com> - 3.1-4
|
||||||
|
- fix exec stack problem on 32-bit build
|
||||||
|
|
||||||
|
* Thu Jun 12 2014 Dan Horák <dan[at]danny.cz> - 3.1-3
|
||||||
|
- fix header path in pkgconfig file
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 19 2014 Anthony Green <green@redhat.com> - 3.1-1
|
||||||
|
- fix non-multiarch builds (arm).
|
||||||
|
|
||||||
|
* Mon May 19 2014 Anthony Green <green@redhat.com> - 3.1-0
|
||||||
|
- update to 3.1.
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.13-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 3.0.13-4
|
||||||
|
- fix typos in wrapper headers
|
||||||
|
|
||||||
|
* Mon May 27 2013 Tom Callaway <spot@fedoraproject.org> - 3.0.13-3
|
||||||
|
- make header files multilib safe
|
||||||
|
|
||||||
|
* Sat May 25 2013 Tom Callaway <spot@fedoraproject.org> - 3.0.13-2
|
||||||
|
- fix incorrect header pathing (and .pc file)
|
||||||
|
|
||||||
|
* Wed Mar 20 2013 Anthony Green <green@redhat.com> - 3.0.13-1
|
||||||
|
- update to 3.0.13
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.11-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 14 2013 Dennis Gilmore <dennis@ausil.us> - 3.0.11-1
|
||||||
|
- update to 3.0.11
|
||||||
|
|
||||||
|
* Fri Nov 02 2012 Deepak Bhole <dbhole@redhat.com> - 3.0.10-4
|
||||||
|
- Fixed source location
|
||||||
|
|
||||||
|
* Fri Aug 10 2012 Dennis Gilmore <dennis@ausil.us> - 3.0.10-3
|
||||||
|
- drop back to 3.0.10, 3.0.11 was never pushed anywhere as the soname bump broke buildroots
|
||||||
|
- as 3.0.11 never went out no epoch needed.
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.11-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Apr 13 2012 Anthony Green <green@redhat.com> - 3.0.11-1
|
||||||
|
- Upgrade to 3.0.11.
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.10-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Aug 23 2011 Anthony Green <green@redhat.com> - 3.0.10-1
|
||||||
|
- Upgrade to 3.0.10.
|
||||||
|
|
||||||
|
* Fri Mar 18 2011 Dan Horák <dan[at]danny.cz> - 3.0.9-3
|
||||||
|
- added patch for being careful when defining relatively generic symbols
|
||||||
|
|
||||||
|
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.9-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 29 2009 Anthony Green <green@redhat.com> - 3.0.9-1
|
||||||
|
- Upgrade
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 08 2008 Anthony Green <green@redhat.com> 3.0.5-1
|
||||||
|
- Upgrade to 3.0.5
|
||||||
|
|
||||||
|
* Fri Feb 15 2008 Anthony Green <green@redhat.com> 3.0.1-1
|
||||||
|
- Upgrade to 3.0.1
|
||||||
|
|
||||||
|
* Fri Feb 15 2008 Anthony Green <green@redhat.com> 2.99.9-1
|
||||||
|
- Upgrade to 2.99.9
|
||||||
|
- Require pkgconfig for the devel package.
|
||||||
|
- Update summary.
|
||||||
|
|
||||||
|
* Fri Feb 15 2008 Anthony Green <green@redhat.com> 2.99.8-1
|
||||||
|
- Upgrade to 2.99.8
|
||||||
|
|
||||||
|
* Thu Feb 14 2008 Anthony Green <green@redhat.com> 2.99.7-1
|
||||||
|
- Upgrade to 2.99.7
|
||||||
|
|
||||||
|
* Thu Feb 14 2008 Anthony Green <green@redhat.com> 2.99.6-1
|
||||||
|
- Upgrade to 2.99.6
|
||||||
|
|
||||||
|
* Thu Feb 14 2008 Anthony Green <green@redhat.com> 2.99.4-1
|
||||||
|
- Upgrade to 2.99.4
|
||||||
|
|
||||||
|
* Thu Feb 14 2008 Anthony Green <green@redhat.com> 2.99.3-1
|
||||||
|
- Upgrade to 2.99.3
|
||||||
|
|
||||||
|
* Thu Feb 14 2008 Anthony Green <green@redhat.com> 2.99.2-1
|
||||||
|
- Created.
|
17
tests/tests.yml
Normal file
17
tests/tests.yml
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
---
|
||||||
|
# This first play always runs on the local staging system
|
||||||
|
- hosts: localhost
|
||||||
|
roles:
|
||||||
|
- role: standard-test-beakerlib
|
||||||
|
tags:
|
||||||
|
- classic
|
||||||
|
tests:
|
||||||
|
- testsuite
|
||||||
|
required_packages:
|
||||||
|
- libffi
|
||||||
|
- libffi-devel
|
||||||
|
- gcc
|
||||||
|
- dejagnu
|
||||||
|
- rpm-build
|
||||||
|
- gcc-c++
|
||||||
|
- strace
|
63
tests/testsuite/Makefile
Normal file
63
tests/testsuite/Makefile
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
#
|
||||||
|
# Makefile of /tools/libffi/Sanity/testsuite
|
||||||
|
# Description: Runs upstream testsuite
|
||||||
|
# Author: Michal Nowak <mnowak@redhat.com>
|
||||||
|
#
|
||||||
|
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
#
|
||||||
|
# Copyright (c) 2010 Red Hat, Inc.
|
||||||
|
#
|
||||||
|
# This program is free software: you can redistribute it and/or
|
||||||
|
# modify it under the terms of the GNU General Public License as
|
||||||
|
# published by the Free Software Foundation, either version 3 of
|
||||||
|
# the License, or (at your option) any later version.
|
||||||
|
#
|
||||||
|
# This program is distributed in the hope that it will be
|
||||||
|
# useful, but WITHOUT ANY WARRANTY; without even the implied
|
||||||
|
# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
|
||||||
|
# PURPOSE. See the GNU General Public License for more details.
|
||||||
|
#
|
||||||
|
# You should have received a copy of the GNU General Public License
|
||||||
|
# along with this program. If not, see http://www.gnu.org/licenses/.
|
||||||
|
#
|
||||||
|
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
|
||||||
|
export TEST=/tools/libffi/Sanity/testsuite
|
||||||
|
export TESTVERSION=1.0
|
||||||
|
|
||||||
|
BUILT_FILES=
|
||||||
|
|
||||||
|
FILES=$(METADATA) runtest.sh Makefile PURPOSE dynamic_linking.patch dynamic_linking-dg.patch
|
||||||
|
|
||||||
|
.PHONY: all install download clean
|
||||||
|
|
||||||
|
run: $(FILES) build
|
||||||
|
./runtest.sh
|
||||||
|
|
||||||
|
build: $(BUILT_FILES)
|
||||||
|
chmod a+x runtest.sh
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f *~ $(BUILT_FILES)
|
||||||
|
|
||||||
|
|
||||||
|
include /usr/share/rhts/lib/rhts-make.include
|
||||||
|
|
||||||
|
$(METADATA): Makefile
|
||||||
|
@echo "Owner: Michal Nowak <mnowak@redhat.com>" > $(METADATA)
|
||||||
|
@echo "Name: $(TEST)" >> $(METADATA)
|
||||||
|
@echo "TestVersion: $(TESTVERSION)" >> $(METADATA)
|
||||||
|
@echo "Path: $(TEST_DIR)" >> $(METADATA)
|
||||||
|
@echo "Description: Runs upstream testsuite" >> $(METADATA)
|
||||||
|
@echo "Type: Sanity" >> $(METADATA)
|
||||||
|
@echo "TestTime: 19m" >> $(METADATA)
|
||||||
|
@echo "RunFor: libffi" >> $(METADATA)
|
||||||
|
@echo "Requires: libffi libffi-devel gcc dejagnu rpm-build gcc-c++ texinfo strace" >> $(METADATA)
|
||||||
|
@echo "Priority: Normal" >> $(METADATA)
|
||||||
|
@echo "License: GPLv3" >> $(METADATA)
|
||||||
|
@echo "Confidential: no" >> $(METADATA)
|
||||||
|
@echo "Destructive: no" >> $(METADATA)
|
||||||
|
@echo "Releases: -RHEL4 -RHEL5" >> $(METADATA)
|
||||||
|
|
||||||
|
rhts-lint $(METADATA)
|
3
tests/testsuite/PURPOSE
Normal file
3
tests/testsuite/PURPOSE
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
PURPOSE of /tools/libffi/Sanity/testsuite
|
||||||
|
Description: Runs upstream testsuite
|
||||||
|
Author: Michal Nowak <mnowak@redhat.com>
|
29
tests/testsuite/dynamic_linking-dg.patch
Normal file
29
tests/testsuite/dynamic_linking-dg.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- testsuite/lib/libffi-dg.exp 2008-02-14 19:45:33.000000000 -0500
|
||||||
|
+++ testsuite/lib/libffi-dg.exp 2015-02-13 13:32:08.422053435 -0500
|
||||||
|
@@ -110,7 +110,7 @@
|
||||||
|
}
|
||||||
|
verbose "gccdir $gccdir"
|
||||||
|
|
||||||
|
- set ld_library_path "."
|
||||||
|
+ set ld_library_path ""
|
||||||
|
append ld_library_path ":${gccdir}"
|
||||||
|
|
||||||
|
set compiler "${gccdir}/xgcc"
|
||||||
|
@@ -127,16 +127,13 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
- # add the library path for libffi.
|
||||||
|
- append ld_library_path ":${blddirffi}/.libs"
|
||||||
|
-
|
||||||
|
verbose "ld_library_path: $ld_library_path"
|
||||||
|
|
||||||
|
# Point to the Libffi headers in libffi.
|
||||||
|
set libffi_include "${blddirffi}/include"
|
||||||
|
verbose "libffi_include $libffi_include"
|
||||||
|
|
||||||
|
- set libffi_dir "${blddirffi}/.libs"
|
||||||
|
+ set libffi_dir "/usr/LIBRARY_DIR"
|
||||||
|
verbose "libffi_dir $libffi_dir"
|
||||||
|
if { $libffi_dir != "" } {
|
||||||
|
set libffi_dir [file dirname ${libffi_dir}]
|
29
tests/testsuite/dynamic_linking.patch
Normal file
29
tests/testsuite/dynamic_linking.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- testsuite/lib/libffi.exp 2013-03-16 07:19:39.000000000 -0400
|
||||||
|
+++ testsuite/lib/libffi.exp 2014-10-22 11:10:42.449143642 -0400
|
||||||
|
@@ -118,7 +118,7 @@
|
||||||
|
}
|
||||||
|
verbose "gccdir $gccdir"
|
||||||
|
|
||||||
|
- set ld_library_path "."
|
||||||
|
+ set ld_library_path ""
|
||||||
|
append ld_library_path ":${gccdir}"
|
||||||
|
|
||||||
|
set compiler "${gccdir}/xgcc"
|
||||||
|
@@ -142,16 +142,13 @@
|
||||||
|
|
||||||
|
}
|
||||||
|
|
||||||
|
- # add the library path for libffi.
|
||||||
|
- append ld_library_path ":${blddirffi}/.libs"
|
||||||
|
-
|
||||||
|
verbose "ld_library_path: $ld_library_path"
|
||||||
|
|
||||||
|
# Point to the Libffi headers in libffi.
|
||||||
|
set libffi_include "${blddirffi}/include"
|
||||||
|
verbose "libffi_include $libffi_include"
|
||||||
|
|
||||||
|
- set libffi_dir "${blddirffi}/.libs"
|
||||||
|
+ set libffi_dir "/usr/LIBRARY_DIR"
|
||||||
|
verbose "libffi_dir $libffi_dir"
|
||||||
|
if { $libffi_dir != "" } {
|
||||||
|
set libffi_dir [file dirname ${libffi_dir}]
|
86
tests/testsuite/runtest.sh
Executable file
86
tests/testsuite/runtest.sh
Executable file
@ -0,0 +1,86 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
# vim: dict=/usr/share/beakerlib/dictionary.vim cpt=.,w,b,u,t,i,k
|
||||||
|
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
#
|
||||||
|
# runtest.sh of /tools/libffi/Sanity/testsuite
|
||||||
|
# Description: Runs upstream testsuite
|
||||||
|
# Author: Michal Nowak <mnowak@redhat.com>
|
||||||
|
#
|
||||||
|
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
#
|
||||||
|
# Copyright (c) 2010 Red Hat, Inc.
|
||||||
|
#
|
||||||
|
# This program is free software: you can redistribute it and/or
|
||||||
|
# modify it under the terms of the GNU General Public License as
|
||||||
|
# published by the Free Software Foundation, either version 3 of
|
||||||
|
# the License, or (at your option) any later version.
|
||||||
|
#
|
||||||
|
# This program is distributed in the hope that it will be
|
||||||
|
# useful, but WITHOUT ANY WARRANTY; without even the implied
|
||||||
|
# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
|
||||||
|
# PURPOSE. See the GNU General Public License for more details.
|
||||||
|
#
|
||||||
|
# You should have received a copy of the GNU General Public License
|
||||||
|
# along with this program. If not, see http://www.gnu.org/licenses/.
|
||||||
|
#
|
||||||
|
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
|
||||||
|
# Include rhts environment
|
||||||
|
. /usr/lib/beakerlib/beakerlib.sh
|
||||||
|
|
||||||
|
PACKAGES=(libffi libffi-devel gcc dejagnu rpm-build gcc-c++)
|
||||||
|
|
||||||
|
rlJournalStart
|
||||||
|
rlPhaseStartSetup
|
||||||
|
for p in "${PACKAGES[@]}"; do
|
||||||
|
if ! rlCheckRpm "$p"; then
|
||||||
|
rlRun "yum -y install $p"
|
||||||
|
rlAssertRpm "$p"
|
||||||
|
fi
|
||||||
|
done;
|
||||||
|
|
||||||
|
rlRun "TmpDir=`mktemp -d`" 0 "Creating tmp directory"
|
||||||
|
rlRun "cp *.patch $TmpDir/"
|
||||||
|
rlRun "pushd $TmpDir"
|
||||||
|
rlFetchSrcForInstalled libffi
|
||||||
|
rlRun "rpm -ivh libffi*.src.rpm"
|
||||||
|
rlRun "popd"
|
||||||
|
rlRun "specfile=$(rpm --eval='%_specdir')/libffi.spec"
|
||||||
|
rlRun "rpmbuild -bp $specfile"
|
||||||
|
rlRun "builddir=$(rpm --eval='%_builddir')"
|
||||||
|
rlRun "pushd $builddir/libffi-*/"
|
||||||
|
rlRun "./configure"
|
||||||
|
rlRUn "make"
|
||||||
|
rlPhaseEnd
|
||||||
|
|
||||||
|
rlPhaseStartTest "Run testsuite"
|
||||||
|
|
||||||
|
# patching the testsuite to test the installed libraries instead of the built ones
|
||||||
|
if [ -e /usr/lib64/libffi.so ]; then
|
||||||
|
export LD_LIBRARY_PATH=/usr/lib64
|
||||||
|
perl -i -pe 's/LIBRARY_DIR/lib64/' $TmpDir/dynamic_linking.patch
|
||||||
|
perl -i -pe 's/LIBRARY_DIR/lib64/' $TmpDir/dynamic_linking-dg.patch
|
||||||
|
else
|
||||||
|
export LD_LIBRARY_PATH=/usr/lib
|
||||||
|
perl -i -pe 's/LIBRARY_DIR/lib/' $TmpDir/dynamic_linking.patch
|
||||||
|
perl -i -pe 's/LIBRARY_DIR/lib/' $TmpDir/dynamic_linking-dg.patch
|
||||||
|
fi
|
||||||
|
test -e testsuite/lib/libffi.exp && rlRun "patch testsuite/lib/libffi.exp < $TmpDir/dynamic_linking.patch"
|
||||||
|
test -e testsuite/lib/libffi-dg.exp && rlRun "patch testsuite/lib/libffi-dg.exp < $TmpDir/dynamic_linking-dg.patch"
|
||||||
|
rlLog "Checking whether we test really the installed libraries."
|
||||||
|
strace -F -e open,openat,stat -o strace.log -- make check
|
||||||
|
LIBFFI_SO_CALLS=`cat strace.log | grep libffi.so | grep -v ENOENT | grep -v 'usr/lib' | grep -v '\"\/lib' | grep -v 'unfinished' | wc -l`
|
||||||
|
rlAssertGreater "The just built libraries should not be used, everything should be taken from /usr" 5 $LIBFFI_SO_CALLS
|
||||||
|
rlRun "cat strace.log | grep libffi.so | grep usr"
|
||||||
|
rlRun "cat strace.log | grep libffi.so | grep rpmbuild" 1
|
||||||
|
rlRun "make check" 0 "RUNNING THE TESTSUITE"
|
||||||
|
rlRun "popd"
|
||||||
|
rlPhaseEnd
|
||||||
|
|
||||||
|
rlPhaseStartCleanup
|
||||||
|
rlRun "ls -al $TmpDir"
|
||||||
|
rlBundleLogs logs $(find . -name 'libffi.sum') $(find . -name 'libffi.log')
|
||||||
|
rlRun "rm -r $TmpDir" 0 "Removing tmp directory"
|
||||||
|
rlPhaseEnd
|
||||||
|
rlJournalPrintText
|
||||||
|
rlJournalEnd
|
Loading…
Reference in New Issue
Block a user