Update to libff-3.4.2.
This commit is contained in:
parent
16342320c7
commit
4bc39b5505
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ libffi-3.0.9.tar.gz
|
||||
/libffi-3.0.11.tar.gz
|
||||
/libffi-3.0.13.tar.gz
|
||||
/libffi-3.1.tar.gz
|
||||
/libffi-3.4.2.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/src/aarch64/sysv.S
|
||||
+++ b/src/aarch64/sysv.S
|
||||
@@ -396,3 +396,8 @@
|
||||
#ifdef __ELF__
|
||||
.size CNAME(ffi_closure_SYSV), .-CNAME(ffi_closure_SYSV)
|
||||
#endif
|
||||
+
|
||||
+#if defined __ELF__ && defined __linux__
|
||||
+ .section .note.GNU-stack,"",%progbits
|
||||
+#endif
|
||||
+
|
@ -1,31 +0,0 @@
|
||||
From 978c9540154d320525488db1b7049277122f736d Mon Sep 17 00:00:00 2001
|
||||
From: Samuli Suominen <ssuominen@gentoo.org>
|
||||
Date: Sat, 31 May 2014 08:53:10 -0400
|
||||
Subject: [PATCH] Add missing GNU stack markings in win32.S
|
||||
|
||||
---
|
||||
src/x86/win32.S | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/x86/win32.S b/src/x86/win32.S
|
||||
index daf0e79..e42baf2 100644
|
||||
--- a/src/x86/win32.S
|
||||
+++ b/src/x86/win32.S
|
||||
@@ -1,5 +1,6 @@
|
||||
/* -----------------------------------------------------------------------
|
||||
- win32.S - Copyright (c) 1996, 1998, 2001, 2002, 2009 Red Hat, Inc.
|
||||
+ win32.S - Copyright (c) 2014 Anthony Green
|
||||
+ Copyright (c) 1996, 1998, 2001, 2002, 2009 Red Hat, Inc.
|
||||
Copyright (c) 2001 John Beniton
|
||||
Copyright (c) 2002 Ranjit Mathew
|
||||
Copyright (c) 2009 Daniel Witte
|
||||
@@ -1304,3 +1305,6 @@ L_ffi_closure_SYSV_inner$stub:
|
||||
|
||||
#endif /* !_MSC_VER */
|
||||
|
||||
+#if defined __ELF__ && defined __linux__
|
||||
+ .section .note.GNU-stack,"",@progbits
|
||||
+#endif
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff -up libffi-3.1/libffi.pc.in.fixpath libffi-3.1/libffi.pc.in
|
||||
--- libffi-3.1/libffi.pc.in.fixpath 2014-04-25 19:45:13.000000000 +0200
|
||||
+++ libffi-3.1/libffi.pc.in 2014-06-12 12:06:06.000000000 +0200
|
||||
@@ -1,11 +1,10 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
libdir=@libdir@
|
||||
-toolexeclibdir=@toolexeclibdir@
|
||||
-includedir=${libdir}/@PACKAGE_NAME@-@PACKAGE_VERSION@/include
|
||||
+includedir=@includedir@
|
||||
|
||||
Name: @PACKAGE_NAME@
|
||||
Description: Library supporting Foreign Function Interfaces
|
||||
Version: @PACKAGE_VERSION@
|
||||
-Libs: -L${toolexeclibdir} -lffi
|
||||
+Libs: -L${libdir} -lffi
|
||||
Cflags: -I${includedir}
|
@ -1,17 +0,0 @@
|
||||
Most temp file directories need to be hardened against execution, but
|
||||
libffi needs execute privileges. Add a libffi-specific temp directory
|
||||
that can be set up by sysadmins as needed with suitable permissions.
|
||||
This both ensures that libffi will have a valid temp directory to use
|
||||
as well as preventing attempts to access other directories.
|
||||
|
||||
diff -rup a/src/closures.c b/src/closures.c
|
||||
--- a/src/closures.c 2014-05-11 09:54:19.000000000 -0400
|
||||
+++ b/src/closures.c 2020-04-29 20:50:00.454853909 -0400
|
||||
@@ -362,6 +362,7 @@ static struct
|
||||
const char *arg;
|
||||
int repeat;
|
||||
} open_temp_exec_file_opts[] = {
|
||||
+ { open_temp_exec_file_env, "LIBFFI_TMPDIR", 0 },
|
||||
{ open_temp_exec_file_env, "TMPDIR", 0 },
|
||||
{ open_temp_exec_file_dir, "/tmp", 0 },
|
||||
{ open_temp_exec_file_dir, "/var/tmp", 0 },
|
@ -1,11 +0,0 @@
|
||||
--- libffi-3.1/src/aarch64/ffi.c.orig 2014-04-25 18:45:13.000000000 +0100
|
||||
+++ libffi-3.1/src/aarch64/ffi.c 2015-01-15 02:36:56.314906455 +0000
|
||||
@@ -728,7 +728,7 @@
|
||||
state.ngrn = N_X_ARG_REG;
|
||||
|
||||
memcpy (allocate_to_stack (&state, stack, ty->alignment,
|
||||
- ty->size), ecif->avalue + i, ty->size);
|
||||
+ ty->size), ecif->avalue[i], ty->size);
|
||||
}
|
||||
break;
|
||||
|
36
libffi.spec
36
libffi.spec
@ -1,22 +1,17 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
%global multilib_arches %{ix86} ppc ppc64 ppc64p7 s390 s390x x86_64
|
||||
%global multilib_arches %{ix86} x86_64
|
||||
|
||||
Name: libffi
|
||||
Version: 3.1
|
||||
Release: 28%{?dist}
|
||||
Version: 3.4.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A portable foreign function interface library
|
||||
License: MIT
|
||||
URL: http://sourceware.org/libffi
|
||||
|
||||
Source0: ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
|
||||
Source0: https://github.com/libffi/libffi/releases/download/v3.4.2/libffi-3.4.2.tar.gz
|
||||
Source1: ffi-multilib.h
|
||||
Source2: ffitarget-multilib.h
|
||||
Patch0: libffi-3.1-fix-include-path.patch
|
||||
Patch1: libffi-3.1-fix-exec-stack.patch
|
||||
Patch2: libffi-aarch64-rhbz1174037.patch
|
||||
Patch3: libffi-3.1-aarch64-fix-exec-stack.patch
|
||||
Patch4: libffi-3.1-libffi_tmpdir.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -65,14 +60,14 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fixpath
|
||||
%patch1 -p1 -b .execstack
|
||||
%patch2 -p1 -b .aarch64
|
||||
%patch3 -p1 -b .aarch64execstack
|
||||
%patch4 -p1 -b .libffitmpdir
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
# For now we disable the static templates to avoid ghc and
|
||||
# gobject-introspection failures:
|
||||
# https://gitlab.haskell.org/ghc/ghc/-/issues/20051
|
||||
# https://gitlab.gnome.org/GNOME/gobject-introspection/-/merge_requests/283
|
||||
# We need to get these fixes into Fedora before we can reeanble them.
|
||||
%configure --disable-static --disable-exec-static-tramp
|
||||
%make_build
|
||||
|
||||
%check
|
||||
@ -97,21 +92,17 @@ mkdir -p $RPM_BUILD_ROOT%{_includedir}
|
||||
# can have both a 32- and 64-bit version of the library, and they each need
|
||||
# their own correct-but-different versions of the headers to be usable.
|
||||
for i in ffi ffitarget; do
|
||||
mv $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}/include/$i.h $RPM_BUILD_ROOT%{_includedir}/$i-${basearch}.h
|
||||
mv $RPM_BUILD_ROOT%{_includedir}/$i.h $RPM_BUILD_ROOT%{_includedir}/$i-${basearch}.h
|
||||
done
|
||||
install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/ffi.h
|
||||
install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_includedir}/ffitarget.h
|
||||
%else
|
||||
mv $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}/include/{ffi,ffitarget}.h $RPM_BUILD_ROOT%{_includedir}
|
||||
%endif
|
||||
rm -rf $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc README
|
||||
%doc README.md
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
@ -122,6 +113,9 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/libffi-%{version}
|
||||
%{_infodir}/libffi.info.*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 28 Carlos O'Donell <carlos@redhat.com> - 3.4.2-1
|
||||
- Rebase to libffi 3.4.2.
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-28
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user