73 lines
2.0 KiB
Diff
73 lines
2.0 KiB
Diff
From 89020f74a8309c41b1211f45e05d5ec619004eb7 Mon Sep 17 00:00:00 2001
|
|
From: Peter Hutterer <peter.hutterer@who-t.net>
|
|
Date: Fri, 15 Nov 2019 15:22:38 +1000
|
|
Subject: [PATCH libevdev] configure.ac: drop the custom linker and compiler
|
|
flags
|
|
|
|
Let these be defined by the build environment. No-one has ever done any true
|
|
analysis of these options for the libevdev context and whether they're
|
|
beneficial. Let's assume the distributions know what they want to set.
|
|
|
|
We leave in the visibility setting and the various warning options, both of
|
|
those are useful/needed.
|
|
|
|
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
|
---
|
|
configure.ac | 19 +------------------
|
|
libevdev/Makefile.am | 2 +-
|
|
2 files changed, 2 insertions(+), 19 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index b284acb..0d2eb9f 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -56,16 +56,6 @@ LT_PREREQ([2.2])
|
|
LT_INIT
|
|
LT_PATH_LD
|
|
|
|
-with_ldflags=""
|
|
-if test "x$lt_cv_prog_gnu_ld" = "xyes"; then
|
|
- CC_CHECK_FLAGS_APPEND([with_ldflags], [LDFLAGS], [\
|
|
- -Wl,--as-needed \
|
|
- -Wl,--gc-sections \
|
|
- -Wl,-z,relro \
|
|
- -Wl,-z,now])
|
|
-fi
|
|
-AC_SUBST([GNU_LD_FLAGS], $with_ldflags)
|
|
-
|
|
AC_CHECK_LIB([m], [round])
|
|
|
|
PKG_PROG_PKG_CONFIG()
|
|
@@ -87,14 +77,7 @@ if test "x$GCC" = "xyes"; then
|
|
-Wno-unused-parameter \
|
|
-Wstrict-prototypes \
|
|
-Wmissing-prototypes \
|
|
- -fvisibility=hidden \
|
|
- -pipe \
|
|
- -fno-strict-aliasing \
|
|
- -ffunction-sections \
|
|
- -fdata-sections \
|
|
- -fno-strict-aliasing \
|
|
- -fdiagnostics-show-option \
|
|
- -fno-common])
|
|
+ -fvisibility=hidden ])
|
|
fi
|
|
AC_SUBST([GCC_CFLAGS], $with_cflags)
|
|
|
|
diff --git a/libevdev/Makefile.am b/libevdev/Makefile.am
|
|
index f2757de..f6bee97 100644
|
|
--- a/libevdev/Makefile.am
|
|
+++ b/libevdev/Makefile.am
|
|
@@ -20,7 +20,7 @@ libevdev_la_LDFLAGS = \
|
|
$(AM_LDFLAGS) \
|
|
-version-info $(LIBEVDEV_LT_VERSION) \
|
|
-Wl,--version-script="$(srcdir)/libevdev.sym" \
|
|
- $(GNU_LD_FLAGS)
|
|
+ $(NULL)
|
|
|
|
EXTRA_libevdev_la_DEPENDENCIES = $(srcdir)/libevdev.sym
|
|
|
|
--
|
|
2.23.0
|
|
|