import libevdev-1.5.9-5.el8
This commit is contained in:
commit
1e2e058486
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/libevdev-1.5.9.tar.xz
|
1
.libevdev.metadata
Normal file
1
.libevdev.metadata
Normal file
@ -0,0 +1 @@
|
||||
9457e33af5c1e66e29c1385a5550fe60aef8e42e SOURCES/libevdev-1.5.9.tar.xz
|
98
SOURCES/0001-Drop-custom-linker-compiler-flags.patch
Normal file
98
SOURCES/0001-Drop-custom-linker-compiler-flags.patch
Normal file
@ -0,0 +1,98 @@
|
||||
From bf9a0112249ae64ad9c432d63dc6bd0e6ab16cb0 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Wed, 10 Oct 2018 20:06:34 +1000
|
||||
Subject: [PATCH libevdev] Drop custom linker/compiler flags
|
||||
|
||||
Let those be defined by the build environment
|
||||
|
||||
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
---
|
||||
configure.ac | 29 -----------------------------
|
||||
libevdev/Makefile.am | 4 ++--
|
||||
tools/Makefile.am | 2 +-
|
||||
3 files changed, 3 insertions(+), 32 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3fe8746..7dc00cd 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -56,16 +56,6 @@ LT_PREREQ([2.2])
|
||||
LT_INIT
|
||||
LT_PATH_LD
|
||||
|
||||
-with_ldflags=""
|
||||
-if test "x$lt_cv_prog_gnu_ld" = "xyes"; then
|
||||
- CC_CHECK_FLAGS_APPEND([with_ldflags], [LDFLAGS], [\
|
||||
- -Wl,--as-needed \
|
||||
- -Wl,--gc-sections \
|
||||
- -Wl,-z,relro \
|
||||
- -Wl,-z,now])
|
||||
-fi
|
||||
-AC_SUBST([GNU_LD_FLAGS], $with_ldflags)
|
||||
-
|
||||
AC_CHECK_LIB([m], [round])
|
||||
|
||||
PKG_PROG_PKG_CONFIG()
|
||||
@@ -84,25 +74,6 @@ AC_ARG_ENABLE([test-run],
|
||||
[run_tests="$enableval"], [run_tests="yes"])
|
||||
AM_CONDITIONAL(RUN_TESTS, [test "x$run_tests" = "xyes"])
|
||||
|
||||
-with_cflags=""
|
||||
-if test "x$GCC" = "xyes"; then
|
||||
- CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
|
||||
- -Wall \
|
||||
- -Wextra \
|
||||
- -Wno-unused-parameter \
|
||||
- -Wstrict-prototypes \
|
||||
- -Wmissing-prototypes \
|
||||
- -fvisibility=hidden \
|
||||
- -pipe \
|
||||
- -fno-strict-aliasing \
|
||||
- -ffunction-sections \
|
||||
- -fdata-sections \
|
||||
- -fno-strict-aliasing \
|
||||
- -fdiagnostics-show-option \
|
||||
- -fno-common])
|
||||
-fi
|
||||
-AC_SUBST([GCC_CFLAGS], $with_cflags)
|
||||
-
|
||||
AC_PATH_PROG(DOXYGEN, [doxygen])
|
||||
if test "x$DOXYGEN" = "x"; then
|
||||
AC_MSG_WARN([doxygen not found - required for documentation])
|
||||
diff --git a/libevdev/Makefile.am b/libevdev/Makefile.am
|
||||
index fcb434d..99367a5 100644
|
||||
--- a/libevdev/Makefile.am
|
||||
+++ b/libevdev/Makefile.am
|
||||
@@ -1,6 +1,6 @@
|
||||
lib_LTLIBRARIES=libevdev.la
|
||||
|
||||
-AM_CPPFLAGS = $(GCC_CFLAGS) $(GCOV_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)
|
||||
+AM_CPPFLAGS = $(GCOV_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)
|
||||
AM_LDFLAGS = $(GCOV_LDFLAGS)
|
||||
|
||||
libevdev_la_SOURCES = \
|
||||
@@ -20,7 +20,7 @@ libevdev_la_LDFLAGS = \
|
||||
$(AM_LDFLAGS) \
|
||||
-version-info $(LIBEVDEV_LT_VERSION) \
|
||||
-Wl,--version-script="$(srcdir)/libevdev.sym" \
|
||||
- $(GNU_LD_FLAGS)
|
||||
+ $(NULL)
|
||||
|
||||
EXTRA_libevdev_la_DEPENDENCIES = $(srcdir)/libevdev.sym
|
||||
|
||||
diff --git a/tools/Makefile.am b/tools/Makefile.am
|
||||
index d699c5c..13fe286 100644
|
||||
--- a/tools/Makefile.am
|
||||
+++ b/tools/Makefile.am
|
||||
@@ -4,7 +4,7 @@ bin_PROGRAMS = \
|
||||
mouse-dpi-tool \
|
||||
libevdev-tweak-device
|
||||
|
||||
-AM_CPPFLAGS = $(GCC_CFLAGS) -I$(top_srcdir) -I$(top_srcdir)/include -I$(top_srcdir)/libevdev
|
||||
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/include -I$(top_srcdir)/libevdev
|
||||
libevdev_ldadd = $(top_builddir)/libevdev/libevdev.la
|
||||
|
||||
libevdev_events_SOURCES = libevdev-events.c
|
||||
--
|
||||
2.19.1
|
||||
|
241
SPECS/libevdev.spec
Normal file
241
SPECS/libevdev.spec
Normal file
@ -0,0 +1,241 @@
|
||||
Name: libevdev
|
||||
Version: 1.5.9
|
||||
Release: 5%{?dist}
|
||||
Summary: Kernel Evdev Device Wrapper Library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: MIT
|
||||
URL: http://www.freedesktop.org/wiki/Software/libevdev
|
||||
Source0: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch01: 0001-Drop-custom-linker-compiler-flags.patch
|
||||
|
||||
BuildRequires: git-core
|
||||
BuildRequires: automake libtool
|
||||
BuildRequires: python3 python3-devel
|
||||
|
||||
%description
|
||||
%{name} is a library to wrap kernel evdev devices and provide a proper API
|
||||
to interact with those devices.
|
||||
|
||||
%package devel
|
||||
Summary: Kernel Evdev Device Wrapper Library Development Package
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Kernel Evdev Device Wrapper Library Development Package.
|
||||
|
||||
%package utils
|
||||
Summary: Kernel Evdev Device Wrapper Library Utilities Package
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description utils
|
||||
Utilities to handle and/or debug evdev devices.
|
||||
|
||||
%prep
|
||||
%autosetup -S git
|
||||
# Replace whatever the source uses with the approved call
|
||||
pathfix.py -i %{__python3} -p -n $(git grep -l '#!/usr/bin/.*python.*')
|
||||
|
||||
%build
|
||||
autoreconf --force -v --install || exit 1
|
||||
%configure --disable-static --disable-silent-rules --disable-gcov
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
# We intentionally don't ship *.la files
|
||||
rm -f %{buildroot}%{_libdir}/*.la
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%doc COPYING
|
||||
%{_libdir}/libevdev.so.*
|
||||
|
||||
%files devel
|
||||
%dir %{_includedir}/libevdev-1.0/
|
||||
%dir %{_includedir}/libevdev-1.0/libevdev
|
||||
%{_includedir}/libevdev-1.0/libevdev/libevdev.h
|
||||
%{_includedir}/libevdev-1.0/libevdev/libevdev-uinput.h
|
||||
%{_libdir}/libevdev.so
|
||||
%{_libdir}/pkgconfig/libevdev.pc
|
||||
%{_mandir}/man3/libevdev.3*
|
||||
|
||||
%files utils
|
||||
%{_bindir}/touchpad-edge-detector
|
||||
%{_bindir}/mouse-dpi-tool
|
||||
%{_bindir}/libevdev-tweak-device
|
||||
|
||||
%changelog
|
||||
* Wed Oct 10 2018 Peter Hutterer <peter.hutterer@redhat.com> 1.5.9-5
|
||||
- Drop custom linker/compiler flags (#1630579)
|
||||
|
||||
* Thu Jul 12 2018 Peter Hutterer <peter.hutterer@redhat.com> 1.5.9-4
|
||||
- Replace all python3 calls with the rpm macro
|
||||
- Switch to autosetup git to match other packages
|
||||
|
||||
* Wed Apr 04 2018 Peter Hutterer <peter.hutterer@redhat.com> 1.5.9-3
|
||||
- Use python3 instead of python2
|
||||
- use autosetup
|
||||
|
||||
* Thu Mar 15 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.5.9-2
|
||||
- Update Python 2 dependency declarations to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||
|
||||
* Thu Mar 08 2018 Peter Hutterer <peter.hutterer@redhat.com> 1.5.9-1
|
||||
- libevdev 1.5.9
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.5.8-2
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Mon Jan 29 2018 Peter Hutterer <peter.hutterer@redhat.com> 1.5.8-1
|
||||
- libevdev 1.5.8
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu May 04 2017 Peter Hutterer <peter.hutterer@redhat.com> 1.5.7-1
|
||||
- libevdev 1.5.7
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Jan 04 2017 Peter Hutterer <peter.hutterer@redhat.com> 1.5.6-1
|
||||
- libevdev 1.5.6
|
||||
|
||||
* Thu Dec 01 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.5-1
|
||||
- libevdev 1.5.5
|
||||
|
||||
* Fri Aug 26 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.4-1
|
||||
- libevdev 1.5.4
|
||||
|
||||
* Mon Aug 22 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.3-1
|
||||
- libevdev 1.5.3
|
||||
|
||||
* Wed Aug 17 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.2-2
|
||||
- Fix complaints about double tracking IDs on the MagicMouse (#1361325)
|
||||
|
||||
* Wed Jun 15 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.2-1
|
||||
- libevdev 1.5.2
|
||||
|
||||
* Mon May 16 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.1-1
|
||||
- libevdev 1.5.1
|
||||
|
||||
* Fri May 13 2016 Peter Hutterer <peter.hutterer@redhat.com> 1.5.0-1
|
||||
- libevdev 1.5
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Dec 22 2015 Peter Hutterer <peter.hutterer@redhat.com> 1.4.5-2
|
||||
- Fix a couple of coverity warnings
|
||||
- Fix a potential race condition when checking uinput device's syspath
|
||||
(inactive in Fedora, we use the ioctl and never get here)
|
||||
|
||||
* Wed Nov 11 2015 Peter Hutterer <peter.hutterer@redhat.com> 1.4.5-1
|
||||
- libevdev 1.4.5
|
||||
|
||||
* Tue Sep 01 2015 Peter Hutterer <peter.hutterer@redhat.com> 1.4.4-1
|
||||
- libevdev 1.4.4
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Apr 24 2015 Peter Hutterer <peter.hutterer@redhat.com> 1.4.2-1
|
||||
- libevdev 1.4.2
|
||||
|
||||
* Wed Apr 08 2015 Peter Hutterer <peter.hutterer@redhat.com> 1.4.1-1
|
||||
- libevdev 1.4.1
|
||||
|
||||
* Wed Mar 04 2015 Peter Hutterer <peter.hutterer@redhat.com> 1.4-1
|
||||
- libevdev 1.4
|
||||
|
||||
* Fri Dec 05 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.3.2-1
|
||||
- libevdev 1.3.2
|
||||
|
||||
* Thu Nov 13 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.3.1-1
|
||||
- libevdev 1.3.1
|
||||
|
||||
* Tue Sep 09 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.3-1
|
||||
- libevdev 1.3
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.99.901-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Fri Aug 08 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.2.99.901-1
|
||||
- libevdev 1.3RC1
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Jun 05 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.2.2-1
|
||||
- libevdev 1.2.2
|
||||
|
||||
* Wed May 14 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.2.1-1
|
||||
- libevdev 1.2.1
|
||||
|
||||
* Tue May 13 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.2-5
|
||||
- Bump release to fix the upgrade path from F20 which is now named
|
||||
1.2-04compat.
|
||||
|
||||
* Wed Apr 30 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.2-1
|
||||
- libevdev 1.2
|
||||
|
||||
* Thu Apr 24 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.1.99.1-1
|
||||
- libevdev 1.2 RC1
|
||||
|
||||
* Tue Mar 25 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.1-1
|
||||
- libevdev 1.1
|
||||
|
||||
* Wed Mar 19 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.0.99.2-1
|
||||
- libevdev 1.0.99.2
|
||||
|
||||
* Tue Mar 11 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.0.99.1-1
|
||||
- libevdev 1.0.99.1
|
||||
- Add libevdev-utils sub-package
|
||||
|
||||
* Fri Mar 07 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.0.1-1
|
||||
- libevdev 1.0.1
|
||||
|
||||
* Tue Feb 18 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.0-1
|
||||
- libevdev 1.0
|
||||
|
||||
* Wed Feb 05 2014 Peter Hutterer <peter.hutterer@redhat.com> 0.9.1-1
|
||||
- libevdev 1.0RC1
|
||||
|
||||
* Fri Jan 03 2014 Peter Hutterer <peter.hutterer@redhat.com> 0.6-3
|
||||
- Restore deprecated constants LIBEVDEV_READ_* dropped from 0.6 (#1046426)
|
||||
|
||||
* Thu Dec 26 2013 Adam Williamson <awilliam@redhat.com> 0.6-2
|
||||
- revert catastrophic upstream dropping of 'deprecated' functions - #1046426
|
||||
|
||||
* Mon Dec 23 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.6-1
|
||||
- libevdev 0.6
|
||||
|
||||
* Fri Nov 22 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.5-1
|
||||
- libevdev 0.5
|
||||
|
||||
* Fri Nov 01 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.4.1-1
|
||||
- libevdev 0.4.1
|
||||
|
||||
* Wed Oct 02 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.4-2
|
||||
- disable gcov (#1012180)
|
||||
- disable unittests, we don't run them anyway
|
||||
|
||||
* Wed Sep 18 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.4-1
|
||||
- libevdev 0.4
|
||||
|
||||
* Tue Aug 13 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.3-1
|
||||
- libevdev 0.3
|
||||
|
||||
* Thu Jul 25 2013 Peter Hutterer <peter.hutterer@redhat.com> 0.2.1-1
|
||||
- Initial package (#987204)
|
||||
|
Loading…
Reference in New Issue
Block a user