We used to move the header files in /usr/include/libev, whereas upstream (and other distributions) put them in /usr/include. This was confusing users of the library, who had to either come up with clever tricks to build on Fedora (often as downstream changes to the packages in Fedora) or worse, depend on the Fedora-only changes, so that the software would not build anywhere else. However, this means that the /usr/include/event.h file (which we used to put in /usr/include/libev/event.h) now conflicts with the one from libevent-devel. To avoid making libev-devel conflict with libevent-devel (which would be pretty terrible for users of both libraries, like the libverto developers for example), this commit introduces a new libev-libevent-devel subpackage just to contain this one header file, so that only this subpackage conflicts with libevent-devel. Given that the point of libev's event.h was to be a compatibility header with libevent, this actually makes it easier for users to rely on it. Finally, the pkgconfig file becomes completely unnecessary. As it was a Fedora-specific change that libev upstream rejected several times when it was proposed to them, this commit also drops it. All in all, this should remove user confusion over the Fedora libev package, and stop various upstreams from depending on Fedora-specific changes. Note that this should really not be pushed in Fedora <= 20 at this time, but only to Rawhide.
36 lines
870 B
Diff
36 lines
870 B
Diff
From c681304443714aabf4ede3682074dd95a6ee6a5c Mon Sep 17 00:00:00 2001
|
|
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
Date: Sun, 8 Sep 2013 09:39:25 +0400
|
|
Subject: [PATCH 2/3] Modernize the configure.ac
|
|
|
|
Without it, Automake 1.13 and above will refuse it.
|
|
|
|
See the details for AM_INIT_AUTOMAKE at:
|
|
http://www.gnu.org/software/automake/manual/automake.html#Public-Macros
|
|
|
|
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index f0c6d2b..aa83142 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1,10 +1,10 @@
|
|
-AC_INIT
|
|
+AC_INIT([libev], [4.15])
|
|
|
|
orig_CFLAGS="$CFLAGS"
|
|
|
|
AC_CONFIG_SRCDIR([ev_epoll.c])
|
|
|
|
-AM_INIT_AUTOMAKE(libev,4.15) dnl also update ev.h!
|
|
+AM_INIT_AUTOMAKE
|
|
AC_CONFIG_HEADERS([config.h])
|
|
AM_MAINTAINER_MODE
|
|
|
|
--
|
|
1.8.3.1
|
|
|