Update to 4.15 (rhbz 987489)
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
de53d2d38d
commit
984c6fce9f
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ libev-3.9.tar.gz
|
||||
/libev-4.03.tar.gz
|
||||
/libev-4.04.tar.gz
|
||||
/libev-4.11.tar.gz
|
||||
/libev-4.15.tar.gz
|
||||
|
59
0001-Add-pkgconfig-support.patch
Normal file
59
0001-Add-pkgconfig-support.patch
Normal file
@ -0,0 +1,59 @@
|
||||
From 502f04beeb0ac26c6f1944845713fe3f69d35387 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sun, 8 Sep 2013 09:38:38 +0400
|
||||
Subject: [PATCH 1/3] Add pkgconfig support
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
Makefile.am | 4 ++++
|
||||
configure.ac | 2 +-
|
||||
libev.pc.in | 11 +++++++++++
|
||||
3 files changed, 16 insertions(+), 1 deletion(-)
|
||||
create mode 100644 libev.pc.in
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 059305b..9e556c0 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -11,6 +11,10 @@ man_MANS = ev.3
|
||||
|
||||
include_HEADERS = ev.h ev++.h event.h
|
||||
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+
|
||||
+pkgconfig_DATA = libev.pc
|
||||
+
|
||||
lib_LTLIBRARIES = libev.la
|
||||
|
||||
libev_la_SOURCES = ev.c event.c
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 80b18cb..f0c6d2b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -22,5 +22,5 @@ AC_PROG_LIBTOOL
|
||||
|
||||
m4_include([libev.m4])
|
||||
|
||||
-AC_CONFIG_FILES([Makefile])
|
||||
+AC_CONFIG_FILES([Makefile libev.pc])
|
||||
AC_OUTPUT
|
||||
diff --git a/libev.pc.in b/libev.pc.in
|
||||
new file mode 100644
|
||||
index 0000000..3b6c636
|
||||
--- /dev/null
|
||||
+++ b/libev.pc.in
|
||||
@@ -0,0 +1,11 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: libev
|
||||
+Description: High-performance event loop/event model
|
||||
+Version: @VERSION@
|
||||
+Libs: -L${libdir} -lev
|
||||
+Libs.private:
|
||||
+Cflags: -I${includedir}
|
||||
--
|
||||
1.8.3.1
|
||||
|
35
0002-Modernize-the-configure.ac.patch
Normal file
35
0002-Modernize-the-configure.ac.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From c681304443714aabf4ede3682074dd95a6ee6a5c Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sun, 8 Sep 2013 09:39:25 +0400
|
||||
Subject: [PATCH 2/3] Modernize the configure.ac
|
||||
|
||||
Without it, Automake 1.13 and above will refuse it.
|
||||
|
||||
See the details for AM_INIT_AUTOMAKE at:
|
||||
http://www.gnu.org/software/automake/manual/automake.html#Public-Macros
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f0c6d2b..aa83142 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1,10 +1,10 @@
|
||||
-AC_INIT
|
||||
+AC_INIT([libev], [4.15])
|
||||
|
||||
orig_CFLAGS="$CFLAGS"
|
||||
|
||||
AC_CONFIG_SRCDIR([ev_epoll.c])
|
||||
|
||||
-AM_INIT_AUTOMAKE(libev,4.15) dnl also update ev.h!
|
||||
+AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_HEADERS([config.h])
|
||||
AM_MAINTAINER_MODE
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
35
0003-Respect-the-CFLAGS-if-defined.patch
Normal file
35
0003-Respect-the-CFLAGS-if-defined.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 288dcead638c2c5597c6ce150d16bd5de6e1ff85 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sun, 8 Sep 2013 09:40:30 +0400
|
||||
Subject: [PATCH 3/3] Respect the CFLAGS if defined
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=908096
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index aa83142..3a8164b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1,13 +1,13 @@
|
||||
AC_INIT([libev], [4.15])
|
||||
|
||||
-orig_CFLAGS="$CFLAGS"
|
||||
-
|
||||
AC_CONFIG_SRCDIR([ev_epoll.c])
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_HEADERS([config.h])
|
||||
AM_MAINTAINER_MODE
|
||||
|
||||
+orig_CFLAGS="$CFLAGS"
|
||||
+
|
||||
AC_PROG_CC
|
||||
|
||||
dnl Supply default CFLAGS, if not specified
|
||||
--
|
||||
1.8.3.1
|
||||
|
18
libev.spec
18
libev.spec
@ -3,17 +3,17 @@
|
||||
|
||||
Name: libev
|
||||
Summary: High-performance event loop/event model with lots of features
|
||||
Version: 4.11
|
||||
Release: 3%{?dist}
|
||||
Version: 4.15
|
||||
Release: 1%{?dist}
|
||||
License: BSD or GPLv2+
|
||||
URL: http://software.schmorp.de/pkg/libev.html
|
||||
Source0: http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
|
||||
|
||||
BuildRequires: autoconf automake libtool
|
||||
|
||||
Patch0: libev-4.11-Add-pkgconfig-support.patch
|
||||
Patch1: libev-4.11-Modernize-the-configure.ac.patch
|
||||
Patch2: libev-4.11-Respect-the-CFLAGS-if-defined.patch
|
||||
Patch0: 0001-Add-pkgconfig-support.patch
|
||||
Patch1: 0002-Modernize-the-configure.ac.patch
|
||||
Patch2: 0003-Respect-the-CFLAGS-if-defined.patch
|
||||
|
||||
%description
|
||||
Libev is modeled (very loosely) after libevent and the Event Perl
|
||||
@ -93,6 +93,10 @@ install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Sep 8 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 4.15-1
|
||||
- Update to 4.15 (rhbz 987489)
|
||||
- Fix dates in spec
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.11-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
@ -130,7 +134,7 @@ install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
|
||||
* Sat Jan 2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
|
||||
- 3.9
|
||||
|
||||
* Fri Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
|
||||
* Mon Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
|
||||
- 3.8
|
||||
- always use the most recent automake
|
||||
- BuildRequires now libtool
|
||||
@ -178,7 +182,7 @@ install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
|
||||
* Tue Sep 2 2008 kwizart <kwizart at gmail.com> - 3.43-4
|
||||
- Fix pkgconfig support
|
||||
|
||||
* Mon Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
|
||||
* Tue Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
|
||||
- removed libev.a
|
||||
- installing with "-p"
|
||||
- event.h is removed intentionaly, because is there only for
|
||||
|
Loading…
Reference in New Issue
Block a user