Remove old unused patch
This commit is contained in:
parent
ea3c50bf81
commit
468afbd26b
@ -1,59 +0,0 @@
|
|||||||
From 502f04beeb0ac26c6f1944845713fe3f69d35387 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Sun, 8 Sep 2013 09:38:38 +0400
|
|
||||||
Subject: [PATCH 1/3] Add pkgconfig support
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
Makefile.am | 4 ++++
|
|
||||||
configure.ac | 2 +-
|
|
||||||
libev.pc.in | 11 +++++++++++
|
|
||||||
3 files changed, 16 insertions(+), 1 deletion(-)
|
|
||||||
create mode 100644 libev.pc.in
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index 059305b..9e556c0 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -11,6 +11,10 @@ man_MANS = ev.3
|
|
||||||
|
|
||||||
include_HEADERS = ev.h ev++.h event.h
|
|
||||||
|
|
||||||
+pkgconfigdir = $(libdir)/pkgconfig
|
|
||||||
+
|
|
||||||
+pkgconfig_DATA = libev.pc
|
|
||||||
+
|
|
||||||
lib_LTLIBRARIES = libev.la
|
|
||||||
|
|
||||||
libev_la_SOURCES = ev.c event.c
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 80b18cb..f0c6d2b 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -22,5 +22,5 @@ AC_PROG_LIBTOOL
|
|
||||||
|
|
||||||
m4_include([libev.m4])
|
|
||||||
|
|
||||||
-AC_CONFIG_FILES([Makefile])
|
|
||||||
+AC_CONFIG_FILES([Makefile libev.pc])
|
|
||||||
AC_OUTPUT
|
|
||||||
diff --git a/libev.pc.in b/libev.pc.in
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..3b6c636
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/libev.pc.in
|
|
||||||
@@ -0,0 +1,11 @@
|
|
||||||
+prefix=@prefix@
|
|
||||||
+exec_prefix=@prefix@
|
|
||||||
+libdir=@libdir@
|
|
||||||
+includedir=@includedir@
|
|
||||||
+
|
|
||||||
+Name: libev
|
|
||||||
+Description: High-performance event loop/event model
|
|
||||||
+Version: @VERSION@
|
|
||||||
+Libs: -L${libdir} -lev
|
|
||||||
+Libs.private:
|
|
||||||
+Cflags: -I${includedir}
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user