diff --git a/.gitignore b/.gitignore
index e69de29..61b155e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/liberation-fonts-1.07.2.tar.gz
+/liberation-narrow-fonts-1.07.5.tar.gz
+/liberation-narrow-fonts-1.07.6.tar.gz
diff --git a/liberation-narrow-fonts-generate.pe b/liberation-narrow-fonts-generate.pe
new file mode 100644
index 0000000..bf9bcb2
--- /dev/null
+++ b/liberation-narrow-fonts-generate.pe
@@ -0,0 +1,19 @@
+#!/usr/bin/env fontforge
+
+# script file for FontForge for TTF generation
+# usage:
+# mkdir TTFfiles
+# chmod +x generate.pe
+# ./generate.pe *.sfd
+
+if ($version < "20061220")
+ Error("Your version of FontForge is too old - 20061220 or newer is required");
+endif
+i = 1
+while ( i < $argc )
+ Open($argv[i], 1)
+ #Use gen_flags=Defualt fmflags value as -1
+ gen_flags = -1
+ Generate("" + $fontname + ".ttf", "", gen_flags)
+ i++
+endloop
diff --git a/liberation-narrow-fonts.conf b/liberation-narrow-fonts.conf
new file mode 100644
index 0000000..fdbe20d
--- /dev/null
+++ b/liberation-narrow-fonts.conf
@@ -0,0 +1,16 @@
+
+
+
+
+ sans-serif
+
+ Liberation Sans Narrow
+
+
+
+ Liberation Sans Narrow
+
+ sans-serif
+
+
+
diff --git a/liberation-narrow-fonts.metainfo.xml b/liberation-narrow-fonts.metainfo.xml
new file mode 100644
index 0000000..a550a1b
--- /dev/null
+++ b/liberation-narrow-fonts.metainfo.xml
@@ -0,0 +1,24 @@
+
+
+ com.github.LiberationNarrow
+ CC-BY-3.0
+ Liberation
+ Liberation Narrow
+ The Liberation Narrow Fonts are intended to be replacements for the Arial Narrow.
+
+
+ The Liberation(tm) Fonts is a font family which aims at metric compatibility with Arial, Times New Roman, and Courier New. It is sponsored by Red Hat
+
+
+ vishalvijayraghavan_at_gmail_dot_com
+ https://github.com/liberationfonts/liberation-sans-narrow
+
+ Liberation Narrow
+ Liberation Narrow Bold
+ Liberation Narrow BoldItalic
+ Liberation Narrow Italic
+
+
+
+
+
diff --git a/liberation-narrow-fonts.spec b/liberation-narrow-fonts.spec
new file mode 100644
index 0000000..a287f28
--- /dev/null
+++ b/liberation-narrow-fonts.spec
@@ -0,0 +1,111 @@
+%global priority 59
+%global fontname liberation-narrow
+%global fontconf %{priority}-%{fontname}.conf
+%global catalogue %{_sysconfdir}/X11/fontpath.d
+
+Name: %{fontname}-fonts
+Summary: Sans-serif Narrow fonts to replace commonly used Microsoft Arial Narrow
+Version: 1.07.6
+Release: 4%{?dist}
+Epoch: 2
+# The license of the Liberation Fonts is a EULA that contains GPLv2 and two
+# exceptions:
+# The first exception is the standard FSF font exception.
+# The second exception is an anti-lockdown clause somewhat like the one in
+# GPLv3. This license is Free, but GPLv2 and GPLv3 incompatible.
+License: Liberation
+Group: User Interface/X
+URL: https://github.com/liberationfonts/liberation-sans-narrow
+Source0: %{url}/files/2579430/%{name}-%{version}.tar.gz
+Source1: %{name}-generate.pe
+Source2: %{name}.conf
+Source3: %{name}.metainfo.xml
+BuildArch: noarch
+BuildRequires: fontpackages-devel, xorg-x11-font-utils
+BuildRequires: fontforge
+BuildRequires: libappstream-glib
+Requires: fontpackages-filesystem
+
+%description
+The Liberation Sans Narrow Fonts are intended to be replacements for
+the Arial Narrow.
+
+%prep
+%autosetup %{name}
+rm -rf scripts
+mv src/LiberationSansNarrow* .
+rm -rf src
+cp -p %{SOURCE1} .
+cp -p %{SOURCE2} .
+chmod 755 %{name}-generate.pe
+
+%build
+./%{name}-generate.pe *.sfd
+
+%install
+# fonts .ttf
+install -m 0755 -d %{buildroot}%{_fontdir}
+install -m 0644 -p *.ttf %{buildroot}%{_fontdir}
+
+# catalogue
+install -m 0755 -d %{buildroot}%{catalogue}
+ln -s %{_fontdir} %{buildroot}%{catalogue}/%{name}
+
+# fonts.{dir,scale}
+mkfontscale %{buildroot}%{_fontdir}
+mkfontdir %{buildroot}%{_fontdir}
+
+install -m 0755 -d %{buildroot}%{_fontconfig_templatedir} \
+ %{buildroot}%{_fontconfig_confdir}
+install -m 0644 -p %{SOURCE2} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}
+install -Dm 0644 -p %{SOURCE3} \
+ %{buildroot}%{_datadir}/metainfo/%{fontname}.metainfo.xml
+
+ln -s %{_fontconfig_templatedir}/%{fontconf} \
+ %{buildroot}%{_fontconfig_confdir}/%{fontconf}
+
+
+%check
+appstream-util validate-relax --nonet \
+ %{buildroot}%{_datadir}/metainfo/%{fontname}.metainfo.xml
+
+%_font_pkg -f %{fontconf} *.ttf
+
+%doc AUTHORS ChangeLog COPYING README.rst TODO
+%license License.txt
+%{_datadir}/metainfo/%{fontname}.metainfo.xml
+%verify(not md5 size mtime) %{_fontdir}/fonts.dir
+%verify(not md5 size mtime) %{_fontdir}/fonts.scale
+%{catalogue}/%{name}
+
+%changelog
+* Tue Jul 28 2020 Fedora Release Engineering - 2:1.07.6-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Wed Jan 29 2020 Fedora Release Engineering - 2:1.07.6-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Wed Sep 4 2019 Vishal Vijayraghavan - 2:1.07.6-2
+- Resolves:rh#1747737 packages with conflicts
+
+* Thu Jul 25 2019 Fedora Release Engineering - 1.07.5-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Fri Feb 01 2019 Fedora Release Engineering - 1.07.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Mon Jul 23 2018 Vishal Vijayraghavan - 1.07.5-1
+- new release since liberation-narrow font is seperted from liberation 1.x
+
+* Fri Nov 23 2012 Pravin Satpute - 1.07.2-10
+- added fontpackages-filesystem in requires
+
+* Thu Nov 22 2012 Pravin Satpute - 1.07.2-9
+- spec file clean up
+
+* Thu Jul 26 2012 Pravin Satpute - 1.07.2-8
+- updated as per pkg review comments #840878
+
+* Tue Jul 17 2012 Pravin Satpute - 1.07.2-7
+- Initial release after splitting it from liberation-fonts tarball due to license incompatibility.
diff --git a/sources b/sources
new file mode 100644
index 0000000..7d242b5
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (liberation-narrow-fonts-1.07.6.tar.gz) = 964a41dc3861644f536817a40d79273da8fb9fec0911e7ab8a7d7e226171724ea6f966bda656edbf21c2d99f0d9b7b0bcfcdc85263ef20ba1d70fe7538d2243d