diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..d606a64
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/liberation-narrow-fonts-1.07.5.tar.gz
diff --git a/EMPTY b/EMPTY
deleted file mode 100644
index 0519ecb..0000000
--- a/EMPTY
+++ /dev/null
@@ -1 +0,0 @@
-
\ No newline at end of file
diff --git a/liberation-narrow-fonts-generate.pe b/liberation-narrow-fonts-generate.pe
new file mode 100644
index 0000000..bf9bcb2
--- /dev/null
+++ b/liberation-narrow-fonts-generate.pe
@@ -0,0 +1,19 @@
+#!/usr/bin/env fontforge
+
+# script file for FontForge for TTF generation
+# usage:
+# mkdir TTFfiles
+# chmod +x generate.pe
+# ./generate.pe *.sfd
+
+if ($version < "20061220")
+ Error("Your version of FontForge is too old - 20061220 or newer is required");
+endif
+i = 1
+while ( i < $argc )
+ Open($argv[i], 1)
+ #Use gen_flags=Defualt fmflags value as -1
+ gen_flags = -1
+ Generate("" + $fontname + ".ttf", "", gen_flags)
+ i++
+endloop
diff --git a/liberation-narrow-fonts.conf b/liberation-narrow-fonts.conf
new file mode 100644
index 0000000..fdbe20d
--- /dev/null
+++ b/liberation-narrow-fonts.conf
@@ -0,0 +1,16 @@
+
+
+
+
+ sans-serif
+
+ Liberation Sans Narrow
+
+
+
+ Liberation Sans Narrow
+
+ sans-serif
+
+
+
diff --git a/liberation-narrow-fonts.metainfo.xml b/liberation-narrow-fonts.metainfo.xml
new file mode 100644
index 0000000..a550a1b
--- /dev/null
+++ b/liberation-narrow-fonts.metainfo.xml
@@ -0,0 +1,24 @@
+
+
+ com.github.LiberationNarrow
+ CC-BY-3.0
+ Liberation
+ Liberation Narrow
+ The Liberation Narrow Fonts are intended to be replacements for the Arial Narrow.
+
+
+ The Liberation(tm) Fonts is a font family which aims at metric compatibility with Arial, Times New Roman, and Courier New. It is sponsored by Red Hat
+
+
+ vishalvijayraghavan_at_gmail_dot_com
+ https://github.com/liberationfonts/liberation-sans-narrow
+
+ Liberation Narrow
+ Liberation Narrow Bold
+ Liberation Narrow BoldItalic
+ Liberation Narrow Italic
+
+
+
+
+
diff --git a/liberation-narrow-fonts.spec b/liberation-narrow-fonts.spec
new file mode 100644
index 0000000..f26666b
--- /dev/null
+++ b/liberation-narrow-fonts.spec
@@ -0,0 +1,97 @@
+%global priority 59
+%global fontname liberation-narrow
+%global fontconf %{priority}-%{fontname}.conf
+%global catalogue %{_sysconfdir}/X11/fontpath.d
+
+Name: %{fontname}-fonts
+Summary: Sans-serif Narrow fonts to replace commonly used Microsoft Arial Narrow
+Version: 1.07.5
+Release: 2%{?dist}
+# The license of the Liberation Fonts is a EULA that contains GPLv2 and two
+# exceptions:
+# The first exception is the standard FSF font exception.
+# The second exception is an anti-lockdown clause somewhat like the one in
+# GPLv3. This license is Free, but GPLv2 and GPLv3 incompatible.
+License: Liberation
+URL: https://github.com/liberationfonts/liberation-sans-narrow
+Source0: https://github.com/liberationfonts/liberation-sans-narrow/releases/download/%{version}/%{name}-%{version}.tar.gz
+Source1: %{name}-generate.pe
+Source2: %{name}.conf
+Source3: %{name}.metainfo.xml
+BuildArch: noarch
+BuildRequires: fontpackages-devel, xorg-x11-font-utils
+BuildRequires: fontforge
+BuildRequires: libappstream-glib
+Requires: fontpackages-filesystem
+
+%description
+The Liberation Sans Narrow Fonts are intended to be replacements for \
+the Arial Narrow.
+
+%prep
+%autosetup %{name}
+rm -rf scripts
+mv src/LiberationSansNarrow* .
+rm -rf src
+cp -p %{SOURCE1} .
+cp -p %{SOURCE2} .
+chmod 755 %{name}-generate.pe
+
+%build
+./%{name}-generate.pe *.sfd
+
+%install
+# fonts .ttf
+install -m 0755 -d %{buildroot}%{_fontdir}
+install -m 0644 -p *.ttf %{buildroot}%{_fontdir}
+
+# catalogue
+install -m 0755 -d %{buildroot}%{catalogue}
+ln -s %{_fontdir} %{buildroot}%{catalogue}/%{name}
+
+# fonts.{dir,scale}
+mkfontscale %{buildroot}%{_fontdir}
+mkfontdir %{buildroot}%{_fontdir}
+
+install -m 0755 -d %{buildroot}%{_fontconfig_templatedir} \
+ %{buildroot}%{_fontconfig_confdir}
+install -m 0644 -p %{SOURCE2} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}
+install -Dm 0644 -p %{SOURCE3} \
+ %{buildroot}%{_datadir}/metainfo/%{fontname}.metainfo.xml
+
+ln -s %{_fontconfig_templatedir}/%{fontconf} \
+ %{buildroot}%{_fontconfig_confdir}/%{fontconf}
+
+
+%check
+appstream-util validate-relax --nonet \
+ %{buildroot}%{_datadir}/metainfo/%{fontname}.metainfo.xml
+
+%_font_pkg -f %{fontconf} *.ttf
+
+%doc AUTHORS ChangeLog COPYING README.rst TODO
+%license License.txt
+%{_datadir}/metainfo/%{fontname}.metainfo.xml
+%verify(not md5 size mtime) %{_fontdir}/fonts.dir
+%verify(not md5 size mtime) %{_fontdir}/fonts.scale
+%{catalogue}/%{name}
+
+%changelog
+*Tue Aug 14 2018 Vishal Vijayraghavan - 1.07.5-2
+- Resolves: rhbz#1614530
+
+*Mon Jul 23 2018 Vishal Vijayraghavan - 1.07.5-1
+- new release since liberation-narrow font is seperted from liberation 1.x
+
+* Fri Nov 23 2012 Pravin Satpute - 1.07.2-10
+- added fontpackages-filesystem in requires
+
+* Thu Nov 22 2012 Pravin Satpute - 1.07.2-9
+- spec file clean up
+
+* Thu Jul 26 2012 Pravin Satpute - 1.07.2-8
+- updated as per pkg review comments #840878
+
+* Tue Jul 17 2012 Pravin Satpute - 1.07.2-7
+- Initial release after splitting it from liberation-fonts tarball due to license incompatibility.
diff --git a/sources b/sources
new file mode 100644
index 0000000..cf2e3c7
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (liberation-narrow-fonts-1.07.5.tar.gz) = 3e3f2560f39c23b707df0e59c62cde4c46b22b76d3ae97f6cb78bc314707f51c9817ad7fd44d7fcb70bb771300e2ff075aab35f55ecf8a62048fa3d4071970b0