Fix description to not talk about DRM

- Sync some small bugfixes from git
This commit is contained in:
Adam Jackson 2015-03-25 13:09:48 -04:00
parent 4be7bb34ed
commit 7b672b1ff6
4 changed files with 157 additions and 2 deletions

View File

@ -0,0 +1,57 @@
From d56f21c494b315306215c4730835a9b291360e9b Mon Sep 17 00:00:00 2001
From: Eric Anholt <eric@anholt.net>
Date: Fri, 13 Jun 2014 14:59:37 -0700
Subject: [PATCH 1/3] Use the EGL pkgconfig for finding eglplatform.h.
We don't ever explicity link against libEGL, so no need to make use of
EGL_LIBS.
Fixes #30.
---
configure.ac | 1 +
src/Makefile.am | 1 +
test/Makefile.am | 4 +++-
3 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 399e351..f97c9b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,6 +98,7 @@ AC_SUBST(EPOXY_LINK_LIBS)
AM_CONDITIONAL(BUILD_EGL, test x$build_egl = xyes)
if test x$build_egl = xyes; then
+ PKG_CHECK_MODULES(EGL, [egl])
AC_DEFINE([BUILD_EGL], [1], [build EGL tests])
fi
diff --git a/src/Makefile.am b/src/Makefile.am
index 8e20cd6..49c3507 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,6 +28,7 @@ AM_CFLAGS = \
$(CWARNFLAGS) \
$(VISIBILITY_CFLAGS) \
$(X11_CFLAGS) \
+ $(EGL_CFLAGS) \
$()
epoxyincludedir = $(includedir)/epoxy
diff --git a/test/Makefile.am b/test/Makefile.am
index ffb330e..f29baca 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -46,7 +46,9 @@ libwgl_common_la_LIBADD = $(EPOXY)
AM_CPPFLAGS = \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
- $(X11_CFLAGS)
+ $(X11_CFLAGS) \
+ $(EGL_CFLAGS) \
+ $()
AM_CFLAGS = $(CWARNFLAGS)
--
1.9.3

View File

@ -0,0 +1,27 @@
From 0096b79923f4a2b73b004f679d48ef110936a459 Mon Sep 17 00:00:00 2001
From: Eric Anholt <eric@anholt.net>
Date: Fri, 13 Jun 2014 15:00:31 -0700
Subject: [PATCH 2/3] Fix context type detection if we find
eglGetCurrentContext().
Fixes #29.
---
src/dispatch_common.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/dispatch_common.c b/src/dispatch_common.c
index b36b639..4e34d6e 100644
--- a/src/dispatch_common.c
+++ b/src/dispatch_common.c
@@ -378,7 +378,7 @@ epoxy_current_context_is_glx(void)
sym = dlsym(NULL, "eglGetCurrentContext");
if (sym) {
if (epoxy_egl_get_current_gl_context_api() != EGL_NONE)
- return true;
+ return false;
} else {
(void)dlerror();
}
--
1.9.3

View File

@ -0,0 +1,60 @@
From b2ae054b3aa0d6796b6936c7a89b8cce7cefe7ba Mon Sep 17 00:00:00 2001
From: Eric Anholt <eric@anholt.net>
Date: Fri, 13 Jun 2014 15:54:29 -0700
Subject: [PATCH 3/3] Avoid name conflicts between pkgconfig's EGL_LIBS and a
temporary var.
I felt a little uncomfortable knowing I had two things defining
EGL_LIBS, but it worked on my system. It failed on the travis ci
build.
---
test/Makefile.am | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/test/Makefile.am b/test/Makefile.am
index f29baca..1892b17 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -22,9 +22,9 @@
EPOXY = $(builddir)/../src/libepoxy.la
check_LTLIBRARIES = \
- $(EGL_LIBS) \
- $(GLX_LIBS) \
- $(WGL_LIBS) \
+ $(EGL_UTIL_LIB) \
+ $(GLX_UTIL_LIB) \
+ $(WGL_UTIL_LIB) \
$()
libegl_common_la_SOURCES = \
@@ -78,7 +78,7 @@ EGL_TESTS = \
egl_gles2_without_glx \
$()
-EGL_LIBS = libegl_common.la
+EGL_UTIL_LIB = libegl_common.la
endif
if BUILD_GLX
@@ -116,7 +116,7 @@ GLX_TESTS = \
$(GLX_NON_APPLE_TESTS) \
$()
-GLX_LIBS = libglx_common.la
+GLX_UTIL_LIB = libglx_common.la
endif
if BUILD_WGL
@@ -127,7 +127,7 @@ WGL_TESTS = \
wgl_usefontbitmaps_unicode$(EXEEXT) \
$()
-WGL_LIBS = libwgl_common.la
+WGL_UTIL_LIB = libwgl_common.la
endif
egl_has_extension_nocontext_LDADD = $(EPOXY) libegl_common.la $(X11_LIBS)
--
1.9.3

View File

@ -3,10 +3,10 @@
#global commit 6eb075c70e2f91a9c45a90677bd46e8fb0432655
#global shortcommit %(c=%{commit}; echo ${c:0:7})
Summary: Direct Rendering Manager runtime library
Summary: epoxy runtime library
Name: libepoxy
Version: 1.2
Release: 1%{?dist}
Release: 2%{?dist}
License: MIT
URL: http://github.com/anholt/libepoxy
# github url - generated archive
@ -20,6 +20,10 @@ BuildRequires: mesa-libGLES-devel
BuildRequires: xorg-x11-util-macros
BuildRequires: python3
Patch1: 0001-Use-the-EGL-pkgconfig-for-finding-eglplatform.h.patch
Patch2: 0002-Fix-context-type-detection-if-we-find-eglGetCurrentC.patch
Patch3: 0003-Avoid-name-conflicts-between-pkgconfig-s-EGL_LIBS-an.patch
%description
A library for handling OpenGL function pointer management.
@ -33,6 +37,9 @@ developing applications that use %{name}.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%build
autoreconf -vif || exit 1
@ -69,6 +76,10 @@ make check ||:
%{_libdir}/pkgconfig/epoxy.pc
%changelog
* Wed Mar 25 2015 Adam Jackson <ajax@redhat.com> 1.2-2
- Fix description to not talk about DRM
- Sync some small bugfixes from git
* Mon Oct 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.0-1
- Update to 1.2 GA
- Don't fail build on make check failure for some architectures