Rebase to latest upstream version (3.1.20150325)
This commit is contained in:
parent
ead47067ec
commit
bf233f85fb
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ libedit-20110227-3.0.tar.gz
|
||||
/libedit-20130712-3.1.tar.gz
|
||||
/libedit-20140213-3.1.tar.gz
|
||||
/libedit-20141030-3.1.tar.gz
|
||||
/libedit-20150325-3.1.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 8c0f52589d106e5ac32d7868d7b51d3dfab6c0a5 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Wed, 25 Mar 2015 17:33:00 +0100
|
||||
Subject: [PATCH] Ignore non-ASCII characters only if charset is not UTF-8
|
||||
|
||||
---
|
||||
src/eln.c | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/eln.c b/src/eln.c
|
||||
index 5bcfb4f..6023891 100644
|
||||
--- a/src/eln.c
|
||||
+++ b/src/eln.c
|
||||
@@ -76,9 +76,11 @@ el_gets(EditLine *el, int *nread)
|
||||
{
|
||||
const wchar_t *tmp;
|
||||
|
||||
- el->el_flags |= IGNORE_EXTCHARS;
|
||||
+ if (!(el->el_flags & CHARSET_IS_UTF8))
|
||||
+ el->el_flags |= IGNORE_EXTCHARS;
|
||||
tmp = el_wgets(el, nread);
|
||||
- el->el_flags &= ~IGNORE_EXTCHARS;
|
||||
+ if (!(el->el_flags & CHARSET_IS_UTF8))
|
||||
+ el->el_flags &= ~IGNORE_EXTCHARS;
|
||||
return ct_encode_string(tmp, &el->el_lgcyconv);
|
||||
}
|
||||
|
||||
--
|
||||
2.1.0
|
||||
|
14
libedit.spec
14
libedit.spec
@ -1,16 +1,15 @@
|
||||
%global snap 20141030
|
||||
%global dir_snap 20141029
|
||||
%global snap 20150325
|
||||
%global dir_snap 20150325
|
||||
|
||||
Summary: The NetBSD Editline library
|
||||
Name: libedit
|
||||
Version: 3.1
|
||||
Release: 11.%{snap}cvs%{?dist}
|
||||
Release: 12.%{snap}cvs%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.thrysoee.dk/editline/
|
||||
Source0: http://www.thrysoee.dk/editline/%{name}-%{snap}-%{version}.tar.gz
|
||||
Patch1: 0001-Ignore-non-ASCII-characters-only-if-charset-is-not-U.patch
|
||||
Patch2: 0002-Hide-protected-symbols-from-other-modules.patch
|
||||
Patch1: 0001-Hide-protected-symbols-from-other-modules.patch
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
%description
|
||||
@ -32,7 +31,6 @@ This package contains development files for %{name}.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{dir_snap}-%{version}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Suppress rpmlint error.
|
||||
iconv -f ISO8859-1 -t UTF-8 -o ChangeLog.utf-8 ChangeLog
|
||||
@ -73,6 +71,10 @@ find $RPM_BUILD_ROOT -type f -name "*.la" -delete
|
||||
%{_includedir}/editline/readline.h
|
||||
|
||||
%changelog
|
||||
* Thu Mar 26 2015 Boris Ranto <branto@redhat.com> - 3.1-12.20150325cvs
|
||||
- Rebase to latest upstream version
|
||||
- We no longer need the patch to not ignore extchars on utf8 charset -- the patch was merged upstream
|
||||
|
||||
* Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 3.1-11.20141030cvs
|
||||
- change the format of patches
|
||||
- hide protected functions from other modules
|
||||
|
Loading…
Reference in New Issue
Block a user