* Thu Mar 24 2011 Jerry James <loganjerry@gmail.com> - 3.0-3.20110227cvs
- Update to 3.0 (20110227 snap) - Drop upstreamed -sigwinch patch - Preserve ChangeLog timestamp when converting to UTF-8 - Fix "unused direct shared library dependency" warning from rpmlint - Don't BR gawk; it is on the exceptions list
This commit is contained in:
parent
38bd05a667
commit
9284484112
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
libedit-20100424-3.0.tar.gz
|
||||
libedit-20110227-3.0.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- libedit-20100424-3.0/src/read.c.sigwinch 2010-04-22 14:09:52.000000000 -0600
|
||||
+++ libedit-20100424-3.0/src/read.c 2011-02-05 18:16:19.007277633 -0700
|
||||
@@ -325,6 +325,9 @@
|
||||
sig_set(el);
|
||||
el_set(el, EL_REFRESH);
|
||||
goto again;
|
||||
+ } else if (el->el_signal->sig_no == SIGWINCH) {
|
||||
+ sig_set(el);
|
||||
+ goto again;
|
||||
}
|
||||
if (!tried && read__fixio(el->el_infd, errno) == 0)
|
||||
tried = 1;
|
@ -1,6 +1,6 @@
|
||||
diff -durp libedit-20100424-3.0.orig/examples/fileman.c libedit-20100424-3.0/examples/fileman.c
|
||||
--- libedit-20100424-3.0.orig/examples/fileman.c 2010-04-22 13:13:17.000000000 -0600
|
||||
+++ libedit-20100424-3.0/examples/fileman.c 2011-02-07 13:14:13.209553427 -0700
|
||||
diff -durp libedit-20110227-3.0.orig/examples/fileman.c libedit-20110227-3.0/examples/fileman.c
|
||||
--- libedit-20110227-3.0.orig/examples/fileman.c 2010-04-22 13:13:17.000000000 -0600
|
||||
+++ libedit-20110227-3.0/examples/fileman.c 2011-03-24 15:48:02.492809146 -0600
|
||||
@@ -279,7 +279,7 @@ command_generator (text, state)
|
||||
|
||||
/* Return the next name which partially matches from the
|
||||
@ -10,9 +10,9 @@ diff -durp libedit-20100424-3.0.orig/examples/fileman.c libedit-20100424-3.0/exa
|
||||
{
|
||||
list_index++;
|
||||
|
||||
diff -durp libedit-20100424-3.0.orig/examples/wtc1.c libedit-20100424-3.0/examples/wtc1.c
|
||||
--- libedit-20100424-3.0.orig/examples/wtc1.c 2010-04-22 13:13:17.000000000 -0600
|
||||
+++ libedit-20100424-3.0/examples/wtc1.c 2011-02-07 13:19:20.839378510 -0700
|
||||
diff -durp libedit-20110227-3.0.orig/examples/wtc1.c libedit-20110227-3.0/examples/wtc1.c
|
||||
--- libedit-20110227-3.0.orig/examples/wtc1.c 2010-04-22 13:13:17.000000000 -0600
|
||||
+++ libedit-20110227-3.0/examples/wtc1.c 2011-03-24 15:48:02.493809075 -0600
|
||||
@@ -60,7 +60,7 @@ complete(EditLine *el, int ch)
|
||||
char *buf, *bptr;
|
||||
const LineInfoW *lf = el_wline(el);
|
||||
@ -22,10 +22,10 @@ diff -durp libedit-20100424-3.0.orig/examples/wtc1.c libedit-20100424-3.0/exampl
|
||||
|
||||
/* Find the last word */
|
||||
for (ptr = lf->cursor -1; !iswspace(*ptr) && ptr > lf->buffer; --ptr)
|
||||
diff -durp libedit-20100424-3.0.orig/src/readline.c libedit-20100424-3.0/src/readline.c
|
||||
--- libedit-20100424-3.0.orig/src/readline.c 2010-04-24 12:32:18.000000000 -0600
|
||||
+++ libedit-20100424-3.0/src/readline.c 2011-02-07 13:14:13.210553427 -0700
|
||||
@@ -1273,8 +1273,8 @@ history_truncate_file (const char *filen
|
||||
diff -durp libedit-20110227-3.0.orig/src/readline.c libedit-20110227-3.0/src/readline.c
|
||||
--- libedit-20110227-3.0.orig/src/readline.c 2011-02-26 15:42:59.000000000 -0700
|
||||
+++ libedit-20110227-3.0/src/readline.c 2011-03-24 15:48:02.500808588 -0600
|
||||
@@ -1280,8 +1280,8 @@ history_truncate_file (const char *filen
|
||||
}
|
||||
}
|
||||
fflush(fp);
|
||||
@ -36,10 +36,10 @@ diff -durp libedit-20100424-3.0.orig/src/readline.c libedit-20100424-3.0/src/rea
|
||||
out3:
|
||||
fclose(tp);
|
||||
out2:
|
||||
diff -durp libedit-20100424-3.0.orig/src/vi.c libedit-20100424-3.0/src/vi.c
|
||||
--- libedit-20100424-3.0.orig/src/vi.c 2010-04-22 14:09:52.000000000 -0600
|
||||
+++ libedit-20100424-3.0/src/vi.c 2011-02-07 13:14:13.211553427 -0700
|
||||
@@ -1008,6 +1008,7 @@ vi_histedit(EditLine *el, Int c)
|
||||
diff -durp libedit-20110227-3.0.orig/src/vi.c libedit-20110227-3.0/src/vi.c
|
||||
--- libedit-20110227-3.0.orig/src/vi.c 2011-02-26 15:42:59.000000000 -0700
|
||||
+++ libedit-20110227-3.0/src/vi.c 2011-03-24 15:48:02.501808516 -0600
|
||||
@@ -1009,6 +1009,7 @@ vi_histedit(EditLine *el, Int c)
|
||||
char *cp;
|
||||
size_t len;
|
||||
Char *line;
|
||||
@ -47,7 +47,7 @@ diff -durp libedit-20100424-3.0.orig/src/vi.c libedit-20100424-3.0/src/vi.c
|
||||
|
||||
if (el->el_state.doingarg) {
|
||||
if (vi_to_history_line(el, 0) == CC_ERROR)
|
||||
@@ -1032,16 +1033,14 @@ vi_histedit(EditLine *el, Int c)
|
||||
@@ -1036,16 +1037,14 @@ vi_histedit(EditLine *el, Int c)
|
||||
ct_wcstombs(cp, line, TMP_BUFSIZ - 1);
|
||||
cp[TMP_BUFSIZ - 1] = '\0';
|
||||
len = strlen(cp);
|
||||
@ -69,7 +69,7 @@ diff -durp libedit-20100424-3.0.orig/src/vi.c libedit-20100424-3.0/src/vi.c
|
||||
case 0:
|
||||
close(fd);
|
||||
execlp("vi", "vi", tempfile, (char *)NULL);
|
||||
@@ -1063,15 +1062,17 @@ vi_histedit(EditLine *el, Int c)
|
||||
@@ -1067,15 +1066,17 @@ vi_histedit(EditLine *el, Int c)
|
||||
len = 0;
|
||||
el->el_line.cursor = el->el_line.buffer;
|
||||
el->el_line.lastchar = el->el_line.buffer + len;
|
||||
|
23
libedit.spec
23
libedit.spec
@ -1,4 +1,4 @@
|
||||
%define snap 20100424
|
||||
%define snap 20110227
|
||||
|
||||
Summary: The NetBSD Editline library
|
||||
Name: libedit
|
||||
@ -12,10 +12,6 @@ Source0: http://www.thrysoee.dk/editline/%{name}-%{snap}-%{version}.tar.gz
|
||||
# eliminate compile-time warnings
|
||||
Patch0: libedit-3.0-warnings.patch
|
||||
|
||||
# bz #575383
|
||||
Patch1: libedit-3.0-sigwinch.patch
|
||||
|
||||
BuildRequires: gawk
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
%description
|
||||
@ -37,17 +33,17 @@ This package contains development files for %{name}.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{snap}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# Suppress rpmlint error.
|
||||
iconv --from-code ISO8859-1 --to-code UTF-8 ./ChangeLog \
|
||||
--output ChangeLog.utf-8 && mv ChangeLog.utf-8 ./ChangeLog
|
||||
iconv -f ISO8859-1 -t UTF-8 -o ChangeLog.utf-8 ChangeLog
|
||||
touch -r ChangeLog ChangeLog.utf-8
|
||||
mv -f ChangeLog.utf-8 ChangeLog
|
||||
|
||||
%build
|
||||
%configure --disable-static --enable-widec
|
||||
|
||||
# Trying to omit unused direct shared library dependencies leads to
|
||||
# undefined non-weak symbols.
|
||||
# Fix unused direct shared library dependencies.
|
||||
sed -i "s/lcurses/ltinfo/" src/Makefile
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -82,6 +78,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/editline/readline.h
|
||||
|
||||
%changelog
|
||||
* Thu Mar 24 2011 Jerry James <loganjerry@gmail.com> - 3.0-3.20110227cvs
|
||||
- Update to 3.0 (20110227 snap)
|
||||
- Drop upstreamed -sigwinch patch
|
||||
- Preserve ChangeLog timestamp when converting to UTF-8
|
||||
- Fix "unused direct shared library dependency" warning from rpmlint
|
||||
- Don't BR gawk; it is on the exceptions list
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-3.20100424cvs
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user