Update to 20121213-3.0 (#912957)
This commit is contained in:
parent
f4b654def6
commit
5a2257359c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
libedit-20110227-3.0.tar.gz
|
||||
/libedit-20110802-3.0.tar.gz
|
||||
/libedit-20120601-3.0.tar.gz
|
||||
/libedit-20121213-3.0.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 73a91fafe8da0a1e8905280e8fa861a5d1d0e698 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Wed, 18 Jul 2012 14:11:55 +0200
|
||||
Subject: [PATCH] fix crash of el_insertstr() on incomplete multi-byte
|
||||
sequence
|
||||
|
||||
https://bugzilla.redhat.com/840598
|
||||
---
|
||||
src/chared.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/chared.c b/src/chared.c
|
||||
index f816d89..d3b0f22 100644
|
||||
--- a/src/chared.c
|
||||
+++ b/src/chared.c
|
||||
@@ -612,7 +612,7 @@ FUN(el,insertstr)(EditLine *el, const Char *s)
|
||||
{
|
||||
size_t len;
|
||||
|
||||
- if ((len = Strlen(s)) == 0)
|
||||
+ if (s == NULL || (len = Strlen(s)) == 0)
|
||||
return -1;
|
||||
if (el->el_line.lastchar + len >= el->el_line.limit) {
|
||||
if (!ch_enlargebufs(el, len))
|
||||
--
|
||||
1.7.10.4
|
||||
|
11
libedit.spec
11
libedit.spec
@ -1,17 +1,14 @@
|
||||
%global snap 20120601
|
||||
%global snap 20121213
|
||||
|
||||
Summary: The NetBSD Editline library
|
||||
Name: libedit
|
||||
Version: 3.0
|
||||
Release: 9.%{snap}cvs%{?dist}
|
||||
Release: 10.%{snap}cvs%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.thrysoee.dk/editline/
|
||||
Source0: http://www.thrysoee.dk/editline/%{name}-%{snap}-%{version}.tar.gz
|
||||
|
||||
# fix crash of el_insertstr() on incomplete multi-byte sequence (#840598)
|
||||
Patch0: libedit-20120601-3.0-insertstr-mb.patch
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
%description
|
||||
@ -32,7 +29,6 @@ This package contains development files for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{snap}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
# Suppress rpmlint error.
|
||||
iconv -f ISO8859-1 -t UTF-8 -o ChangeLog.utf-8 ChangeLog
|
||||
@ -71,6 +67,9 @@ find $RPM_BUILD_ROOT -type f -name "*.la" -delete
|
||||
%{_includedir}/editline/readline.h
|
||||
|
||||
%changelog
|
||||
* Wed Feb 20 2013 Kamil Dudka <kdudka@redhat.com> - 3.0-10.20121213cvs
|
||||
- Update to 20121213-3.0 (#912957)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-9.20120601cvs
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user