Update to 20140213-3.1
This commit is contained in:
parent
af557c4941
commit
4497e9dec6
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ libedit-20110227-3.0.tar.gz
|
||||
/libedit-20121213-3.0.tar.gz
|
||||
/libedit-20130601-3.1.tar.gz
|
||||
/libedit-20130712-3.1.tar.gz
|
||||
/libedit-20140213-3.1.tar.gz
|
||||
|
@ -1,56 +0,0 @@
|
||||
From b595cb4f3aa7b7378999445e8b9be0811bdb1ec9 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Tue, 21 Jan 2014 13:03:12 +0100
|
||||
Subject: [PATCH 1/2] [libedit] readline: avoid SIGSEGV in clear_history()
|
||||
|
||||
... if called prior to using_history(). This needed to be worked around
|
||||
in PHP: http://git.php.net/?p=php-src.git;a=commitdiff;h=31d67bd3
|
||||
|
||||
Bug: https://bugzilla.redhat.com/show_bug.cgi?id=1055409
|
||||
---
|
||||
src/readline.c | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/src/readline.c b/src/readline.c
|
||||
index 8cb43b9..a76a570 100644
|
||||
--- a/src/readline.c
|
||||
+++ b/src/readline.c
|
||||
@@ -1479,6 +1479,9 @@ clear_history(void)
|
||||
{
|
||||
HistEvent ev;
|
||||
|
||||
+ if (h == NULL || e == NULL)
|
||||
+ rl_initialize();
|
||||
+
|
||||
(void)history(h, &ev, H_CLEAR);
|
||||
history_length = 0;
|
||||
}
|
||||
--
|
||||
1.7.1
|
||||
|
||||
|
||||
From ffe1db33353b4a95d6018b77190dfb0c8e2e7cf3 Mon Sep 17 00:00:00 2001
|
||||
From: Ondrej Vasik <ovasik@redhat.com>
|
||||
Date: Wed, 24 Jul 2013 16:15:32 +0200
|
||||
Subject: [PATCH 2/2] [libedit] examples/fileman.c: fix minor typo in a comment
|
||||
|
||||
---
|
||||
examples/fileman.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/examples/fileman.c b/examples/fileman.c
|
||||
index 2d1a0d4..8cf89b3 100644
|
||||
--- a/examples/fileman.c
|
||||
+++ b/examples/fileman.c
|
||||
@@ -3,7 +3,7 @@
|
||||
to manipulate files and their modes.
|
||||
|
||||
NOTE: this was taken from the GNU Readline documentation and ported
|
||||
- to libedit. A commad to output the history list was added.
|
||||
+ to libedit. A command to output the history list was added.
|
||||
|
||||
*/
|
||||
|
||||
--
|
||||
1.7.1
|
||||
|
14
libedit.spec
14
libedit.spec
@ -1,17 +1,13 @@
|
||||
%global snap 20130712
|
||||
%global snap 20140213
|
||||
|
||||
Summary: The NetBSD Editline library
|
||||
Name: libedit
|
||||
Version: 3.1
|
||||
Release: 4.%{snap}cvs%{?dist}
|
||||
Release: 5.%{snap}cvs%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.thrysoee.dk/editline/
|
||||
Source0: http://www.thrysoee.dk/editline/%{name}-%{snap}-%{version}.tar.gz
|
||||
|
||||
# avoid SIGSEGV in clear_history() if called prior to using_history() (#1055409)
|
||||
Patch1: libedit-20130712-history.patch
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
%description
|
||||
@ -32,7 +28,6 @@ This package contains development files for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{snap}-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
# Suppress rpmlint error.
|
||||
iconv -f ISO8859-1 -t UTF-8 -o ChangeLog.utf-8 ChangeLog
|
||||
@ -71,8 +66,11 @@ find $RPM_BUILD_ROOT -type f -name "*.la" -delete
|
||||
%{_includedir}/editline/readline.h
|
||||
|
||||
%changelog
|
||||
* Wed Mar 19 2014 Kamil Dudka <kdudka@redhat.com> - 3.1-1.20140213cvs
|
||||
- Update to 20140213-3.1
|
||||
|
||||
* Tue Jan 21 2014 Kamil Dudka <kdudka@redhat.com> - 3.1-4.20130712cvs
|
||||
- avoid SIGSEGV in clear_history() if called prior to using_history() (#1055409)
|
||||
- Avoid SIGSEGV in clear_history() if called prior to using_history() (#1055409)
|
||||
|
||||
* Thu Jan 02 2014 Kamil Dudka <kdudka@redhat.com> - 3.1-3.20130712cvs
|
||||
- Update to 20130712-3.1 (#1045675)
|
||||
|
Loading…
Reference in New Issue
Block a user