libecpg/libecpg-12.2-dependency-build.patch
Filip Januš 208c877be2 Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1780209
Patch 	libecpg-10.5-external-libpq.patch was updated
Due to modified makefile was updated build section in spec

new upstream patch resolves missing buildrequires of ecpg
link to upstream discussion: https://www.postgresql.org/message-id/20200321221303.GA17979%40momjian.us
2020-03-23 09:56:20 +01:00

35 lines
1.1 KiB
Diff

Upstream patch
link: https://www.postgresql.org/message-id/20200321221303.GA17979%40momjian.us
diff --git a/src/interfaces/ecpg/pgtypeslib/Makefile b/src/interfaces/ecpg/pgtypeslib/Makefile
index 530b580d7c..ae79ead7a7 100644
--- a/src/interfaces/ecpg/pgtypeslib/Makefile
+++ b/src/interfaces/ecpg/pgtypeslib/Makefile
@@ -24,6 +24,7 @@ override CFLAGS += $(PTHREAD_CFLAGS)
SHLIB_LINK_INTERNAL = -lpgcommon_shlib -lpgport_shlib
SHLIB_LINK += $(filter -lintl -lm, $(LIBS))
+SHLIB_PREREQS = submake-libpgport
SHLIB_EXPORTS = exports.txt
diff --git a/src/interfaces/libpq/Makefile b/src/interfaces/libpq/Makefile
index a06882651f..d4919970f8 100644
--- a/src/interfaces/libpq/Makefile
+++ b/src/interfaces/libpq/Makefile
@@ -85,13 +85,12 @@ endif
ifeq ($(PORTNAME), win32)
SHLIB_LINK += -lshell32 -lws2_32 -lsecur32 $(filter -leay32 -lssleay32 -lcomerr32 -lkrb5_32, $(LIBS))
endif
+SHLIB_PREREQS = submake-libpgport
SHLIB_EXPORTS = exports.txt
all: all-lib
-all-lib: | submake-libpgport
-
# Shared library stuff
include $(top_srcdir)/src/Makefile.shlib
backend_src = $(top_srcdir)/src/backend