Rebase dependency build patch
This commit is contained in:
parent
6bb865fa2f
commit
f7b43619c4
@ -1,34 +1,13 @@
|
|||||||
Upstream patch
|
diff --git a/src/interfaces/libpq/Makefile b/src/interfaces/libpq/Makefile
|
||||||
link: https://www.postgresql.org/message-id/20200321221303.GA17979%40momjian.us
|
index 32a9fdfb7b..899de131da 100644
|
||||||
|
--- a/src/interfaces/libpq/Makefile
|
||||||
diff --git a/src/interfaces/ecpg/pgtypeslib/Makefile b/src/interfaces/ecpg/pgtypeslib/Makefile
|
+++ b/src/interfaces/libpq/Makefile
|
||||||
index 530b580d7c..ae79ead7a7 100644
|
@@ -76,8 +76,6 @@ SHLIB_PREREQS = submake-libpgport
|
||||||
--- a/src/interfaces/ecpg/pgtypeslib/Makefile
|
|
||||||
+++ b/src/interfaces/ecpg/pgtypeslib/Makefile
|
SHLIB_EXPORTS = exports.txt
|
||||||
@@ -24,6 +24,7 @@ override CFLAGS += $(PTHREAD_CFLAGS)
|
|
||||||
|
-all: all-lib
|
||||||
SHLIB_LINK_INTERNAL = -lpgcommon_shlib -lpgport_shlib
|
-
|
||||||
SHLIB_LINK += $(filter -lintl -lm, $(LIBS))
|
# Shared library stuff
|
||||||
+SHLIB_PREREQS = submake-libpgport
|
include $(top_srcdir)/src/Makefile.shlib
|
||||||
|
backend_src = $(top_srcdir)/src/backend
|
||||||
SHLIB_EXPORTS = exports.txt
|
|
||||||
|
|
||||||
diff --git a/src/interfaces/libpq/Makefile b/src/interfaces/libpq/Makefile
|
|
||||||
index a06882651f..d4919970f8 100644
|
|
||||||
--- a/src/interfaces/libpq/Makefile
|
|
||||||
+++ b/src/interfaces/libpq/Makefile
|
|
||||||
@@ -85,13 +85,12 @@ endif
|
|
||||||
ifeq ($(PORTNAME), win32)
|
|
||||||
SHLIB_LINK += -lshell32 -lws2_32 -lsecur32 $(filter -leay32 -lssleay32 -lcomerr32 -lkrb5_32, $(LIBS))
|
|
||||||
endif
|
|
||||||
+SHLIB_PREREQS = submake-libpgport
|
|
||||||
|
|
||||||
SHLIB_EXPORTS = exports.txt
|
|
||||||
|
|
||||||
all: all-lib
|
|
||||||
|
|
||||||
-all-lib: | submake-libpgport
|
|
||||||
-
|
|
||||||
# Shared library stuff
|
|
||||||
include $(top_srcdir)/src/Makefile.shlib
|
|
||||||
backend_src = $(top_srcdir)/src/backend
|
|
||||||
|
Loading…
Reference in New Issue
Block a user