Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/libecpg.git#1bf1e3f0574b025b79b021ef0639fa8c70185af7
This commit is contained in:
parent
0e04f8fc5e
commit
ea74020a5b
1
.fmf/version
Normal file
1
.fmf/version
Normal file
@ -0,0 +1 @@
|
||||
1
|
11
ci.fmf
Normal file
11
ci.fmf
Normal file
@ -0,0 +1,11 @@
|
||||
summary: Tier tests
|
||||
discover:
|
||||
how: fmf
|
||||
# using temporary location before the test is merged
|
||||
#repository: git://pkgs.devel.redhat.com/tests/micropipenv
|
||||
#ref: master
|
||||
repository: https://src.fedoraproject.org/forks/hhorak/tests/postgresql.git
|
||||
ref: add-libecpg
|
||||
filter: 'tag:libecpg'
|
||||
execute:
|
||||
how: tmt
|
@ -12,42 +12,15 @@ server package update, without requiring any existing postgresql.conf
|
||||
to be updated. (Of course, a user who dislikes this behavior can still
|
||||
override it via postgresql.conf.)
|
||||
|
||||
diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c
|
||||
index 9481f2d..75532c7 100644
|
||||
--- a/src/backend/utils/misc/guc.c
|
||||
+++ b/src/backend/utils/misc/guc.c
|
||||
@@ -3196,7 +3196,7 @@ static struct config_string ConfigureNamesString[] =
|
||||
},
|
||||
&Unix_socket_directories,
|
||||
#ifdef HAVE_UNIX_SOCKETS
|
||||
- DEFAULT_PGSOCKET_DIR,
|
||||
+ DEFAULT_PGSOCKET_DIR ", /tmp",
|
||||
#else
|
||||
"",
|
||||
#endif
|
||||
diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
|
||||
index feeff9e..3e3d784 100644
|
||||
--- a/src/bin/initdb/initdb.c
|
||||
+++ b/src/bin/initdb/initdb.c
|
||||
@@ -1234,7 +1234,7 @@ setup_config(void)
|
||||
|
||||
#ifdef HAVE_UNIX_SOCKETS
|
||||
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'",
|
||||
- DEFAULT_PGSOCKET_DIR);
|
||||
+ DEFAULT_PGSOCKET_DIR ", /tmp");
|
||||
#else
|
||||
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''");
|
||||
#endif
|
||||
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
|
||||
index e278fa0..9ee15d4 100644
|
||||
--- a/src/include/pg_config_manual.h
|
||||
+++ b/src/include/pg_config_manual.h
|
||||
@@ -169,7 +169,7 @@
|
||||
* here's where to twiddle it. You can also override this at runtime
|
||||
* with the postmaster's -k switch.
|
||||
diff -up postgresql-13.0/src/include/pg_config_manual.h.patch1 postgresql-13.0/src/include/pg_config_manual.h
|
||||
--- postgresql-13.0/src/include/pg_config_manual.h.patch1 2020-10-23 10:18:12.204959024 +0200
|
||||
+++ postgresql-13.0/src/include/pg_config_manual.h 2020-10-23 10:18:39.391208931 +0200
|
||||
@@ -201,7 +201,7 @@
|
||||
* support them yet.
|
||||
*/
|
||||
#ifndef WIN32
|
||||
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||
|
||||
/*
|
||||
* This is the default event source for Windows event log.
|
||||
#else
|
||||
#define DEFAULT_PGSOCKET_DIR ""
|
||||
#endif
|
||||
|
18
libecpg.spec
18
libecpg.spec
@ -1,9 +1,9 @@
|
||||
%global majorversion 12
|
||||
%global majorversion 13
|
||||
|
||||
Summary: ECPG - Embedded SQL in C
|
||||
Name: libecpg
|
||||
Version: %majorversion.4
|
||||
Release: 1%{?dist}
|
||||
Version: %majorversion.1
|
||||
Release: 3%{?dist}
|
||||
|
||||
License: PostgreSQL
|
||||
Url: http://www.postgresql.org/
|
||||
@ -29,6 +29,8 @@ BuildRequires: libpq-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: multilib-rpm-config
|
||||
|
||||
Requires: libpgtypes = %{version}-%{release}
|
||||
|
||||
%description
|
||||
An embedded SQL program consists of code written in an ordinary programming
|
||||
language, in this case C, mixed with SQL commands in specially marked sections.
|
||||
@ -127,6 +129,16 @@ find_lang_bins %name-devel.lst ecpg
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 03 2020 Honza Horak <hhorak@redhat.com> - 13.1-3
|
||||
- Add Requires: libpgtypes to avoid the need to test interoperability
|
||||
between the various combinations of old and new subpackages
|
||||
|
||||
* Wed Nov 18 2020 Honza Horak <hhorak@redhat.com> - 13.1-1
|
||||
- Rebase to upstream release 13.0
|
||||
|
||||
* Fri Oct 23 2020 Honza Horak <hhorak@redhat.com> - 13.0-1
|
||||
- Rebase to upstream release 13.0
|
||||
|
||||
* Tue Aug 25 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1
|
||||
- Rebase to upstream release 12.4
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (postgresql-12.4.tar.bz2) = 36daf10878ca153370829178786dd6ee366ab4d4d6dc9c527536740fdb14b688ae4c33f850eb4243a7667d23f87e4bfd1ddee0755447ad4f3996e423e391c2f3
|
||||
SHA512 (postgresql-12.4.tar.bz2.sha256) = d5c6d9c6cf189f0ef9c4ebac18782f25c0ff8420d0b063217f4ac250cca4706ec782e983326ffcb23258bcd5bf17b481e53d84aeb85b5744bfd90ea1bd33431a
|
||||
SHA512 (postgresql-13.1.tar.bz2) = b7bd378db1dcb74ebcd5fffba03b82d8117d182029e4caca48eef62d8bcdbeef2c2e10f18eef0cdafb9d7acf21aa164d040e56687709f97b08c51540a786eeca
|
||||
SHA512 (postgresql-13.1.tar.bz2.sha256) = 58f2ad590b5946bdb3f8bc512318c60a48916ebac7df854b6b737daa609b4fd78c71fe9bf04a4103885527ed498bb46bf68ce8e656b357f9ae43b556bd48df41
|
||||
|
Loading…
Reference in New Issue
Block a user