rebase: latest release 11.0
Per release notes: https://www.postgresql.org/docs/11/static/release-11-0.html Version: 11.0-1
This commit is contained in:
parent
4f5a423f92
commit
a437480288
12
generate-sources.sh
Executable file
12
generate-sources.sh
Executable file
@ -0,0 +1,12 @@
|
||||
#! /bin/sh
|
||||
|
||||
rm sources
|
||||
set -e
|
||||
spectool -S *.spec | cut -d' ' -f2 \
|
||||
| grep -E -e 'postgresql-.*\.tar\.*' -e 'postgresql.*\.pdf' | sort | \
|
||||
while read line
|
||||
do
|
||||
base=`basename "$line"`
|
||||
echo " * handling $base"
|
||||
sha512sum --tag "$base" >> sources
|
||||
done
|
@ -6,7 +6,7 @@ in sync!
|
||||
Related: rhbz#1618698
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index febbced..9737b55 100644
|
||||
index bcdbd95..4bea236 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||
@ -18,10 +18,10 @@ index febbced..9737b55 100644
|
||||
backend/replication/pgoutput \
|
||||
fe_utils \
|
||||
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||
index 4ed5174..d0e0dae 100644
|
||||
index 9a4a8a3..2bdfb77 100644
|
||||
--- a/src/Makefile.global.in
|
||||
+++ b/src/Makefile.global.in
|
||||
@@ -457,7 +457,7 @@ endif
|
||||
@@ -513,7 +513,7 @@ endif
|
||||
|
||||
# This macro is for use by libraries linking to libpq. (Because libpgport
|
||||
# isn't created with the same link flags as libpq, it can't be used.)
|
||||
@ -30,11 +30,11 @@ index 4ed5174..d0e0dae 100644
|
||||
|
||||
# This macro is for use by client executables (not libraries) that use libpq.
|
||||
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||
@@ -483,7 +483,6 @@ endif
|
||||
@@ -539,7 +539,6 @@ endif
|
||||
# Commonly used submake targets
|
||||
|
||||
submake-libpq:
|
||||
submake-libpq: | submake-generated-headers
|
||||
- $(MAKE) -C $(libpq_builddir) all
|
||||
|
||||
submake-libpgport:
|
||||
submake-libpgport: | submake-generated-headers
|
||||
$(MAKE) -C $(top_builddir)/src/port all
|
||||
|
12
libecpg.spec
12
libecpg.spec
@ -1,8 +1,8 @@
|
||||
%global majorversion 10
|
||||
%global majorversion 11
|
||||
|
||||
Summary: ECPG - Embedded SQL in C
|
||||
Name: libecpg
|
||||
Version: %majorversion.5
|
||||
Version: %majorversion.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: PostgreSQL
|
||||
@ -75,10 +75,6 @@ find . -type f -name .gitignore | xargs rm
|
||||
--without-readline \
|
||||
--datadir=%_datadir/pgsql
|
||||
|
||||
# TODO: can those be built automatically?
|
||||
make -C "src/backend" ../../src/include/utils/fmgroids.h
|
||||
make -C "src/backend" ../../src/include/utils/fmgrprotos.h
|
||||
|
||||
%make_build -C "src/interfaces/ecpg"
|
||||
|
||||
|
||||
@ -130,6 +126,10 @@ find_lang_bins %name-devel.lst ecpg
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 17 2018 Pavel Raiskup <praiskup@redhat.com> - 11.0-1
|
||||
- latest upstream release, per release notes:
|
||||
https://www.postgresql.org/docs/11/static/release-11-0.html
|
||||
|
||||
* Thu Aug 30 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-1
|
||||
- slight simplification before review
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (postgresql-10.5.tar.bz2) = 1bad30ae88beca66f7e8b99b82e7f02aac1e9230b328e6e5a762a704cdd9dc767d924f5a66c68c93586badfef91b7ff336120a567ce970eaa58bb44c662ad48c
|
||||
SHA512 (postgresql-10.5.tar.bz2.sha256) = f4b2bf3c6454905caf4bd5a9a53dec33e7ac6c7593e6464bf75bcd12b185bc1c54f925a088122d8819840a17bbda84e8b42c311a639d7457090ace74725971f9
|
||||
SHA512 (postgresql-11.0.tar.bz2) = 2cf471618dfaabdcbcbd68be3b85b6083376c97fdadce36d2ceb28438b7c736816118eacb1d4f12d48c39f584d78d7ffa89fa6d65858d440045a53921429970a
|
||||
SHA512 (postgresql-11.0.tar.bz2.sha256) = e1fb5c4ed7f584a813ac4f81d056dc3b0e3568c64c243b18cc57715d6bfefbcd159f442c8f2671278bf633751acb9251bd2e24cf97ce8044fae63a6c4592ef1e
|
||||
|
Loading…
Reference in New Issue
Block a user