Merge branch 'f18' into f19

Conflicts:
	libdvdnav.spec
This commit is contained in:
Dominik Mierzejewski 2013-09-10 00:26:26 +02:00
commit 3e448e0fc5
2 changed files with 19 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff --git a/src/searching.c b/src/searching.c
index 66f7adb..31bf0d3 100644
--- a/src/searching.c
+++ b/src/searching.c
@@ -628,6 +628,7 @@ uint32_t dvdnav_describe_title_chapters(dvdnav_t *this, int32_t title, uint64_t
else
endcellnr = 0;
+ if (!pgc->cell_playback) continue;
do {
cell = &pgc->cell_playback[cellnr-1];
if(!(cell->block_type == BLOCK_TYPE_ANGLE_BLOCK &&

View File

@ -1,12 +1,14 @@
Name: libdvdnav Name: libdvdnav
Version: 4.2.0 Version: 4.2.0
Release: 4%{?dist} Release: 5%{?dist}
Summary: A library for reading DVD video discs based on Ogle code Summary: A library for reading DVD video discs based on Ogle code
Group: System Environment/Libraries Group: System Environment/Libraries
License: GPLv2+ License: GPLv2+
Source0: http://dvdnav.mplayerhq.hu/releases/libdvdnav-%{version}.tar.bz2 Source0: http://dvdnav.mplayerhq.hu/releases/libdvdnav-%{version}.tar.bz2
Patch0: %{name}-multilib.patch Patch0: %{name}-multilib.patch
# fix segfault when cell is empty, patch by Simo Sorce, bug #902037
Patch1: %{name}-pgc-cell_playback.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: doxygen BuildRequires: doxygen
@ -30,6 +32,7 @@ libdvdnav library.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .multilib %patch0 -p1 -b .multilib
%patch1 -p1 -b .pgc-cell_playback
%build %build
./configure2 \ ./configure2 \
@ -78,6 +81,9 @@ popd
%{_libdir}/pkgconfig/dvdnavmini.pc %{_libdir}/pkgconfig/dvdnavmini.pc
%changelog %changelog
* Tue Sep 10 2013 Dominik Mierzejewski <rpm[AT]greysector.net> 4.2.0-5
- fix segfault when cell is empty, patch by Simo Sorce, bug #902037
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4 * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild