Merge branch 'f18' into f19
Conflicts: libdvdnav.spec
This commit is contained in:
commit
3e448e0fc5
12
libdvdnav-pgc-cell_playback.patch
Normal file
12
libdvdnav-pgc-cell_playback.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/src/searching.c b/src/searching.c
|
||||
index 66f7adb..31bf0d3 100644
|
||||
--- a/src/searching.c
|
||||
+++ b/src/searching.c
|
||||
@@ -628,6 +628,7 @@ uint32_t dvdnav_describe_title_chapters(dvdnav_t *this, int32_t title, uint64_t
|
||||
else
|
||||
endcellnr = 0;
|
||||
|
||||
+ if (!pgc->cell_playback) continue;
|
||||
do {
|
||||
cell = &pgc->cell_playback[cellnr-1];
|
||||
if(!(cell->block_type == BLOCK_TYPE_ANGLE_BLOCK &&
|
@ -1,12 +1,14 @@
|
||||
Name: libdvdnav
|
||||
Version: 4.2.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: A library for reading DVD video discs based on Ogle code
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: GPLv2+
|
||||
Source0: http://dvdnav.mplayerhq.hu/releases/libdvdnav-%{version}.tar.bz2
|
||||
Patch0: %{name}-multilib.patch
|
||||
# fix segfault when cell is empty, patch by Simo Sorce, bug #902037
|
||||
Patch1: %{name}-pgc-cell_playback.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: doxygen
|
||||
@ -30,6 +32,7 @@ libdvdnav library.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .multilib
|
||||
%patch1 -p1 -b .pgc-cell_playback
|
||||
|
||||
%build
|
||||
./configure2 \
|
||||
@ -78,6 +81,9 @@ popd
|
||||
%{_libdir}/pkgconfig/dvdnavmini.pc
|
||||
|
||||
%changelog
|
||||
* Tue Sep 10 2013 Dominik Mierzejewski <rpm[AT]greysector.net> 4.2.0-5
|
||||
- fix segfault when cell is empty, patch by Simo Sorce, bug #902037
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user