libdrm/0001-configure-Explicitly-check-for-pkg-config-at-the-top.patch
2017-03-23 12:35:42 -04:00

35 lines
984 B
Diff

From b983b054d4f1a6be67105e90f0ae2064f91a762c Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Thu, 23 Mar 2017 12:07:03 -0400
Subject: [PATCH] configure: Explicitly check for pkg-config at the top level
If you don't, then the first place the m4 expands is:
if test "x$INTEL" != "xno"; then
PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
fi
So on non-Intel architectures we never find it in the path, and all
subsequent PKG_CHECK_MODULESes fail. Boo autoconf.
Signed-off-by: Adam Jackson <ajax@redhat.com>
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index 8e593324..2e50d3ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,7 @@ AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
+PKG_PROG_PKG_CONFIG
# Require xorg-macros minimum of 1.12 for XORG_WITH_XSLTPROC
m4_ifndef([XORG_MACROS_VERSION],
--
2.12.0