- Update nouveau patch.

This commit is contained in:
Kristian Høgsberg 2007-03-30 18:57:37 +00:00
parent 63ffb8c824
commit e0646030de
2 changed files with 24 additions and 22 deletions

View File

@ -1,7 +1,7 @@
Summary: Direct Rendering Manager runtime library
Name: libdrm
Version: 2.3.0
Release: 4%{?dist}
Release: 5%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://dri.sourceforge.net
@ -77,6 +77,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pkgconfig/libdrm.pc
%changelog
* Fri Mar 30 2007 Kristian Høgsberg <krh@redhat.com> - 2.3.0-5
- Update nouveau patch.
* Tue Feb 19 2007 Adam Jackson <ajax@redhat.com> 2.3.0-4
- Update nouveau patch
- Fix License tag and other rpmlint noise

View File

@ -1,6 +1,6 @@
--- /dev/null 2006-10-24 10:09:24.521518763 -0400
+++ libdrm-2.3.0/shared-core/nouveau_drm.h 2007-02-13 18:10:33.000000000 -0500
@@ -0,0 +1,153 @@
--- /dev/null 2007-03-29 16:01:53.376400525 -0400
+++ libdrm-2.3.0/shared-core/nouveau_drm.h 2007-03-29 19:02:49.000000000 -0400
@@ -0,0 +1,152 @@
+/*
+ * Copyright 2005 Stephane Marchesin.
+ * All Rights Reserved.
@ -28,6 +28,8 @@
+#ifndef __NOUVEAU_DRM_H__
+#define __NOUVEAU_DRM_H__
+
+#define NOUVEAU_DRM_HEADER_PATCHLEVEL 6
+
+typedef struct drm_nouveau_fifo_alloc {
+ int channel;
+ uint32_t put_base;
@ -40,24 +42,20 @@
+}
+drm_nouveau_fifo_alloc_t;
+
+#define NV_DMA_CONTEXT_FLAGS_PATCH_ROP_AND 0x1
+#define NV_DMA_CONTEXT_FLAGS_PATCH_SRCCOPY 0x2
+#define NV_DMA_CONTEXT_FLAGS_CLIP_ENABLE 0x4
+#define NV_DMA_CONTEXT_FLAGS_MONO 0x8
+
+typedef struct drm_nouveau_object_init {
+ int channel;
+ uint32_t handle;
+ int class;
+ uint32_t flags;
+ /* these are object handles */
+ uint32_t dma0;
+ uint32_t dma1;
+ uint32_t dma_notifier;
+ int class;
+}
+drm_nouveau_object_init_t;
+
+#define NOUVEAU_MEM_ACCESS_RO 1
+#define NOUVEAU_MEM_ACCESS_WO 2
+#define NOUVEAU_MEM_ACCESS_RW 3
+typedef struct drm_nouveau_dma_object_init {
+ int channel;
+ uint32_t handle;
+ int class;
+ int access;
+ int target;
+ uint32_t offset;
@ -83,8 +81,8 @@
+drm_nouveau_mem_alloc_t;
+
+typedef struct drm_nouveau_mem_free {
+ int flags;
+ uint64_t region_offset;
+ int flags;
+}
+drm_nouveau_mem_free_t;
+
@ -94,9 +92,10 @@
+#define NOUVEAU_GETPARAM_BUS_TYPE 5
+#define NOUVEAU_GETPARAM_FB_PHYSICAL 6
+#define NOUVEAU_GETPARAM_AGP_PHYSICAL 7
+#define NOUVEAU_GETPARAM_FB_SIZE 8
+#define NOUVEAU_GETPARAM_AGP_SIZE 9
+typedef struct drm_nouveau_getparam {
+ unsigned int param;
+ unsigned int dummy;
+ uint64_t param;
+ uint64_t value;
+}
+drm_nouveau_getparam_t;
@ -104,8 +103,8 @@
+#define NOUVEAU_SETPARAM_CMDBUF_LOCATION 1
+#define NOUVEAU_SETPARAM_CMDBUF_SIZE 2
+typedef struct drm_nouveau_setparam {
+ unsigned int param;
+ unsigned int value;
+ uint64_t param;
+ uint64_t value;
+}
+drm_nouveau_setparam_t;
+
@ -146,7 +145,7 @@
+
+#define DRM_NOUVEAU_FIFO_ALLOC 0x00
+#define DRM_NOUVEAU_OBJECT_INIT 0x01
+#define DRM_NOUVEAU_DMA_OBJECT_INIT 0x02 // We don't want this eventually..
+#define DRM_NOUVEAU_DMA_OBJECT_INIT 0x02
+#define DRM_NOUVEAU_MEM_ALLOC 0x03
+#define DRM_NOUVEAU_MEM_FREE 0x04
+#define DRM_NOUVEAU_GETPARAM 0x05
@ -155,7 +154,7 @@
+#endif /* __NOUVEAU_DRM_H__ */
+
--- libdrm-2.3.0/shared-core/Makefile.am.nouveau 2006-11-07 23:03:26.000000000 -0500
+++ libdrm-2.3.0/shared-core/Makefile.am 2007-02-13 18:10:11.000000000 -0500
+++ libdrm-2.3.0/shared-core/Makefile.am 2007-03-29 19:00:35.000000000 -0400
@@ -27,6 +27,7 @@
drm.h \
drm_sarea.h \