Update to 2.4.91
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
054d488fb5
commit
bce4f43f08
@ -1,39 +0,0 @@
|
|||||||
From 1fc0d158b55d3e833c0d819e48494b7013a44ebe Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andrey Grodzovsky <andrey.grodzovsky@amd.com>
|
|
||||||
Date: Mon, 19 Feb 2018 02:18:36 -0500
|
|
||||||
Subject: [PATCH 1/2] amdgpu: Fix mistake in initial hole size calculation.
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Signed-off-by: Andrey Grodzovsky <andrey.grodzovsky@amd.com>
|
|
||||||
Acked-by: Christian König <christian.koenig@amd.com>
|
|
||||||
(cherry picked from commit 33a2851ab9bc3cd8a68bedf4cf0fdc549b0f3596)
|
|
||||||
---
|
|
||||||
amdgpu/amdgpu_vamgr.c | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/amdgpu/amdgpu_vamgr.c b/amdgpu/amdgpu_vamgr.c
|
|
||||||
index 722067f3..58400428 100644
|
|
||||||
--- a/amdgpu/amdgpu_vamgr.c
|
|
||||||
+++ b/amdgpu/amdgpu_vamgr.c
|
|
||||||
@@ -57,7 +57,7 @@ drm_private void amdgpu_vamgr_init(struct amdgpu_bo_va_mgr *mgr, uint64_t start,
|
|
||||||
pthread_mutex_init(&mgr->bo_va_mutex, NULL);
|
|
||||||
pthread_mutex_lock(&mgr->bo_va_mutex);
|
|
||||||
n = calloc(1, sizeof(struct amdgpu_bo_va_hole));
|
|
||||||
- n->size = mgr->va_max;
|
|
||||||
+ n->size = mgr->va_max - start;
|
|
||||||
n->offset = start;
|
|
||||||
list_add(&n->list, &mgr->va_holes);
|
|
||||||
pthread_mutex_unlock(&mgr->bo_va_mutex);
|
|
||||||
@@ -80,6 +80,7 @@ amdgpu_vamgr_find_va(struct amdgpu_bo_va_mgr *mgr, uint64_t size,
|
|
||||||
struct amdgpu_bo_va_hole *hole, *n;
|
|
||||||
uint64_t offset = 0, waste = 0;
|
|
||||||
|
|
||||||
+
|
|
||||||
alignment = MAX2(alignment, mgr->va_alignment);
|
|
||||||
size = ALIGN(size, mgr->va_alignment);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.16.2
|
|
||||||
|
|
@ -1,74 +0,0 @@
|
|||||||
From 8ba6cd71db51c245ca4bf4648a61c74a4e06741e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <ignatenko@redhat.com>
|
|
||||||
Date: Mon, 19 Feb 2018 13:55:27 +0100
|
|
||||||
Subject: [PATCH 2/2] meson: do not use cairo/valgrind if disabled
|
|
||||||
|
|
||||||
-Dcairo-tests=false currently results into enabling cairo support if it
|
|
||||||
was found. Same for valgrind.
|
|
||||||
|
|
||||||
v2:
|
|
||||||
* Use underscore-prefixed variables to not change type of variable
|
|
||||||
* Use empty array for "fake" dependency instead of real empty object
|
|
||||||
|
|
||||||
v3:
|
|
||||||
* Fix typo
|
|
||||||
|
|
||||||
Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
|
|
||||||
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
|
|
||||||
(cherry picked from commit 9411f8ea03a4c019a0069845545cae45136596fc)
|
|
||||||
---
|
|
||||||
meson.build | 24 ++++++++++++++++++------
|
|
||||||
1 file changed, 18 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 4aaeb7e1..fbde0546 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -32,8 +32,6 @@ pkg = import('pkgconfig')
|
|
||||||
with_udev = get_option('udev')
|
|
||||||
with_freedreno_kgsl = get_option('freedreno-kgsl')
|
|
||||||
with_install_tests = get_option('install-test-programs')
|
|
||||||
-with_cairo_tests = get_option('cairo-tests')
|
|
||||||
-with_valgrind = get_option('valgrind')
|
|
||||||
|
|
||||||
config = configuration_data()
|
|
||||||
|
|
||||||
@@ -226,8 +224,22 @@ endforeach
|
|
||||||
|
|
||||||
dep_pciaccess = dependency('pciaccess', version : '>= 0.10', required : with_intel)
|
|
||||||
dep_cunit = dependency('cunit', version : '>= 2.1', required : false)
|
|
||||||
-dep_cairo = dependency('cairo', required : with_cairo_tests == 'true')
|
|
||||||
-dep_valgrind = dependency('valgrind', required : with_valgrind == 'true')
|
|
||||||
+_cairo_tests = get_option('cairo-tests')
|
|
||||||
+if _cairo_tests != 'false'
|
|
||||||
+ dep_cairo = dependency('cairo', required : _cairo_tests == 'true')
|
|
||||||
+ with_cairo_tests = dep_cairo.found()
|
|
||||||
+else
|
|
||||||
+ dep_cairo = []
|
|
||||||
+ with_cairo_tests = false
|
|
||||||
+endif
|
|
||||||
+_valgrind = get_option('valgrind')
|
|
||||||
+if _valgrind != 'false'
|
|
||||||
+ dep_valgrind = dependency('valgrind', required : _valgrind == 'true')
|
|
||||||
+ with_valgrind = dep_valgrind.found()
|
|
||||||
+else
|
|
||||||
+ dep_valgrind = []
|
|
||||||
+ with_valgrind = false
|
|
||||||
+endif
|
|
||||||
|
|
||||||
with_man_pages = get_option('man-pages')
|
|
||||||
prog_xslt = find_program('xsltproc', required : with_man_pages == 'true')
|
|
||||||
@@ -259,8 +271,8 @@ foreach t : [
|
|
||||||
[with_radeon, 'RADEON'],
|
|
||||||
[with_vc4, 'VC4'],
|
|
||||||
[with_vmwgfx, 'VMWGFX'],
|
|
||||||
- [dep_cairo.found(), 'CAIRO'],
|
|
||||||
- [dep_valgrind.found(), 'VALGRIND'],
|
|
||||||
+ [with_cairo_tests, 'CAIRO'],
|
|
||||||
+ [with_valgrind, 'VALGRIND'],
|
|
||||||
]
|
|
||||||
config.set10('HAVE_@0@'.format(t[1]), t[0])
|
|
||||||
endforeach
|
|
||||||
--
|
|
||||||
2.16.2
|
|
||||||
|
|
@ -1,10 +0,0 @@
|
|||||||
diff -up libdrm-2.4.75/tests/Makefile.am.dma libdrm-2.4.75/tests/Makefile.am
|
|
||||||
--- libdrm-2.4.75/tests/Makefile.am.dma 2017-01-28 12:47:46.279069827 +1000
|
|
||||||
+++ libdrm-2.4.75/tests/Makefile.am 2017-01-28 12:47:58.589394764 +1000
|
|
||||||
@@ -45,3 +45,6 @@ TESTS = \
|
|
||||||
check_PROGRAMS = \
|
|
||||||
$(TESTS) \
|
|
||||||
drmdevice
|
|
||||||
+
|
|
||||||
+check-programs:
|
|
||||||
+ @echo $(check_PROGRAMS)
|
|
17
libdrm.spec
17
libdrm.spec
@ -47,18 +47,14 @@ end}
|
|||||||
|
|
||||||
Name: libdrm
|
Name: libdrm
|
||||||
Summary: Direct Rendering Manager runtime library
|
Summary: Direct Rendering Manager runtime library
|
||||||
Version: 2.4.90
|
Version: 2.4.91
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
|
|
||||||
URL: https://dri.freedesktop.org
|
URL: https://dri.freedesktop.org
|
||||||
Source0: %{url}/libdrm/%{name}-%{version}.tar.bz2
|
Source0: %{url}/libdrm/%{name}-%{version}.tar.bz2
|
||||||
Source2: 91-drm-modeset.rules
|
Source2: 91-drm-modeset.rules
|
||||||
|
|
||||||
# Backports from upstream
|
|
||||||
Patch0001: 0001-amdgpu-Fix-mistake-in-initial-hole-size-calculation.patch
|
|
||||||
Patch0002: 0002-meson-do-not-use-cairo-valgrind-if-disabled.patch
|
|
||||||
|
|
||||||
BuildRequires: meson >= 0.43
|
BuildRequires: meson >= 0.43
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libatomic_ops-devel
|
BuildRequires: libatomic_ops-devel
|
||||||
@ -83,11 +79,9 @@ BuildRequires: pkgconfig(udev)
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# hardcode the 666 instead of 660 for device nodes
|
# hardcode the 666 instead of 660 for device nodes
|
||||||
Patch3: libdrm-make-dri-perms-okay.patch
|
Patch1001: libdrm-make-dri-perms-okay.patch
|
||||||
# remove backwards compat not needed on Fedora
|
# remove backwards compat not needed on Fedora
|
||||||
Patch4: libdrm-2.4.0-no-bc.patch
|
Patch1002: libdrm-2.4.0-no-bc.patch
|
||||||
# make rule to print the list of test programs
|
|
||||||
Patch5: libdrm-2.4.25-check-programs.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Direct Rendering Manager runtime library
|
Direct Rendering Manager runtime library
|
||||||
@ -287,6 +281,9 @@ install -Dpm0644 -t %{buildroot}%{_udevrulesdir} %{S:2}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.4.91-1
|
||||||
|
- Update to 2.4.91
|
||||||
|
|
||||||
* Thu Mar 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.4.90-2
|
* Thu Mar 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.4.90-2
|
||||||
- Backport fix for broken amdgpu
|
- Backport fix for broken amdgpu
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libdrm-2.4.90.tar.bz2) = 3d32d60c44ffdcb58667d0926e6af8d375332add1f243d8b2d37567aeef4e4b26d786294aeecf46c3dea94fc002fb73756567c457300703acfc21e32ffbd458c
|
SHA512 (libdrm-2.4.91.tar.bz2) = 07578c00c121ba37033db7172590e26d1545f81c242bbce2cfb7fb904bde504822c275d6468e5c5d20360d0046ae73d9b058aa0459ba35eb11927141cc998772
|
||||||
|
Loading…
Reference in New Issue
Block a user