libdrm 2.4.32
- libdrm-2.4.32-tn-surface.patch: Sync with git.
This commit is contained in:
parent
4aa425269c
commit
bc7c0e9e56
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ libdrm-20100612.tar.bz2
|
||||
/libdrm-2.4.27.tar.bz2
|
||||
/libdrm-2.4.30.tar.bz2
|
||||
/libdrm-2.4.31.tar.bz2
|
||||
/libdrm-2.4.32.tar.bz2
|
||||
|
37
libdrm-2.4.32-tn-surface.patch
Normal file
37
libdrm-2.4.32-tn-surface.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From c50cc24690938db53cd91ae9ff2fa0958693f80d Mon Sep 17 00:00:00 2001
|
||||
From: Alex Deucher <alexander.deucher@amd.com>
|
||||
Date: Tue, 14 Feb 2012 16:32:17 +0000
|
||||
Subject: radeon: add TN surface support
|
||||
|
||||
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
|
||||
---
|
||||
diff --git a/radeon/r600_pci_ids.h b/radeon/r600_pci_ids.h
|
||||
index 0ffb741..8fbd749 100644
|
||||
--- a/radeon/r600_pci_ids.h
|
||||
+++ b/radeon/r600_pci_ids.h
|
||||
@@ -269,3 +269,11 @@ CHIPSET(0x6768, CAICOS_6768, CAICOS)
|
||||
CHIPSET(0x6770, CAICOS_6770, CAICOS)
|
||||
CHIPSET(0x6778, CAICOS_6778, CAICOS)
|
||||
CHIPSET(0x6779, CAICOS_6779, CAICOS)
|
||||
+
|
||||
+CHIPSET(0x9900, ARUBA_9900, ARUBA)
|
||||
+CHIPSET(0x9901, ARUBA_9901, ARUBA)
|
||||
+CHIPSET(0x9903, ARUBA_9903, ARUBA)
|
||||
+CHIPSET(0x9904, ARUBA_9904, ARUBA)
|
||||
+CHIPSET(0x990F, ARUBA_990F, ARUBA)
|
||||
+CHIPSET(0x9990, ARUBA_9990, ARUBA)
|
||||
+CHIPSET(0x9991, ARUBA_9991, ARUBA)
|
||||
diff --git a/radeon/radeon_surface.c b/radeon/radeon_surface.c
|
||||
index 94224f5..6303c47 100644
|
||||
--- a/radeon/radeon_surface.c
|
||||
+++ b/radeon/radeon_surface.c
|
||||
@@ -68,6 +68,7 @@ enum radeon_family {
|
||||
CHIP_TURKS,
|
||||
CHIP_CAICOS,
|
||||
CHIP_CAYMAN,
|
||||
+ CHIP_ARUBA,
|
||||
CHIP_LAST,
|
||||
};
|
||||
|
||||
--
|
||||
cgit v0.9.0.2-2-gbebe
|
12
libdrm.spec
12
libdrm.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Direct Rendering Manager runtime library
|
||||
Name: libdrm
|
||||
Version: 2.4.31
|
||||
Release: 4%{?dist}
|
||||
Version: 2.4.32
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://dri.sourceforge.net
|
||||
@ -23,6 +23,8 @@ BuildRequires: libpciaccess-devel
|
||||
|
||||
Source2: 91-drm-modeset.rules
|
||||
|
||||
# sync with git
|
||||
Patch0: libdrm-2.4.32-tn-surface.patch
|
||||
# hardcode the 666 instead of 660 for device nodes
|
||||
Patch3: libdrm-make-dri-perms-okay.patch
|
||||
# remove backwards compat not needed on Fedora
|
||||
@ -53,6 +55,7 @@ Utility programs for the kernel DRM interface. Will void your warranty.
|
||||
%prep
|
||||
#setup -q -n %{name}-%{gitdate}
|
||||
%setup -q
|
||||
%patch0 -p1 -b .tn
|
||||
%patch3 -p1 -b .forceperms
|
||||
%patch4 -p1 -b .no-bc
|
||||
%patch5 -p1 -b .check
|
||||
@ -133,6 +136,7 @@ done
|
||||
%{_includedir}/libdrm/drm_mode.h
|
||||
%{_includedir}/libdrm/drm_sarea.h
|
||||
%ifarch %{ix86} x86_64 ia64
|
||||
%{_includedir}/libdrm/intel_aub.h
|
||||
%{_includedir}/libdrm/intel_bufmgr.h
|
||||
%{_includedir}/libdrm/intel_debug.h
|
||||
%endif
|
||||
@ -165,6 +169,10 @@ done
|
||||
%{_libdir}/pkgconfig/libkms.pc
|
||||
|
||||
%changelog
|
||||
* Wed Mar 21 2012 Adam Jackson <ajax@redhat.com> 2.4.32-1
|
||||
- libdrm 2.4.32
|
||||
- libdrm-2.4.32-tn-surface.patch: Sync with git.
|
||||
|
||||
* Sat Feb 25 2012 Peter Robinson <pbrobinson@fedoraproject.org> 2.4.31-4
|
||||
- Add gem_ binaries to x86 only exclusion too
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user